Announcement

Collapse
No announcement yet.

[Community Project] WIP Weather & Ocean Water Shader

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Short Question

    When im gonna Package my GAME

    i get everytime an Error BECAUSE the OCEAN PLUGIN LIB; Cant be Opend, how i can Resolve it?

    Comment


      Had the same issue.

      I did has Zoc says and its working:

      Okay... Here we go, the super basic version tutorial:

      1) Download and install this: https://desktop.github.com/

      2) Open this page: https://github.com/TheZoc/OceanProject (this is my fork of the original project, with fixes that allows it to run in UE 4.14. I've already submitted a pull request - i.e.: update the main project with my changes)

      3) Click on the "Clone or Download" green button, on the right

      4) On the small pane that opens in Step 3, choose the option "Open in Desktop"

      5) Clone it (aka: download it) using the GitHub Desktop application downloaded on step 1

      6) Done, you have the latest project with UE4.14 fixes!

      Comment


        Originally posted by mike444 View Post
        tukor open in VS and comment the two lines that cause the crash and rebuild
        Ill try...is there a tuto for using the fish... or the boats? PLease

        Comment


          Not work on 4.15.preview 4, OceanPlugin Error

          Comment


            Packaging to Linux gives an error? I've installed the cross compile stuff.

            Comment


              Hey [MENTION=1127]TK-Master[/MENTION]. Absolutely stunning work.

              I have a couple of questions.

              - Can I download this and use it with my project by crediting you ?
              - Is there a list of complete features and caveats somewhere ?
              - Is there an instruction list on how to usethis on different maps ?
              - Does this project use (have to use) LPV ?
              - I take it that this "ocean entity" also provides physical attributes uniformly (bouyancy, drift etc..)
              - Can I contribute any way ?

              Thanks and keep up the great work.

              EDIT: Recompiled and packaged with 4.15. Works without problems.
              Last edited by TAN_; 02-19-2017, 02:26 PM.
              ArtStation

              General Development Blog

              Comment


                Any update for 4.15? I need the Skydome but don't have 4.12 installed.
                Last edited by IndieCrusader; 02-19-2017, 09:43 PM.
                Don't let your dreams be memes!
                https://youtu.be/5-sfG8BV8wU

                Comment


                  @ Omegahhh
                  what about your waves? What are your intentions with that?
                  [MENTION=7998]j[/MENTION]onathan who needs a market version for what?

                  Comment


                    Hey DotCam great project. You really saved my school project with this. I have a simple noob question if you all don't mind: What if you want to record a short gameplay scene with sequence recorder in ocean storm map ? What is the best way to adjust the ocean waves according to ManOWar's movements ? For example when you drive the ship in the first time and record it; it always plays the same animation, but waves are not in the same position (changes dynamically). Do I have to add the ocean into the sequencer to make waves and ship's movement synchronized ? I'm guessing there is a simple way to do this (as for built-in solution) but i don't know any other way from sequence recorder. Any help greatly appreciated.

                    edit: i've solved my issue. If any of you encounter something like this, forget sequence recorder it does not help. try tweaking render options in sequencer.
                    Last edited by finwefeanor; 02-28-2017, 05:52 AM.

                    Comment


                      This is great and i thank you.

                      But this thing is killing my frame rate... From 200 to around 100......

                      Comment


                        Originally posted by tukor View Post
                        This is great and i thank you.

                        But this thing is killing my frame rate... From 200 to around 100......
                        LOL yeah i lost at least 40-60 and im on a 64GB machine with 2x 1080GTX cards. Its super super heavy.
                        I see a "lite version" in the drop-down for the ocean types, but, its all jacked up. wonder if that may resolve the FPS loss
                        Founder and CEO of Angry Penguin Studio, LLC
                        Dallas, TX USA
                        https://www.facebook.com/AngryPenguinStudios

                        Comment


                          Does anyone have a recompiled fork for4.15 that they are willing to share. I would greatly appreciate it. I thank you all in advance. Great Plugin BTW.

                          Comment


                            UPDATE: If you see the error below reset your settings to default, I must have set something that caused this to happen, I am still trying to figure out what but it went away after the reset.



                            I am getting a new error with packaged version in either 64 or 32 bit. See image included. I do not see the issue when I am running in the editor, none of the warnings seem to indicate any trouble. It could be my values for the ocean or terrain or the rocks causing this it is hard to fix because I only see it running packaged - noeditor. Any help would be great! This is only happening in 4.15.


                            You can see the part of the ocean is missing on one side of the island, the other side works fine as expected. The Ocean animates and as it does this the trouble animates along with it. Again any help great appreciated!
                            Attached Files
                            Last edited by Vexar; 02-28-2017, 09:38 PM.
                            Victor "Vexar" Mercieca
                            Twitch Channel
                            Artstation
                            Youtube Channel

                            Comment


                              Originally posted by tukor View Post
                              This is great and i thank you.

                              But this thing is killing my frame rate... From 200 to around 100......
                              Yeah it is a total pig regarding memory and FPS it is why I think Epic should write a water system or buy this one and add it to the engine. This one has a lot of features but it is not finished or something I could use in a shipping product.
                              Victor "Vexar" Mercieca
                              Twitch Channel
                              Artstation
                              Youtube Channel

                              Comment


                                actually I think its by far the best water yet and as for performance considering all the features works well.

                                Does anyone here have version that works with ue 4.15? Please

                                Comment

                                Working...
                                X