Announcement

Collapse
No announcement yet.

[Community Project] WIP Weather & Ocean Water Shader

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Zoc View Post
    Without the error list and uproject file contents, it's harder to track the issue :/
    Click image for larger version

Name:	1.PNG
Views:	1
Size:	140.5 KB
ID:	1119780

    Click image for larger version

Name:	2.PNG
Views:	1
Size:	37.5 KB
ID:	1119781

    Click image for larger version

Name:	3.PNG
Views:	1
Size:	14.4 KB
ID:	1119782

    Click image for larger version

Name:	4.PNG
Views:	1
Size:	138.2 KB
ID:	1119783

    Click image for larger version

Name:	5.PNG
Views:	1
Size:	10.1 KB
ID:	1119784

    Click image for larger version

Name:	6.PNG
Views:	1
Size:	134.1 KB
ID:	1119785

    Click image for larger version

Name:	7.PNG
Views:	1
Size:	154.9 KB
ID:	1119786

    Click image for larger version

Name:	8.PNG
Views:	1
Size:	11.1 KB
ID:	1119787

    Click image for larger version

Name:	9.PNG
Views:	1
Size:	34.3 KB
ID:	1119788

    Click image for larger version

Name:	10.PNG
Views:	1
Size:	133.6 KB
ID:	1119789

    Click image for larger version

Name:	11.PNG
Views:	1
Size:	17.2 KB
ID:	1119790

    Click image for larger version

Name:	12.PNG
Views:	1
Size:	19.5 KB
ID:	1119791


    These are my mistakes, This is from the base project ( ocean project ) When importing my personal project happens the same
    Last edited by UnmeiNoAkaiito; 12-09-2016, 10:48 AM.

    Comment


      Originally posted by UnmeiNoAkaiito View Post
      These are my mistakes, This is from the base project ( ocean project ) When importing my personal project happens the same
      Well, the whole project is not required to use the plugin, and I advise you to check this link: https://github.com/UE4-OceanProject/...o-your-project

      Still... That made me do further inspections of the base project, since I didn't touch it in my PR.

      So, I made a new commit with these changes:

      Fixed errors and warnings
      - Changed M_Ocean_SSR Reflection Cubemap param from Color to Linear Color
      - Changed ThirdPersonCharacter GrabComponentAtLocation node with GrabComponentAtLocationWithRotation. Left the rotation data as default (0,0,0).
      - Deleted broken BP_SkyOLD (Replaced with BP_Skydome). Removed together auxiliary WB_SkyOLD_HUD debug widget.
      - Deleted Old versions of the ManOfWar meshes (they were messing up the build tool and weren't referenced anywhere)
      - Updated BP_Rivertool, replacing the deprecated functions
      - Replaced View.ViewSizeAndSceneTexelSize.xy with an external node in M_PP_RadialBlur
      You can find it here: https://github.com/TheZoc/OceanProject

      [MENTION=5439]DotCam[/MENTION] and [MENTION=1127]TK-Master[/MENTION], I haven't submitted a PR for this one, because the old one is still pending a merge. If you want to merge these, just tell me!
      (I'll submit a new PR after the previous one is accepted )
      Last edited by Zoc; 12-09-2016, 04:06 PM. Reason: grammar

      Comment


        Originally posted by Zoc View Post
        Well, the whole project is not required to use the plugin, and I advise you to check this link: https://github.com/UE4-OceanProject/...o-your-project

        Still... That made me do further inspections of the base project, since I didn't touch it in my PR.

        So, I made a new commit with these changes:



        You can find it here: https://github.com/TheZoc/OceanProject

        [MENTION=5439]DotCam[/MENTION] and [MENTION=1127]TK-Master[/MENTION], I haven't submitted a PR for this one, because the old one is still pending a merge. If you want to merge these, just tell me!
        (I'll submit a new PR after the previous one is accepted )
        thank you very much!

        Comment


          Originally posted by UnmeiNoAkaiito View Post
          thank you very much!
          Click image for larger version

Name:	1.PNG
Views:	1
Size:	23.6 KB
ID:	1119842

          Click image for larger version

Name:	2.PNG
Views:	1
Size:	11.9 KB
ID:	1119843

          Click image for larger version

Name:	3.PNG
Views:	1
Size:	197.6 KB
ID:	1119844

          Click image for larger version

Name:	4.PNG
Views:	1
Size:	228.6 KB
ID:	1119845

          Click image for larger version

Name:	5.PNG
Views:	1
Size:	13.0 KB
ID:	1119846

          Click image for larger version

Name:	6.PNG
Views:	1
Size:	74.6 KB
ID:	1119847

          New mistakes appeared (This is from the base project ocean project )

          Comment


            Originally posted by UnmeiNoAkaiito View Post
            New mistakes appeared (This is from the base project ocean project )
            I just tested, it's working here. Start from a fresh git clone.

            Also, check the link I posted in the previous reply.
            Attached Files

            Comment


              Click image for larger version

Name:	Capture22.JPG
Views:	1
Size:	22.7 KB
ID:	1119857

              I just get this every time I try to load the level. This is after downloading the 14.4 branch and putting the Plugin folder into the level folder.
              I really need to move on from 4.12.5 and this bloody thing has held me back for months. Can someone just tell us how to do it on a blueprint only project please?
              It's an awesome plugin and I'd hate to lose it
              thx

              Comment


                Originally posted by Zoc View Post
                I just tested, it's working here. Start from a fresh git clone.

                Also, check the link I posted in the previous reply.
                How do we 'start from a fresh git clone' please?

                Comment


                  Originally posted by dazuk1978 View Post
                  [ATTACH=CONFIG]120972[/ATTACH]
                  I just get this every time I try to load the level. This is after downloading the 14.4 branch and putting the Plugin folder into the level folder.
                  Man, you're not putting plugins into "level folder", but "project folder". I hope you just just incorrect word for project

                  Perhaps config file still points to some older version. Try this
                  1) Remove plugin folder.
                  2) Open .uproject file with text editor. Remove section of OceanPlugin.
                  3) Just put fresh plugin to your project. If plugin wouldn't detected automatically, just enable it in project settings. Editor should write fresh section to .uproject file.

                  Comment


                    Originally posted by Zoc View Post
                    I just tested, it's working here. Start from a fresh git clone.

                    Also, check the link I posted in the previous reply.

                    Click image for larger version

Name:	1.PNG
Views:	1
Size:	65.4 KB
ID:	1119868

                    Click image for larger version

Name:	2 xD.PNG
Views:	1
Size:	43.4 KB
ID:	1119869

                    I used the link that sent me, Import to my main project as the page specifies it And this happened this time

                    Comment


                      Originally posted by UnmeiNoAkaiito View Post

                      [ATTACH=CONFIG]120996[/ATTACH]

                      I used the link that sent me, Import to my main project as the page specifies it And this happened this time
                      This is not a big problem. Just create an empty folder and this Warning will go away.

                      Originally posted by UnmeiNoAkaiito View Post
                      [ATTACH=CONFIG]120993[/ATTACH]
                      You will need to look at your log file to see what's wrong and fix the build.

                      Comment


                        little help here ...

                        using 4.14.1 github UE
                        pulled the "4.12" version of the ocean plugin (the latest branch is listed as 4.12)
                        copy: plugins to plugins and ../content/ocean
                        refuses to build for some reason. As soon as i launch solution to load the editor (my project) it complains the entire time about the plugin (the .dll in the binary folder)
                        little help on getting this thing installed properly? Im sure its on my end with me not knowing 100% what im pulling. I guess i got used to selecting my build, repssing download ZIP and using that ... since there is no option for that, im a little confused.

                        thanks!
                        Founder and CEO of Angry Penguin Studio, LLC
                        Dallas, TX USA
                        https://www.facebook.com/AngryPenguinStudios

                        Comment


                          Originally posted by Zoc View Post
                          This is not a big problem. Just create an empty folder and this Warning will go away.



                          You will need to look at your log file to see what's wrong and fix the build.


                          In which route? Could you give an example please

                          Comment


                            Someday the plugin to upload to the marketplace? It would be easier to handle

                            Comment


                              Hey everyone! First and foresmost thank you for this amazing piece of shader, phenomenal effort!
                              Now for my question. How is it that in my project the transition point of the water looks so awkward and discolored? it's like the closeup water has more color than it should. It appears as a full circle. If you tilt the camera to look straight down and move up. Eventually it becomes smaller as you move up and dissapears at a great distance.

                              Something to do with some mid range shader stuff?
                              Thankful for any help regarding this issue.

                              EDIT: I've come to the conclusion it is somehow connected to lighting. As it can be seen in daytime and not at night. (rotating SunLight) - DirectionalLight. It also goes away if I tune the intensity of the light down to 0.
                              Will experiment some more.

                              (Running 4.13.2)
                              Click image for larger version

Name:	AwkwardTransit.png
Views:	1
Size:	908.8 KB
ID:	1119955
                              Last edited by Mireneye; 12-13-2016, 03:16 PM.

                              Comment


                                For 4.14 version the galleon lost its camera function... now the camera goes to the sky instead of circling the player when on sailing mode. How can I fix that?

                                Comment

                                Working...
                                X