Announcement

Collapse
No announcement yet.

[Community Project] WIP Weather & Ocean Water Shader

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Does anyone know where in the BP_Sky or its parent TimeManager.h have the hard cutoff for when the sun disappears and the night sky comes out. It doesn't work well for high latitudes, it should be based off of the suns altitude and not the time but I cannot seem to find where this is set up.

    Maybe it's a skysphere thing?

    Anyone know about this part?

    Comment


      Originally posted by Vexar View Post
      The only trouble I have had in 4.14 related to the Ocean plugin is that Epic changed something in the camera code that clips the reflection of the Ocean making it look black in PIE when you tilt the camera up or down but this goes away as soon as you run the same exact thing in Full Screen mode. I have to investigate which switch or adjustment is needed to make this go away. At first I thought it was something wrong with the plug in but it has something to do with a Camera code change. For now I just switch to Full screen. This did not happen in 4.12.5 with exact same scene.
      It looks fine here o.O

      Comment


        Anyone have the 4.14 download?
        I am having trouble with the pull
        Founder and CEO of Angry Penguin Studio, LLC
        Dallas, TX USA
        https://www.facebook.com/AngryPenguinStudios

        Comment


          hi all,do you know, if they are going to release 4.14 version?

          Comment


            Originally posted by Zoc View Post
            It looks fine here o.O
            I dont know what it is, but with out any changes I do not see it in 4.12.5, so I am pretty sure it is something I did in a "setting" that is causing it. It does not happen in the Ocean Demo levels. It only happens when the window is smaller, and not full screen on my own level.

            I will show you with screen shots in a future update.

            Update: Well I made a screen shot to show the trouble I am having with 4.14 this happens during Playing in Editor Only. Traversing the level in editing mode has no visual issues.






            UPDATE 2: FIXED the trouble
            After investigating the Planer Reflection component of the Ocean system I found a setting named Extra FOV the number was set to 0, I changed it 65 same as my camera setup as a test and it was fixed! Looks better then ever. I know it increases the rendering time overhead so I am going to try to reduce / tune this value. Maybe this value is a new feature for 4.14. I have not double checked to see if this option is in 4.12.5. I am happy I found it though!
            Attached Files
            Last edited by Vexar; 12-01-2016, 08:04 PM.
            Victor "Vexar" Mercieca
            Twitch Channel
            Artstation
            Youtube Channel

            Comment


              A lot missing for the new plugin?

              Comment


                is there a working fork avail?
                i was using the 4.14 fork (by Zoc i think) and i started getting 40+ errors in a compile from the plugin itelf.
                Founder and CEO of Angry Penguin Studio, LLC
                Dallas, TX USA
                https://www.facebook.com/AngryPenguinStudios

                Comment


                  how to run the shader????

                  Originally posted by DotCam View Post
                  A quick update on my shader, I haven't been able to work on it as much as I'd like, but finally have a new video update. I have managed to switch over to a translucent material, due to the wave heights overlapping I was encountering an issue with translucent depth sorting causing issues, but have that under control now. I have also moved all of the material parameters into a blueprint so everything can be controlled in one place. Still need to add in many more features, but translucency with proper depth shading was not as simple as I expected.

                  Could someone tell me how to run the shader??

                  Comment


                    Originally posted by Angrytoilet View Post
                    is there a working fork avail?
                    i was using the 4.14 fork (by Zoc i think) and i started getting 40+ errors in a compile from the plugin itelf.
                    Did you get it from here? https://github.com/TheZoc/OceanProject.git

                    Would you mind trying again and making sure your UE4 version is 4.14, and report the errors back here, together with your uproject file contents?

                    Comment


                      Originally posted by Zoc View Post
                      Did you get it from here? https://github.com/TheZoc/OceanProject.git

                      Would you mind trying again and making sure your UE4 version is 4.14, and report the errors back here, together with your uproject file contents?
                      I have the same problems

                      Comment


                        Going to be testing 4.14.1 with Zoc changes, I will update and see if it is working.

                        Update1: Tested and working with 4.14.1 - Thanks Zoc.
                        http://i.imgur.com/GdNyT4u.png
                        Attached Files
                        Last edited by Vexar; 12-09-2016, 03:06 AM.
                        Victor "Vexar" Mercieca
                        Twitch Channel
                        Artstation
                        Youtube Channel

                        Comment


                          Originally posted by UnmeiNoAkaiito View Post
                          I have the same problems
                          Without the error list and uproject file contents, it's harder to track the issue :/

                          Comment


                            Originally posted by Zoc View Post
                            Without the error list and uproject file contents, it's harder to track the issue :/
                            Click image for larger version

Name:	1.PNG
Views:	1
Size:	140.5 KB
ID:	1119780

                            Click image for larger version

Name:	2.PNG
Views:	1
Size:	37.5 KB
ID:	1119781

                            Click image for larger version

Name:	3.PNG
Views:	1
Size:	14.4 KB
ID:	1119782

                            Click image for larger version

Name:	4.PNG
Views:	1
Size:	138.2 KB
ID:	1119783

                            Click image for larger version

Name:	5.PNG
Views:	1
Size:	10.1 KB
ID:	1119784

                            Click image for larger version

Name:	6.PNG
Views:	1
Size:	134.1 KB
ID:	1119785

                            Click image for larger version

Name:	7.PNG
Views:	1
Size:	154.9 KB
ID:	1119786

                            Click image for larger version

Name:	8.PNG
Views:	1
Size:	11.1 KB
ID:	1119787

                            Click image for larger version

Name:	9.PNG
Views:	1
Size:	34.3 KB
ID:	1119788

                            Click image for larger version

Name:	10.PNG
Views:	1
Size:	133.6 KB
ID:	1119789

                            Click image for larger version

Name:	11.PNG
Views:	1
Size:	17.2 KB
ID:	1119790

                            Click image for larger version

Name:	12.PNG
Views:	1
Size:	19.5 KB
ID:	1119791


                            These are my mistakes, This is from the base project ( ocean project ) When importing my personal project happens the same
                            Last edited by UnmeiNoAkaiito; 12-09-2016, 10:48 AM.

                            Comment


                              Originally posted by UnmeiNoAkaiito View Post
                              These are my mistakes, This is from the base project ( ocean project ) When importing my personal project happens the same
                              Well, the whole project is not required to use the plugin, and I advise you to check this link: https://github.com/UE4-OceanProject/...o-your-project

                              Still... That made me do further inspections of the base project, since I didn't touch it in my PR.

                              So, I made a new commit with these changes:

                              Fixed errors and warnings
                              - Changed M_Ocean_SSR Reflection Cubemap param from Color to Linear Color
                              - Changed ThirdPersonCharacter GrabComponentAtLocation node with GrabComponentAtLocationWithRotation. Left the rotation data as default (0,0,0).
                              - Deleted broken BP_SkyOLD (Replaced with BP_Skydome). Removed together auxiliary WB_SkyOLD_HUD debug widget.
                              - Deleted Old versions of the ManOfWar meshes (they were messing up the build tool and weren't referenced anywhere)
                              - Updated BP_Rivertool, replacing the deprecated functions
                              - Replaced View.ViewSizeAndSceneTexelSize.xy with an external node in M_PP_RadialBlur
                              You can find it here: https://github.com/TheZoc/OceanProject

                              [MENTION=5439]DotCam[/MENTION] and [MENTION=1127]TK-Master[/MENTION], I haven't submitted a PR for this one, because the old one is still pending a merge. If you want to merge these, just tell me!
                              (I'll submit a new PR after the previous one is accepted )
                              Last edited by Zoc; 12-09-2016, 04:06 PM. Reason: grammar

                              Comment


                                Originally posted by Zoc View Post
                                Well, the whole project is not required to use the plugin, and I advise you to check this link: https://github.com/UE4-OceanProject/...o-your-project

                                Still... That made me do further inspections of the base project, since I didn't touch it in my PR.

                                So, I made a new commit with these changes:



                                You can find it here: https://github.com/TheZoc/OceanProject

                                [MENTION=5439]DotCam[/MENTION] and [MENTION=1127]TK-Master[/MENTION], I haven't submitted a PR for this one, because the old one is still pending a merge. If you want to merge these, just tell me!
                                (I'll submit a new PR after the previous one is accepted )
                                thank you very much!

                                Comment

                                Working...
                                X