Announcement

Collapse
No announcement yet.

m2u interactive sync script for Maya -> UE4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Yes, python is supposed to be case-sensitive. The files should have been lowercased according to the changes in code. I didn't get the same problem on my system, because there are still lowercased .pyc files (compiled python), while the originals have been reverted to uppercase. Probably a problem of windows and git disagreeing on the case-ness of a file. I will remember to fix the naming of these files in the repository. Thx!

    The problem of compiling in 4.14. Yes, deleting or commenting the line in question is ok. The correct solution takes a lot more time though, because I don't want to (again) adapt the changes of the asset import code, but instead only detect for .fbx import and then call upon the m2uFbxFactory, while delegating all other assets to the original code. But as far as I remember, that's not so simple. There has to be a reason for the current hacky solution.
    Deprecation warnings can be ignored until the next minor version increase (4.15)


    [MENTION=3956]James Barnette[/MENTION]: Do you have any suggestions on how to improve the maya instructions? The current readme https://github.com/m2u/m2u/blob/develop/README.md contains step-by-step instructions with links to official documentations where appropriate. Anything in particular that is unclear?

    Comment


      Hello, alfalfasprossen and other Unreal enthusiast

      I am a freelance 3d environment artist and I would like to try your m2U plugin but I am not a tech artist or coder.
      I have visual studio and manage to clone the directory.
      I am getting an error about the dll (missing or built with a different engine) I am using 4.13.2 ( is that the issue and I can only use 4.13.0 ?)

      I created a c++ project that point in a folder and all the data managed to be built in it with the dll.
      But when I launch again the project I am getting the error about the DLL.

      can anyone help me...I wish a video would explain the install.

      Thanks

      Julien Lefebvre

      https://jlef.artstation.com/

      Comment


        4.13.2 should be fine. Incompatibility between the built plugin dll and a project shouldn't occur when building both with the same engine. Did you compile the pluing with the engine or with your project? (Did you clone the Engine or did you put the plugin code into a project that just uses the installed engine). If you've upgraded the engine version inbetween builds, try to use the 'clean solution' option from visual studio to make sure no outdated binaries are lying around.

        Comment


          Really interesting tools ! I think watch how to work with it.
          Portfolio Art Station

          Comment


            does this support 4.16?

            Comment


              I have this error: Cannot open include file: 'fbxsdk.h': No such file or directory
              I tried to compile with the project and with the engine. With the project at least recognice the plugin (it doesn't work) but with the engine anything happen. I fixed the files for 4.17 but there are something bad still.

              Comment


                Curious if anyone could kindly provide ideas or instructions for updating this in newer Engine versions?
                I have tried adding the plugin to my Engine/Plugins folder and then Generating visual studio project files on a C++ UE4 project, but I get the following errors:

                Running D:/Epic Games/UE_4.19/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="G:/bluenonagon/ue4/m2u/m2u.uproject" -game -rocket -progress
                Discovering modules, targets and source code for project...
                While compiling D:\Epic Games\UE_4.19\Engine\Intermediate\Build\BuildRules\UE4Rules.dll:
                ERROR: d:\Epic Games\UE_4.19\Engine\Plugins\m2uUE4Plugin\Source\m2uPlugin\m2uPlugin.Build.cs(7,10) : error CS1729: 'UnrealBuildTool.ModuleRules' does not contain a constructor that takes 0 arguments
                ERROR: d:\Epic Games\UE_4.19\Engine\Plugins\m2uUE4Plugin\Source\m2uPlugin\m2uPlugin.Build.cs(30,4) : error CS0103: The name 'AddThirdPartyPrivateStaticDependencies' does not exist in the current context
                ERROR: UnrealBuildTool Exception: Unable to compile source files.

                Comment


                  Noticed that the 3dsMax code on Github was deprecated as it was never really implemented. Was wondering if I can get some pointers on how I can implement this myself? I am trying to optimize the exporting-importing progress workflow with 3dsMax to UE4. In the meantime I am going to hopefully get this installed to see how it works and be doing research on it.

                  Comment


                    I was wondering if this project is still active, we're up to 4.22 as of writing this, and I'm very hopeful about this project.

                    Comment

                    Working...
                    X