Announcement

Collapse
No announcement yet.

[PLUGIN] Adventure Kit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    FTC responded to my question about tight spaces on the Marketplace question thread. Regarding the tight spaces, something was not working right, and it's been fixed, an update was submitted, should be live soon.

    Regarding the snapping locations (did I see you asking about this in the Marketplace question space too?) - I wonder... if you set up your character to use a key binding to allow "entering" a zone, rather than the default auto-enter, if that might work for you. FTC has a video up on how to do this, which I now have mine set up as. I didn't like my character simply entering the zones when passing by, wanted it to be a manual thing only when wanted - nothing like grabbing a wall or a ledge as you're running and gunning to ruin your day. Point is, having to press a key to enter a zone, requires you create "can enter" logic, which might invoke the zone to work for you, rather than snapping which seems like the zone isn't being "entered".

    Very curious if you get ALS working properly, I'd like to do the same thing, but anticipated problems with the movement modes between the two assets, just as you're experiencing, and decided not to take on that particular challenge. Best luck resolving it, I might do it myself if I know there's been a success story.

    Leave a comment:


  • replied
    FTC

    I've been trying to get this to work with ALSV3 thinking it was something in that project that wasn't working with the Adventure Kit. After trying a fresh Third Person project I'm having the same issues with the character only snapping to locations instead of using the montages, getting stuck in jump state when entering a ledge from jumping, unable to go up/down on ladder etc. Can you offer any assistance?

    Leave a comment:


  • replied
    Having trouble with tight spaces - using even the sample character straight from the kit - the character gets stuck at the end of the zone. Thus, stuck in the zone. Can't seem to find a way to fix this. Any ideas anyone? Anyone else having this problem?

    This has been a problem with engine versions since at least 4.19, and up through 4.23.

    The problem doesn't occur with a fresh project, but after opening and closing a few times, sure enough, it starts again, more or less making it so tight spaces can't be utilized.

    Any help appreciated! Thanks.

    Leave a comment:


  • replied
    It is working now but I developed my own system. I was using only a handful features from the Adventure Kit so I rather developed my own stuff, so I have a full control of things. It took me a month but it was worth it.

    Leave a comment:


  • replied
    Hello Sir Edlin

    I have tested the examples map on my end and haven't come across a problem. Is a specific zone more prone to problems? Does it happen in the example project or in your project?

    Kind Regards

    Leave a comment:


  • replied
    Hi,

    the latest version of Advenutre-Kit from Github for Unreal Engine 4.23 compiles fine but it does not work properly while playing. Movement in zones does not work properly. The characters are stuck or they move erratically. Can you please check.

    Leave a comment:


  • replied
    Originally posted by hitoArtiGames View Post
    Hello! I was following the integration tutorial and when I got to the 3rd video where he implements the ledge jump... I can't make it work.

    It's worth mentioning that when I created the ledge zones... they never connect to each other no matter how close I put them to each other ... so I tried the demo map that comes with the feature pack. I see two ledges connected and when I use my character it can't ledge jump but when I use the premade character from the AdvKit ... the ledge jump works normally.

    My character is based on a custom C++ Character class... so I had to make my Character class inherit from the AdvKitCharacter C++ class. I made sure that all the unreal functions call their parent function.

    Can you please help me with this? Is there something I'm doing wrong?

    SOLVED IT! Turns out that in my Custom character constructor method I create the capsule component when the AdvKitCharacter already does that... so I removed that line and it works!

    Leave a comment:


  • replied
    Hello! I was following the integration tutorial and when I got to the 3rd video where he implements the ledge jump... I can't make it work.

    It's worth mentioning that when I created the ledge zones... they never connect to each other no matter how close I put them to each other ... so I tried the demo map that comes with the feature pack. I see two ledges connected and when I use my character it can't ledge jump but when I use the premade character from the AdvKit ... the ledge jump works normally.

    My character is based on a custom C++ Character class... so I had to make my Character class inherit from the AdvKitCharacter C++ class. I made sure that all the unreal functions call their parent function.

    Can you please help me with this? Is there something I'm doing wrong?

    Leave a comment:


  • replied
    Hello!

    Don't know if the thread is still active, but I have a problem with the wall walking...
    When I use the Set Orientation Node, if I put any value in X, the Camera will be tilted in a vanilla project ( and in mine, even the character will be tilted )
    Is it normal? Can I work around it?

    Leave a comment:


  • replied
    hi i've got a issue , i've juste by this plugin and installed iit in a 4.21 version of the engine then i got to the folder UE_Install_Dir/4.XX/Engine/Plugins/Marketplace/AdvKitPlugin ( like it's say in the setup on the github) lanche the install.bat and i get only somme ERREUR 3 (0x00000003) saying thatt it can't find the additionalcontent folder ( tahnt doesn't existe at all ) .

    Leave a comment:


  • replied
    Ouahhh, i will try the demo before buy it but it looks amazing !

    Leave a comment:


  • replied
    Sir Edlin could you please show how build the c++ proyect, couse im lost, and just install visual studio but "build" it´s a little bit confused, and i see some videos but i can´t get it, i get missing modules, or built with a different version: AdvKitRuntime and advKitEditor, they say would you like to rebuild them? i say yes, and i have a m: try to rebuilding from souce manually, im lost

    Leave a comment:


  • replied
    Originally posted by TI-Morelos View Post

    How do I install the plugin for 4.21? Please help
    It is simple. Create the 4.21 C++ project. Copy AdvKitPlugin into that C++ project under Plugins folder. Edit AdvKitPlugin.uplugin and change "EngineVersion": "4.21.0". Then start Visual Studio and build the C++ project. After that you will get built plugin under AdvKitPlugin folder. Then you can copy AdvKitPlugin to any project that you want. Do not forget to enable the plugin in your project under menu EDIT->Plugins.

    Leave a comment:


  • replied
    Originally posted by Sir Edlin View Post
    Hi Pascal,

    can you please update compatibility to 4.21. The plugin compiles fine and it would be nice that people know it is possible to use it with the latest version of Unreal Engine.

    Thank you for your support and best regards!
    How do I install the plugin for 4.21? Please help

    Leave a comment:


  • replied
    Hi Pascal,

    can you please update compatibility to 4.21. The plugin compiles fine and it would be nice that people know it is possible to use it with the latest version of Unreal Engine.

    Thank you for your support and best regards!

    Leave a comment:

Working...
X