Announcement

Collapse
No announcement yet.

BLUI Open Source HTML5/JS/CSS HUD/UI

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Anyone else using BLUI with UE 4.14? When starting a packaged game it takes about a minute before even the splash screen shows up if BLUI is included in the project. If I remove BLUI everything starts as expected, i.e. the splash appears after a few seconds. I am not quite sure how to debug this either, cause the delay happens before the logging is initialized. So I suspect it's something that happens when the engine loads the plugin or something with loading CEF, but I'm just guessing. (I'm skipping from 4.11 to 4.14 so I am not sure how it behaves in 4.12 and 4.13)

    Comment


      Originally posted by C.Hallqvist View Post
      Anyone else using BLUI with UE 4.14? When starting a packaged game it takes about a minute before even the splash screen shows up if BLUI is included in the project. If I remove BLUI everything starts as expected, i.e. the splash appears after a few seconds. I am not quite sure how to debug this either, cause the delay happens before the logging is initialized. So I suspect it's something that happens when the engine loads the plugin or something with loading CEF, but I'm just guessing. (I'm skipping from 4.11 to 4.14 so I am not sure how it behaves in 4.12 and 4.13)
      Seems to start in UE 4.12, in 4.11 the splash appears after a couple of seconds but in 4.12, 4.13 and 4.14 it takes a minute before the splash appears.

      Comment


        How can you activate pepper flash module?

        Comment


          Hi! Does this work on UE4 4.13?

          Comment


            Originally posted by CodyKnight View Post
            Hi! Does this work on UE4 4.13?
            yes it does

            Comment


              Onlinesub missing ?

              Comment


                Hi, I Try Build the last release and i Receive this error... Why???

                libcef_dll_wrapper.lib(frame_ctocpp.obj) : error LNK2038: mismatch detected for '_MSC_VER': value '1800' doesn't match value '1900' in Module.Blu.cpp.obj

                Comment


                  Hey,

                  Got a few questions about Blui -

                  1. Does this work with 4.14.3? It looks like the Plugin has not been updated for a while. :\
                  2. Does anyone have any advice on what to use for a "Designer" tool? Adobe Edge animate is dead and Tumult Hype is Mac only.

                  Comment


                    Hi fellow blui users. I've been using my plugin build for many versions now - and I know it's glitchy, especially with the 1 min delay on startup with packaged projects. Does anyone have a link to a GitHub fork which is current, and also contains a working, current version of CEF - even better - a version of CEF which is built with the flag set that allows media codecs that aren't just the open source codecs? Many thanks in advance!

                    Comment


                      Hi, delay 1Min when Package in Log show this message

                      ERROR:tcp_socket_win.cc(361)] bind() returned an error: Only one usage of each socket address (protocol/network address/port) is normally permitted.
                      This error in CEF??? CEF in GitHub BLUI project not Updated???

                      Comment


                        Is this plugin compatible with Unreal Engine 4.14.3? I'm using the 3.1 release from the Github page but Unreal keeps telling me the plugin is incompatible when I go to load. :/ Any ideas?
                        Smart Ping System | Simple Icon System | Low Poly Weapons Armory | Nocturnal Arts

                        Comment


                          Guys hello, does this plugin still work on 4.15? Is something special I need to do in order to make it work?

                          Comment


                            I have this message error : "Missing or incompatible modules in BLUI plugin - would you like to disable it?"
                            Maybe it's not compatible or maybe it's my fault.

                            Someone have an idea please ?

                            Comment


                              Originally posted by MangeDesChips View Post
                              I have this message error : "Missing or incompatible modules in BLUI plugin - would you like to disable it?"
                              Maybe it's not compatible or maybe it's my fault.

                              Someone have an idea please ?
                              I have the same problem, any fix?

                              Comment


                                Hi all.. Just had successfully integrate and ran BLUI ExampleHUD on UE4 3.14.
                                Web page is rendered on the viewport nicely
                                A quick question on the functionality. Is it possible to render the HTML content to mesh.
                                If its possible can anyone show a BluePrint screenshot on how to attain such capability?

                                Greatly appreciate any help on this.
                                Thank you

                                Comment

                                Working...
                                X