Announcement

Collapse
No announcement yet.

BLUI Open Source HTML5/JS/CSS HUD/UI

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can this work in VR?

    Comment


      Originally posted by Priximan View Post
      Thanks Alex for this suggestion!
      I was able to get the mouse click working, just had to convert the mouse position to widget local coordinates, after that it was working but the keyboard input was not working, will try that "set input mode".
      This works fine in 4.8 but doesn't work in 4.9 . When we click on the widget we cannot return to the mode Game, in 4.9 we are blocked in UI Mode. Maybe due to the release of the keybords events ..

      Thanks a lot for this plugins it is wonderfull !

      Comment


        Originally posted by Dryfter View Post
        How did you get it to work in 4.9? I just tried a few times to simply activate it and I keep receiving a "missing or incompatible modules in BLUI plugin" and I have to disable it or the editor aborts start-up. Probably something obvious but I can't find it...
        You downloaded a release build and added it to your project's plugins folder correct?

        HTML/CSS/JS Powered UI - Free

        Comment


          Originally posted by Lobohotpants View Post
          Can this work in VR?
          Yes, but keep in mind the dual cameras needed.

          HTML/CSS/JS Powered UI - Free

          Comment


            Originally posted by AaronShea View Post
            You downloaded a release build and added it to your project's plugins folder correct?
            I Have the same problem in 4.9 but in 4.8 all work fine

            Comment


              Any error messages will help in trying to figure out what's going on.
              Post screenshots etc.
              Thanks!

              HTML/CSS/JS Powered UI - Free

              Comment


                I will probably make a video to show this issue

                Comment


                  Originally posted by Lobohotpants View Post
                  Can this work in VR?
                  Got BLUI working in VR for the LeapJam along with some UMG hacks, say hello your new air-touch internet



                  Grab the experience here.


                  @AaronShea Thanks for an awesome plugin, its really powerful! I'll be making a pull request later on with some more functions exposed.

                  I've got a question, when I tried to compile BLUI for 4.10 its giving me lots of

                  Code:
                   error LNK2038: mismatch detected for '_MSC_VER': value '1800' doesn't match value '1900' in BluPrivatePCH.h.obj
                  any idea where we can find or compile VS 1900 dlls that would be compatible?
                  Plugins: GES - Node.js - TensorFlow - Socket.io Client - ZipUtility - Leap Motion - Hydra - Myo

                  Comment


                    Amazing stuff you got! II await your pull!
                    As for the errors, that comes from vs2015 and CEF not being compiled with the new VS version. I'm on that now!

                    HTML/CSS/JS Powered UI - Free

                    Comment


                      BLUI now works with Visual Studio 2015 and UE4.10

                      Release 3.1 has a new download for VS2015 users. As a reminder, 2015 will be the primary supported version from now on. No more VS2013!

                      https://github.com/AaronShea/BLUI/releases/tag/3.1

                      HTML/CSS/JS Powered UI - Free

                      Comment


                        Originally posted by AaronShea View Post
                        BLUI now works with Visual Studio 2015 and UE4.10

                        Release 3.1 has a new download for VS2015 users. As a reminder, 2015 will be the primary supported version from now on. No more VS2013!

                        https://github.com/AaronShea/BLUI/releases/tag/3.1
                        Awesome stuff! Will test 4.10 when I get home today.
                        Plugins: GES - Node.js - TensorFlow - Socket.io Client - ZipUtility - Leap Motion - Hydra - Myo

                        Comment


                          I can't get the 4.10 working on the new update for 3.1. I can't see to see the page loading as I checking my debug page. I see the log blank. Plus I need to know the new right setup for the blue prints.

                          ---
                          update.

                          I did try both version and it didn't work for 4.10 on my project build.
                          I did try to 4.9 version and it work on the vs2013. But not the new VS2015 that didn't work.
                          Last edited by Lightnet; 11-17-2015, 02:28 AM.

                          Comment


                            Evening all!

                            Aaron, the rcent update for 4.10 is working like a charm!

                            I do have some questions for anyone that might have an answer. I've attached some images to help show what I"m talking about but I just can not clear up the end render from the webview. I think it has to do with that the widget has to be scaled down and the bitmap texture that is rendered is then of course scaled. This is just a guess for even the actual size before scaling is a bit more blur than one would think it would be.

                            The actual size image is when the widget is not scaled. The other two are just samples and the webview capture is a direct screen from chrome. It wouldn't be so bad but the text is so muddy, even up close. If this was just an image it could be sharp and crisp so I'm not sure if I'm doing something wrong or if the plugin code needs to be dug into by one of my team members. I thought to ask here first before having one of them put time into things.

                            The UI is 1820x2435 and has to have a scale of .029 to get it the right sizing. Oh and I did enable the gpu setting in the blui settings file.

                            Thanks again!

                            -Aricwithana
                            Attached Files

                            Comment


                              I am new to all of this stuff but have been working with someone who knows blueprints. My game needs to have videos inside it much like what you are doing where the character can go up to a screen and watch a video. This can be through videos as part of the game or through my youtube channel. We have tried the media assets with little success as the sound does not easily match up so I then came across Coherent-labs UI but now I have found what you are doing. This looks like amazing stuff and I want to know if you can have it play through youtube with sound?

                              Also my project is blueprint only so does this work with just blueprints? Are there people on the forums I could pay to have this setup for me? Any information would be awesome. Thanks

                              Comment


                                Hi, I'm trying to get the transparency to work od 4.10, using the demo (i got the material and DisplayUI blueprint to work). It's all fine and with no errors, apart from the alpha not working on elements on website. I've got the widget set to 3d, it might be the problem.

                                Anyway, there's one DIV with background-color: rgba(0,0,0,0.5); and it shows as black on transparent page background. I've also tried a background made of 1x1px white png with 50% alpha, and it looked like 128/128/128 gray material.

                                It might be the 3d widget part, the material being setup wrongly or something changed in 4.10 - or I'm just missing something, since the example project cannot be opened in 4.10 :P

                                Comment

                                Working...
                                X