Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by sudey View Post

    Why when allow static light is disconnected, in case of switching on of vxgi 2.0, the engine crash? Почему когда отключен allow static light, при включении vxgi 2.0, движок крашется?
    Fixed. Исправлено.

    Leave a comment:


  • replied
    Originally posted by sudey View Post

    Why when allow static light is disconnected, in case of switching on of vxgi 2.0, the engine crash?
    I noticed this as well. If you disable static lighting from project settings and enable VXGI, engine will crash immediately on VxgiRendering.cpp while trying to read nonexisting SceneContext.GBufferE.
    Last edited by 0lento; 04-26-2018, 10:51 AM.

    Leave a comment:


  • replied
    Originally posted by Alexey.Panteleev View Post

    I just went ahead and ported the TXAA integration to 4.19 and fixed the crash on viewport resize. It's not perfect (e.g. I expect the dynamic resolution feature will not work properly yet), but it's better than before.

    To make sure that you're using TXAA and not built-in TAA, do something to break it, for example set r.TXAA.EnableColorClipping to 0 and observe trailing artifacts when moving the camera.
    Thank you, I'll check the new branch

    Leave a comment:


  • replied
    Originally posted by Alexey.Panteleev View Post

    I just went ahead and ported the TXAA integration to 4.19 and fixed the crash on viewport resize. It's not perfect (e.g. I expect the dynamic resolution feature will not work properly yet), but it's better than before.

    To make sure that you're using TXAA and not built-in TAA, do something to break it, for example set r.TXAA.EnableColorClipping to 0 and observe trailing artifacts when moving the camera.
    Why when allow static light is disconnected, in case of switching on of vxgi 2.0, the engine crash? Почему когда отключен allow static light, при включении vxgi 2.0, движок крашется?

    Leave a comment:


  • replied
    Alexey.Panteleev

    Hey while you are here I have question.

    Did you considered optimizing Voxelization pass to not happen every frame ? Ie. do not revoxelize static objects, voxelize further cascades less often (every N frames). Etc ?

    On complex scenes consistently even on 1080ti Voxelization pass is most time consuming. It would do wonders to make VXGI more scalable to lower end hardware.

    Leave a comment:


  • replied
    Originally posted by Alexey.Panteleev View Post

    Ok, I'll ping the author of that branch (or take a look at it myself).
    I just went ahead and ported the TXAA integration to 4.19 and fixed the crash on viewport resize. It's not perfect (e.g. I expect the dynamic resolution feature will not work properly yet), but it's better than before.

    To make sure that you're using TXAA and not built-in TAA, do something to break it, for example set r.TXAA.EnableColorClipping to 0 and observe trailing artifacts when moving the camera.

    Leave a comment:


  • replied
    Originally posted by Alexey.Panteleev View Post
    Hi everyone,

    UE 4.19 branch with VXGI 2.0 is up on GitHub: https://github.com/NvPhysX/UnrealEngine/tree/VXGI2-4.19

    I'll try to answer your questions about it here.
    THAT TIMING, THOUGH!! *dies happily*

    Leave a comment:


  • replied
    Originally posted by 0lento View Post
    I'd also love to get some NVIDIA staff response on what's going on with the TXAA's UE4 integration. They also seem to neglect the issue thread on the repo about it. I could never get it to work (it compiles but it looks 100% same as Unreals built-in TAA, I have exactly same ghosting with it so it's safe to say it's not really running on TXAA). The branch on TXAA is also pretty old (based on 4.16) and it has some issues, like if you resize the viewport in editor it will just crash right away.
    Ok, I'll ping the author of that branch (or take a look at it myself).

    Leave a comment:


  • replied
    I'd also love to get some NVIDIA staff response on what's going on with the TXAA's UE4 integration. They also seem to neglect the issue thread on the repo about it. I could never get it to work (it compiles but it looks 100% same as Unreals built-in TAA, I have exactly same ghosting with it so it's safe to say it's not really running on TXAA). The branch on TXAA is also pretty old (based on 4.16) and it has some issues, like if you resize the viewport in editor it will just crash right away.

    Leave a comment:


  • replied
    They've updated Flow for 4.19 as well: https://github.com/NvPhysX/UnrealEng...ee/NvFlow-4.19

    Leave a comment:

Working...
X