Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by 0lento View Post
    Gomo was that some example map? If so, which one? I tried TXAA with some but not all. Also was this on recent version of my repo? There was issue with TXAA before that it crashed on forward shading enabled, this has been fixed a while ago on official TXAA branch and I've mirrored the changed to my branch so that shouldn't happen anymore.
    0lento - It was on my test map.
    I believe it is not your recent revision - I see I downloaded it on 30th of April.
    I have forward shading disabled, but this project was initially set for mobile but then I've changed a lot of settings to be sure VXGI will show up (for some reason I had problem with that) so maybe it was some random rendering setting.

    Leave a comment:


  • replied
    Originally posted by 0lento View Post
    Gomo was that some example map? If so, which one? I tried TXAA with some but not all. Also was this on recent version of my repo? There was issue with TXAA before that it crashed on forward shading enabled, this has been fixed a while ago on official TXAA branch and I've mirrored the changed to my branch so that shouldn't happen anymore.
    Yes, I seem to have encountered several [Line:133] errors when I use the engine, but I don't record the details, and then the engine will collapse and disappear. At first I didn't notice, but later I found that Epic's 4.192 does not exist. It seems that it appears in Gameworks?

    Leave a comment:


  • replied
    Originally posted by Gomo View Post
    I've got this crash when opening map:
    Assertion failed: IsViewportValid() [File:N:\UnrealEngine-4.19-GameWorks-VL\Engine\Source\Runtime\Renderer\Private\PostProcess/RenderingCompositionGraph.h] [Line: 133]

    When I try to load map as a sub level I've got this:
    Assertion failed: Status == NV_TXAA_STATUS_OK [File:N:\UnrealEngine-4.19-GameWorks-VL\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Commands.cpp] [Line: 2295]

    I recently changed AA to TXAA so that is probably the cause.
    - I've just disabled TXAA - that was the cause
    Gomo was that some example map? If so, which one? I tried TXAA with some but not all. Also was this on recent version of my repo? There was issue with TXAA before that it crashed on forward shading enabled, this has been fixed a while ago on official TXAA branch and I've mirrored the changed to my branch so that shouldn't happen anymore.

    Leave a comment:


  • replied
    Originally posted by videoprice View Post
    Hello dear 0lento, The flex 1.2 is out now!
    https://github.com/NVIDIAGameWorks/FleX
    Oh, I'm aware of that, I've been testing their SDK months ago. But like SteveElbows mentioned, it's the Flex SDK, not the UE4 integration. Also since this only exists in Nvidias GameWorks repo and not in their UE4 fork, I'm not allowed to distribute the Flex 1.2 SDK source code myself due to the licensing limitations. As soon as the UE4 integration comes live, it's bound to UE4's license and there's no such limit anymore.

    Originally posted by videoprice View Post
    We are waiting for UE 4.19 Blast 1.1.2 + Flow 1.0.1 + HairWorks 1.4 + HBAO+ 4 + TXAA 3 + Volumetric Lighting + VXGI 2 + Flex 1.2 + WaveWorks
    Regardless what happens with Flex, I will not merge WaveWorks myself for two reasons: doesn't work on AMD and Intel GPUs + it had shader conflict with Flex in past.
    Last edited by 0lento; 05-21-2018, 02:36 PM.

    Leave a comment:


  • replied
    Originally posted by videoprice View Post

    Hello dear 0lento, The flex 1.2 is out now!
    https://github.com/NVIDIAGameWorks/FleX
    That is just FleX itself, not the UE4 integration of FleX.

    Leave a comment:


  • replied
    Originally posted by 0lento View Post



    Few has asked this already, I'm still waiting for official Flex 1.2's UE4 integration to appear before I merge it. It's coming so it would be pointless for me to manually fix the old 4.17 integration to work on 4.19 as it would still use the older Flex. Flex 1.2 is especially interesting as it features plastic deformation now so it's definitely worth the wait.



    Hello dear 0lento, The flex 1.2 is out now!
    https://github.com/NVIDIAGameWorks/FleX

    We are waiting for UE 4.19 Blast 1.1.2 + Flow 1.0.1 + HairWorks 1.4 + HBAO+ 4 + TXAA 3 + Volumetric Lighting + VXGI 2 + Flex 1.2 + WaveWorks

    Thanks a lot
    Last edited by videoprice; 05-21-2018, 10:58 AM.

    Leave a comment:


  • replied
    Originally posted by xingcheng View Post



    Excuse me,How can I get your limit?I can't look your GitHub.
    Hey man! I don't understand your messages, please try to explain more.

    Leave a comment:


  • replied
    I've got this crash when opening map:
    Assertion failed: IsViewportValid() [File:N:\UnrealEngine-4.19-GameWorks-VL\Engine\Source\Runtime\Renderer\Private\PostProcess/RenderingCompositionGraph.h] [Line: 133]

    When I try to load map as a sub level I've got this:
    Assertion failed: Status == NV_TXAA_STATUS_OK [File:N:\UnrealEngine-4.19-GameWorks-VL\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Commands.cpp] [Line: 2295]

    I recently changed AA to TXAA so that is probably the cause.
    - I've just disabled TXAA - that was the cause
    Last edited by Gomo; 05-20-2018, 04:23 PM.

    Leave a comment:


  • replied
    Guys, is there a way to make lightning affect the water surface in WaveWorks? Lightning set up doen’t make any changes to how the ocean looks like.

    Thank you!
    Last edited by script526; 05-20-2018, 06:47 AM.

    Leave a comment:


  • replied
    Originally posted by xingcheng View Post
    Excuse me,How can I get your limit?I can't look your GitHub.
    To get access to any UE4 fork, you need first to link your github account to your unreal engine account:
    https://www.unrealengine.com/en-US/ue4-on-github

    Leave a comment:


  • replied
    Originally posted by VinaCaptcha View Post
    0lento Maybe we will need a full integration as "FleX + Blast + Flow + HairWorks 1.4 + HBAO+ 4 + TXAA 3 + Volumetric Lighting + VXGI 2".
    I love you so much
    Originally posted by VinaCaptcha View Post

    Why do you don't include Flex into this version? I am waiting it so much
    Excuse me,How can I get your limit?I can't look your GitHub.

    Leave a comment:


  • replied
    Is there a time frame for a 4.19 version of VRWorks.

    Leave a comment:


  • replied
    0lento Maybe we will need a full integration as "FleX + Blast + Flow + HairWorks 1.4 + HBAO+ 4 + TXAA 3 + Volumetric Lighting + VXGI 2".
    I love you so much

    Leave a comment:


  • replied
    Originally posted by 0lento View Post
    I think you need to enable HBAO+ with cvar if I remember right, VXGI should work once you enable the relevant settings in PP volume. I'd start by checking the Nvidias VXGI test levels from Samples/UserContent/ (https://github.com/0lento/UnrealEngi...es/UserContent). VXGI test levels are bit hidden, I didn't have time to move them around into more logical folder. It also makes it bit more tedious for me to keep the samples up-to-date if I do as now I'm just keeping the samples on same folders as they are on each nvidia tech branch.


    Few has asked this already, I'm still waiting for official Flex 1.2's UE4 integration to appear before I merge it. It's coming so it would be pointless for me to manually fix the old 4.17 integration to work on 4.19 as it would still use the older Flex. Flex 1.2 is especially interesting as it features plastic deformation now so it's definitely worth the wait.


    My UE4 branches don't have Victory plugin, so I think you've gotten Maxime Dupart's 4.19 branch instead (his does include that).

    Thanks got HBAO+ Running trough cvar. But still the same result on the VXGI map by nvidia (CornellBox) no GI at all.

    I will try to download and build your other branch with just vxgi/flow to see if GI shows on that one.

    Update: I tried the other branch the same issue there. Is it just me having this issue?

    Update2: i think i found the problem

    LogD3D11RHI: Error: VXGI Error: VXGI requires a GPU that supports FP16 typed UAV loads natively (DX11.3) or through NVAPI (Maxwell+) when ambientOcclusionMode = false (GI_Base.cpp, 366)

    LogD3D11RHI: Warning: VXGI support is limited to occlusion-only mode on this GPU.

    So my guess is VXGI 2.0 only supports Maxwell and onwards?

    Nvidia States on github ''Minimum: a 64-bit Windows 7 system with any DirectX 11 class GPU''

    I dont really understand this, haha confusing

    FYI my card even supports DX12
    Last edited by BP_Herbert; 05-16-2018, 09:52 PM.

    Leave a comment:


  • replied
    Originally posted by 最后的馒头 View Post
    Also, ask the official Datasmith tools that don't seem to be able to integrate into the branch engine. He seems to have been encrypted or what else has he done? It can not be rebuilt in the branch.
    I can't tell about datasmith myself, I've never used it nor could I integrate it myself due to the licensing involved around it.

    Leave a comment:

Working...
X