Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Mike.Skolones View Post
    That should do it. I did check in Win64 shadercompilercommon.dll, not yet sure if that would fix it, but rebuilding the ShaderCompileWorker should do it. This is not a bug specific to VXGI, it's a general UE4 problem due to missing dependencies in the solution.

    --Mike

    I noticed you updated the engine 13 hours ago here: https://github.com/NvPhysX/UnrealEng...6d5cedd2038e9d

    but as the commentator on that page said, the code may be overwritten, I also suspect the zip file got updated too, so I won't recompile the engine again, I think building ShaderCompilerWorker is enough right?

    Comment


      I hope your next demo will be this demo: the one shown at 0:12 and 3:34: https://www.youtube.com/watch?v=_E1oVl2d01Q

      Comment


        Originally posted by Mike.Skolones View Post
        That should do it. I did check in Win64 shadercompilercommon.dll, not yet sure if that would fix it, but rebuilding the ShaderCompileWorker should do it. This is not a bug specific to VXGI, it's a general UE4 problem due to missing dependencies in the solution.

        --Mike

        Ah, thanks, that got it working.

        It's actually running pretty well on my work computer, GTX 660

        Comment


          Originally posted by PLASTICA-MAN View Post
          I was sure I tried when viewport is highlighted and I tried that again, the problem is tilde key in an AZERTY keyboard location is not ~ but ², ~to get ~ you need to press Alt Gr + 2, but even that doesn't work, even turning the keyboard to english by clicking shift + Alt doesn't help that. UE4 needs to support AZERTY keyboards, because even by keybindings some movements' controls for the viewport, you can't do the same for when you click play and you have to click shift+alt again. I couldn't find where to rebind console key in the options.






          I checked again for the materials in the Cornell Box sample and all materials have that option enabled by default.





          The option was enabled by default, I even now enabled all other options for VXGI for the materials, but typing r.VXGIDebugMode 2 or r.VXGIDebugMode 3 or r.VXGIDebugMode 0 in the outpot log doesn't still let visualize respectively neither the voxelized opacities nor the emittance colors nor the Diffuse result. Please someone help me to visualize them.





          This one:
          [ATTACH=CONFIG]26348[/ATTACH]




          Thanks but I typed PostProcessVolume_VXGI in the search tab but I could find the VXGI diffuse and VXGI specualr you showed. Waht should I add to the scene to find them? Thanks
          Do you have any "PostProcessVolume" in your scene, if not then add it to your scene and you can find it in the details panel of that PostProcess volume.

          Thanks,

          Comment


            Originally posted by PLASTICA-MAN View Post
            I was sure I tried when viewport is highlighted and I tried that again, the problem is tilde key in an AZERTY keyboard location is not ~ but ², ~to get ~ you need to press Alt Gr + 2, but even that doesn't work, even turning the keyboard to english by clicking shift + Alt doesn't help that. UE4 needs to support AZERTY keyboards, because even by keybindings some movements' controls for the viewport, you can't do the same for when you click play and you have to click shift+alt again. I couldn't find where to rebind console key in the options.
            Go to Edit -> Project Settings and select the Input tab on the left. At the bottom of the page on the right you will see "Console Keys", with this you can choose any key you want to toggle the console.
            Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

            Comment


              Originally posted by Shantaram View Post
              Do you have any "PostProcessVolume" in your scene, if not then add it to your scene and you can find it in the details panel of that PostProcess volume.

              Thanks,

              I added a PostProcessVolume and found the options. Thanks, one problem solved. Now I need to visualize voxelized opacities, he emittance colors and Diffuse result using r.VXGIDebugMode 2 or r.VXGIDebugMode 3 or r.VXGIDebugMode 0 just like in the video here: https://www.youtube.com/watch?v=_E1oVl2d01Q

              and here : https://forums.unrealengine.com/atta...0&d=1424291403

              Anyone succeeded in visualizing them?

              Comment


                Originally posted by PLASTICA-MAN View Post
                I added a PostProcessVolume and found the options. Thanks, one problem solved. Now I need to visualize voxelized opacities, he emittance colors and Diffuse result using r.VXGIDebugMode 2 or r.VXGIDebugMode 3 or r.VXGIDebugMode 0 just like in the video here: https://www.youtube.com/watch?v=_E1oVl2d01Q

                and here : https://forums.unrealengine.com/atta...0&d=1424291403

                Anyone succeeded in visualizing them?
                It should be working. I am able to visualize it. Use this command "r.VXGI.DebugMode 2" instead of "r.VXGIDebugMode 2", there is a missing dot between vxgi and debugmode.

                Click image for larger version

Name:	VXGI_VoxelizedOpacities.PNG
Views:	1
Size:	153.7 KB
ID:	1066820

                I am testing it in the "CornellBox" project provided. I haven't tried it with any other project yet.

                Thanks,
                Last edited by Shantaram; 02-20-2015, 04:48 PM.

                Comment


                  Originally posted by Shantaram View Post
                  It should be working. I am able to visualize it.

                  [ATTACH=CONFIG]26356[/ATTACH]

                  I am testing it in the "CornellBox" project provided. I haven't tried it with any other project yet.

                  Thanks,
                  What did you do to visualize it? First I started output log for the Cornell Box sample , then I entered r.VXGI.DiffuseTracingEnable 1

                  Then I checked that all materials have the option used with VXGI enabled, I even checked all options for VXGI in materials parameters.

                  Then I eneterd r.VXGIDebugMode 2 in the output log, nothing happened. Same with 3 and 0 values
                  Last edited by Nudlegaru; 02-20-2015, 05:02 PM.

                  Comment


                    Originally posted by PLASTICA-MAN View Post
                    What did you do to visualize it? First I started output log for the Cornell Box sample , then I entered r.VXGI.DiffuseTracingEnable 1

                    Then I checked that all materials have the option used with VXGI enabled, I even checked all options for VXGI in materials parameters.

                    Then I eneterd r.VXGIDebugMode 2 in the output log, nothing happened. Same with 3 and 0 values
                    Use this command "r.VXGI.DebugMode 2" instead of "r.VXGIDebugMode 2", there is a missing dot between vxgi and debugmode.

                    Thanks,

                    Comment


                      Is there a way to increase the distance at which the VXGI ends? I'm having issues with the Realistic Rendering sample lighting when you back far enough way from the window.

                      Comment


                        How do we control the VXGI distance? Right now it only renders about a distance of 1000cm

                        Comment


                          Originally posted by Shantaram View Post
                          Use this command "r.VXGI.DebugMode 2" instead of "r.VXGIDebugMode 2", there is a missing dot between vxgi and debugmode.

                          Thanks,
                          Thank you very much, it worked. I knew sth was missing/wrong.

                          BTW, how do you check « Used With VXGI » (or any other option) on all surface materials at the same time or do you have to do it material by material individually?

                          Comment


                            Originally posted by PLASTICA-MAN View Post
                            Thank you very much, it worked. I knew sth was missing/wrong.

                            BTW, how do you check « Used With VXGI » (or any other option) on all surface materials at the same time or do you have to do it material by material individually?
                            I think you have to go through each material and check it.

                            Thanks,

                            Comment


                              Originally posted by darthviper107 View Post
                              How do we control the VXGI distance? Right now it only renders about a distance of 1000cm
                              Console command: r.VXGI.Range NUMBER

                              replace "NUMBER" with something that suits your needs, but as always be aware of entering ridiculous amounts there

                              Comment



                                Great job you did here!

                                Can you please tell me how did you enable VXGI for flashlight you hold in NightRoomNoLights ? Bceause it is compound light with blueprint.

                                Also how did you set up all the surface materials to be able to get VXGI on them? For example, when I click the couch, then on element 0 in the materails, it opens MI_Couch_NOSSS_Mat_Ins which doesn't have VXGI options, when I scroll down, in general tab, I click on MI_Couch_NOSSS_Mat inside it and it opens a tab where I can modify the VXGI options and enable it (Used with VXGI). Is that right?

                                Well, even doing so doesn't get me colour bleeding like in your pics and r.VXGI.DebugMode 2 doesn't get me the same results as yours here: https://forums.unrealengine.com/atta...6&d=1424464446 as if VXGI is not correctly enabled in the scene.

                                I hope you can tell me the steps that made you reach such results.

                                Thank you very much !

                                Comment

                                Working...
                                X