Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Swartz27 View Post
    VXGI 4.17 is out but not in the index yet. Thank you to the Nvidia engineer, if you're ever in Vermont I owe you a beer!
    Aww come on man, I've just settled down with 4.16.2
    Animost Studio

    Comment


      Any one know, when there will be a new hairworks branch for 4.17? And one question: How can i use more than one branch. Like Hairworks + Flex or something?

      [MENTION=894354]Len80[/MENTION]
      You have to link your unreal account with the github account. There is a small tutorial from epic about it. Thats why you get this error.
      01010100 01101000 01100101 00100000 01110100 01110010 01110101 01110100 01101000 00100000 01101001 01110011 00100000 01101111 01110101 01110100 00100000 01110100 01101000 01100101 01110010 01100101 00101110 00100000 01010100 01110010 01110101 01110011 01110100 00100000 01101110 01101111 00110001 00100001 00100000

      Comment


        Originally posted by Beregron View Post
        Any one know, when there will be a new hairworks branch for 4.17? And one question: How can i use more than one branch. Like Hairworks + Flex or something?

        [MENTION=894354]Len80[/MENTION]
        You have to link your unreal account with the github account. There is a small tutorial from epic about it. Thats why you get this error.
        Hi. Get it from here https://github.com/niexuchina/Unreal...7-HairWorks1.4.

        Comment


          Originally posted by Swartz27 View Post
          VXGI 4.17 is out but not in the index yet. Thank you to the Nvidia engineer, if you're ever in Vermont I owe you a beer!
          Anyone got this when compiling?:
          error CS1503: Argument 1: cannot convert from 'UnrealBuildTool.DirectoryReference' to 'string'

          Comment


            Hi guys, I'm trying to merge WaveWorks into other GameWorks tech in 4.16.2, everything compiled fine but when I launch editor it crashes with the following message, anyone have similar problem or some tips about this error?
            [2017.08.22-18.01.19:699][ 0]LogTargetPlatformManagerisplay: Building Assets For Windows
            [2017.08.22-18.01.20:581][ 0]LogDerivedDataCacheisplay: Max Cache Size: 512 MB
            [2017.08.22-18.01.21:466][ 0]LogDerivedDataCache: Loaded boot cache 0.88s 93MB ../../../Engine/DerivedDataCache/Boot.ddc.
            [2017.08.22-18.01.21:466][ 0]LogDerivedDataCacheisplay: Loaded Boot cache: ../../../Engine/DerivedDataCache/Boot.ddc
            [2017.08.22-18.01.21:466][ 0]LogDerivedDataCache: FDerivedDataBackendGraph: Pak pak cache file ../../../Engine/DerivedDataCache/DDC.ddp not found, will not use a pak cache.
            [2017.08.22-18.01.21:467][ 0]LogDerivedDataCache: Unable to find inner node Pak for hierarchical cache Hierarchy.
            [2017.08.22-18.01.21:467][ 0]LogDerivedDataCache: FDerivedDataBackendGraph: EnginePak pak cache file ../../../Engine/DerivedDataCache/DDC.ddp not found, will not use a pak cache.
            [2017.08.22-18.01.21:467][ 0]LogDerivedDataCache: Unable to find inner node EnginePak for hierarchical cache Hierarchy.
            [2017.08.22-18.01.21:479][ 0]LogDerivedDataCache: Using Local data cache path ../../../Engine/DerivedDataCache: Writable
            [2017.08.22-18.01.21:479][ 0]LogDerivedDataCache: Shared data cache path not found in *engine.ini, will not use an Shared cache.
            [2017.08.22-18.01.21:479][ 0]LogDerivedDataCache: Unable to find inner node Shared for hierarchical cache Hierarchy.
            [2017.08.22-18.01.21:591][ 0]LogMaterial: Verifying Global Shaders for PCD3D_SM5
            [2017.08.22-18.01.23:889][ 0]LogSlate: Using Freetype 2.6.0
            [2017.08.22-18.01.24:431][ 0]LogSlate: SlateFontCache - WITH_FREETYPE: 1, WITH_HARFBUZZ: 1
            [2017.08.22-18.01.24:431][ 0]LogSlate: SlateFontCache - WITH_FREETYPE: 1, WITH_HARFBUZZ: 1
            [2017.08.22-18.01.32:373][ 0]LogInit: Selected Device Profile: [Windows]
            [2017.08.22-18.01.34:562][ 0]LogContentStreaming: Texture pool size is 0.00 MB
            [2017.08.22-18.01.34:871][ 0]LogMaterial: Missing cached shader map for material WorldGridMaterial, compiling. Is special engine material.
            [2017.08.22-18.04.50:764][ 0]LogShaderCompilers:Warning: 1 Shader compiler errors compiling WorldGridMaterial for platform PCD3D_SM5:
            [2017.08.22-18.04.50:764][ 0]LogShaderCompilers:Warning: Engine/Shaders/LocalVertexFactory.usf(733,2-9): Shader FVelocityPS, VF FFlexGPUVertexFactory:
            error X3004: undeclared identifier 'TangentX'

            [2017.08.22-18.04.50:765][ 0]LogShaderCompilers:Warning: LocalVertexFactory.usf(733,2-9): error X3004: undeclared identifier 'TangentX'
            [2017.08.22-18.04.50:799][ 0]LogWindows: Windows GetLastError: The operation completed successfully. (0)
            Animost Studio

            Comment


              There's a VXGI 4.17 version !! it's so cool ! i'm so happy, testing this right away !


              Edit: it's working so good ! Bugs from 4.15-4.16 are no more, so happy!
              Last edited by MaximeDupart; 08-22-2017, 08:50 PM.
              LinkedIn | Link custom Shaders | Atmosphere Modelisation & Procedural Planets | Distance Matching Locomotion | Nvidia GameWorks builds - 4.19.2 : VXGI2.0, Blast, HairWorks, Flow - Plugins: VictoryBP

              Comment


                Originally posted by Maxime.Dupart View Post
                There's a VXGI 4.17 version !! it's so cool ! i'm so happy, testing this right away !


                Edit: it's working so good ! Bugs from 4.15-4.16 are no more, so happy!
                Sounds good! Do you plan to merge 4.17 builds soon? In my case I'd need Hairworks and VXGI.
                ArtStation - Portfolio

                Comment


                  Hi Folks,

                  it's me again. I have another question, agin.

                  Is there a branch or a way to use Hairworks and Turbulence with UE 4.17?

                  Originally posted by Xu Nie View Post
                  Thanks for that. But actually i wanted to know, how i can make a merge by myself. But thanks for that branch.
                  Last edited by Beregron; 08-28-2017, 09:39 AM.
                  01010100 01101000 01100101 00100000 01110100 01110010 01110101 01110100 01101000 00100000 01101001 01110011 00100000 01101111 01110101 01110100 00100000 01110100 01101000 01100101 01110010 01100101 00101110 00100000 01010100 01110010 01110101 01110011 01110100 00100000 01101110 01101111 00110001 00100001 00100000

                  Comment


                    Originally posted by The_Distiller View Post

                    Sounds good! Do you plan to merge 4.17 builds soon? In my case I'd need Hairworks and VXGI.
                    Sure, as soon as they have stable released 4.17+
                    LinkedIn | Link custom Shaders | Atmosphere Modelisation & Procedural Planets | Distance Matching Locomotion | Nvidia GameWorks builds - 4.19.2 : VXGI2.0, Blast, HairWorks, Flow - Plugins: VictoryBP

                    Comment


                      Hi, I've currently been testing VXGI 4.15 out which works well but I've come across an issue, since it's quite important to have lightbaking supported for static scene's. I've rebuild UnrealLightmass which fixes the issue of scene's not getting baked anymore. But now on objects using LOD's specifically one's generated with UE4 itself I get lightmap flickering when lod's pop. This only happens in the VXGI build anybody else experienced this or has a fix for this issue ? Would be much appreciated!

                      Fixed this myself by adjusting source code in StaticMesh.cpp, StaticMesh.h and StatichMeshRender.cpp
                      Last edited by AlexanderDG; 08-29-2017, 03:31 PM.

                      Comment


                        Hi AlexanderDG.

                        Please explain how you have fixed the error by modifying the code of those files

                        Thanks in advance !!

                        Comment


                          I just noticed this currently only fixes in editor and not in packaged games yet, I'll post the fixes as soon as I got it working in packaged games.

                          Comment


                            Hi all.

                            I've been trying out VXGI in 4.17.

                            I'm getting horrible stuttering.



                            This is with a blank project, but it doesn't just persist graphically, it affects the entire editor. I can't develop anything because i have to time my clicks to be in the high framerate part of the stutter.

                            My system settings:
                            i7 6700k
                            32gb RAM
                            GTX 1080
                            Windows 10.
                            Lee Devonald
                            Character Technical Artist.
                            Portfolio: http://crazyferretstudios.com

                            Comment


                              Hello DmHookie, I have a couple of suggestions I got into making my own VR games in past month. I was able to get translucent water in the vrfunhouse project. I used the flextranslucent fluid from the /flex project in nvidia. But I have problems with boundaries after the liquid lands on a mesh. here is a screen shot.

                              Comment


                                Anyone with VXGI 4.17 having trouble with VS throwing out errors caused by StageFiles? Its giving me errors for the VXGI/HBAO stagefiles on top of other inputs for other plugins. :/ The error also comes bundled with "error CS1503: Argument 1: cannot convert from 'UnrealBuildTool.DirectoryReference' to 'string'"

                                So close to finally upgrading to the new engine and can take advantage of Volumetric Fog, but this is the only things preventing the transition.
                                Current Project: Shadow Over Isolation

                                Comment

                                Working...
                                X