Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Will HairWorks and Waveworks be updated for the UnrealEngine 4.16?
    How long does it take to wait?
    We will be grateful for the answer!

    Comment


      [MENTION=29363]Alexey.Panteleev[/MENTION]: Any news on VXGI release for UE4.16? Thank you.

      Comment


        When will hairworks for 4.16 be released? Please tell.

        Comment


          hello everyone i its been a while since someone posted something on this subject. but i would really appreciate help, whenever i use this linke : https://github.com/NvPhysX/UnrealEngine ; nothing shows up on gethub, i cant find anything on gethub with nvidia gameworks, i don't know what to do, i am not that experienced with gethub but i am trying my best. and i am very confused as to why the links aren't working properly.

          Comment


            Originally posted by Maxime.Dupart View Post
            Hello, i'm afraid you grabbed the 4.15.3 branch, check on the left, if you downloaded by .zip it also should be the name of the .zip of course.
            The 4.16 branch will actually show 4.17 on splashscreen. I grabbed the source for this build exactly when they isolated their 4.16 work to prepare it for release.

            Also please note that you can't package with this 4.16 branch as it is right now.

            I actually stopped playing with this build in the middle of adding Hairworks to it, it would appears that it's one of the issue preventing proper packaging. I need to remove HairWorks from this build to check and see.
            Would be cool to be able to package with GameWork on 4.16, would "only" need to update to current 4.16 to get it over with.
            Hi. What kind of package issue do you have with HairWorks?

            Comment


              Originally posted by poke1103 View Post
              When will hairworks for 4.16 be released? Please tell.
              It's on the way. If you want to get it earlier, please visit here https://github.com/niexuchina/Unreal...6-HairWorks1.3

              Comment


                Engine\Source\Runtime\Renderer\Private\ShadowRendering.cpp in function: void FProjectedShadowInfo::SetupProjectionStencilMask

                From line 797
                to line 825

                the

                #if WITH_FLEX
                #else
                #endif //Flex

                It produce error if not with flex, and the function gets broken because the terminate brackets gets removed from the for or if, really dono what You trying to achieve here.
                Thanks, looks like this got broken during a merge. We're currently refactoring the fluid surface rendering (which is what this change relates to), this should get cleaned up in the next push.

                Comment


                  Originally posted by Miles.Macklin View Post
                  Thanks, looks like this got broken during a merge. We're currently refactoring the fluid surface rendering (which is what this change relates to), this should get cleaned up in the next push.
                  It's times like this that I reach for the forum 'like post' button before remembering there isnt one here. Like!

                  Comment


                    Originally posted by Xu Nie View Post
                    Hi. What kind of package issue do you have with HairWorks?
                    Hello, Hairworks wasn't the issue. I just ported the other GameWorks feature to 4.16 2months ago and it was a bit dirty code here and there, while overall failling to package.

                    I did not completely port Hairworks to 4.16, and actually stopped in the middle of the job.
                    LinkedIn | Link custom Shaders in 4.21/4.22/4.23 | Atmosphere Modelisation | Distance Matching Locomotion | Nvidia GameWorks builds - 4.19.2 : VXGI2.0, Blast, HairWorks, Flow - Plugins: VictoryBP

                    Comment


                      [MENTION=649466]Maxime.Dupart[/MENTION] : any plan to add waveworks with the new 4.16 volumetric fog plase ?

                      Comment


                        Please help, I already do not know what to do! Does not want a build. Tried a lot of solutions, but without success. I used this branch (https://github.com/sieumeo/UnrealEng...orks+Flex+Flow). Can you suggest a solution or a similar branch with Flex + Flow? I have other branches, but not all, through time.
                        Here are my steps:
                        Run Setup.bat, answer "N" when it asks you about overwriting some files - otherwise it will replace new NVAPI libraries with old ones, and UE4 won't build. (But he did not ask me anything.)
                        Run GenerateProjectFiles.bat
                        Open UE4.sln, build UE4 and ShaderCompileWorker projects. I use: Windows 10 Pro 15063.413 and Visual Studio 2013 Ultimate. Thanks in advance.

                        Click image for larger version

Name:	error.png
Views:	2
Size:	63.8 KB
ID:	1130077
                        Last edited by RuTzoT; 06-24-2017, 05:04 PM.

                        Comment


                          Does casting shadows from Flow components on other objects (or casting shadows on Flow effects) works in recent version? The same question for light: can Flow components reflect light?
                          If any of these works I would be grateful for simple step-by-step guide how to set it

                          Comment


                            [MENTION=727967]RuTzoT[/MENTION]

                            I recommend You to.
                            get Visual Studio 2015 for UE4 and libraries compatibility, and project packaging. Install this.
                            get Build Tools 2015 Update 3 The release is also available via a standalone Build Tools 2015 Update 3 installer. Install this.
                            get Windows SDK 8.1 Windows SDK 8.1 if not full instaled in your system.
                            get Windows SDK 10 for new upcomings changes, install this if you want.

                            My advice it's You extract the repo to an folder and run setup.bat normally, and again extract the repo and overwrite the last extracted folder, and do not run the setup.bat after this.

                            Delete all Intermediate folders and Saved folder

                            Generate projects.

                            Build

                            Etc.....

                            Comment


                              Anyone having issues with VXGI and VR using the Vive?

                              I notice that on the left eye I have no shadows and on the right eye I have shadows, giving pretty bad results in VR....

                              Is there a solutionj for that, since ( looking around ) I'm not the only one experiencing this issue?
                              ENTER REALITY

                              VR Solutions

                              Contact us for more informations

                              Comment


                                @ Maxime.Dupart

                                Hello, I tried to install your branch (https://github.com/MaximeDup/UnrealE...-Old-GameWorks), but it fails compilation.
                                Could you help me to solve this problem?

                                Click image for larger version

Name:	old_erroe.png
Views:	1
Size:	32.5 KB
ID:	1130207
                                Attached Files
                                Last edited by RuTzoT; 06-25-2017, 03:54 AM.

                                Comment

                                Working...
                                X