Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by karma4jake View Post

    I have ported VXGI 1 into 4.19 and it works as intended. I will port it to 4.20 by the end of this weekend, but I believe many more changes were made in 4.21 regarding a few things, so I may not have the required skill for 4.21 VXGI 1.

    I can upload 4.19 if anyone wants that, it has everything 0lento merged in GW with VXGI 1 instead. It's a built local version though so like 15gb dl.
    just upload the branch onto github i would like this thanks, maybe 0lento can get VXGI 1 merged in with newer 4.20+

    Leave a comment:


  • replied
    Originally posted by formatmezzz View Post
    I have ported VXGI 1 into 4.19 and it works as intended. I will port it to 4.20 by the end of this weekend, but I believe many more changes were made in 4.21 regarding a few things, so I may not have the required skill for 4.21 VXGI 1.

    I can upload 4.19 if anyone wants that, it has everything 0lento merged in GW with VXGI 1 instead. It's a built local version though so like 15gb dl.

    Leave a comment:


  • replied
    Originally posted by DsyD View Post
    For the VXGI build, does anyone know how to get the engine to "ignore" a slot in a multi-material-slot mesh for the purposes of determining occlusion?

    It seems that Translucent materials are ignored, which I guess makes some sense.

    But if I have a mesh with multiple material slots, it seems to ignore the entire mesh if just one slot has a Translucent material, even if all of the other slots are Opaque.

    Here for this table mesh, I have two material slots.

    Image 1: both slots Opaque:

    Both slots opaque

    Image 2: One slot Opaque, other Translucent (entire mesh is missing from reflection):
    One Opaque, one Translucent

    Image 3: One slot Opaque, the other WorldGridMaterial (only WorldGridMaterial is missing from reflection):
    One Opaque, one WorldGridMaterial

    In the last image, you can tell from the reflection that the engine is treating the Opaque-material part of the mesh (bottom part of table) as an occluder and ignoring the WorldGridMaterial (top of the table). How can I get it to do the same thing with the material setup in Image 2?
    Does anyone know if this problem above is fixed in 4.20.3 VXGI?

    Leave a comment:


  • replied
    how to get access to FLEX download? can't open github pages crr 404

    Leave a comment:


  • replied
    Originally posted by Devostated View Post
    Hey,
    i'd like to request a 4.21 VXGI 1 version. Alot of people still use a 4.17 branch for using VXGI 1.
    Here are some screenshots for comparison made by Fuze.

    VXGI1: https://imgur.com/a/3fp8gGx
    VXGI2: https://imgur.com/a/z0JsCRO
    can you look into this?

    https://github.com/NvPhysX/UnrealEngine/issues/591

    Leave a comment:


  • replied
    Originally posted by FatmirVaraku View Post
    Hi Olento can you help me with this,please.
    No idea on that or how you got into that situation.

    Originally posted by Kayzield909 View Post
    Flex works but doesn't support VR stereo rendering so holding off on it for now (wanna save my fps).
    Afaik, FleX might work in VR if you don't use instanced stereo, haven't tested this myself though.


    Leave a comment:


  • replied
    Kayzield909 In the regular ue4, complex collision isn't supported as a physx actor. So it might be related to that. Try importing a custom collision with the model part instead.

    Leave a comment:


  • replied
    Originally posted by 0lento View Post
    4.19 Flex from NvPhysX is broken for packaging, I did a PR for this ages ago but nobody from Nvidia merged it:
    https://github.com/NvPhysX/UnrealEngine/pull/523 (PR from 2018 summer)

    My PR branch here: https://github.com/0lento/UnrealEngi...PR-FleX-4.19.2

    to fix the standalone packaging, you at least need to include fixes in this commit: https://github.com/NvPhysX/UnrealEng...cfefd93ee3f41c
    Why they even have 4.19 build if it is broken. They even know it is broken and never cared to warn people or remove it. This is so careless.

    Leave a comment:


  • replied
    Hi all, I've been tweaking Nvidia Flow and I can't seem to get my emitter particles to collide with a complex shape (only colliding with simple). Problem is I want the smoke to flow through a funnel (practice) and jet engine (real application). Any tips? Flex works but doesn't support VR stereo rendering so holding off on it for now (wanna save my fps). Any tips?

    Leave a comment:


  • replied
    Should create a 0lento thread at this point

    Leave a comment:


  • replied
    Hi Olento can you help me with this,please.
    Click image for larger version

Name:	Untitled.png
Views:	47
Size:	71.6 KB
ID:	1580587

    Leave a comment:


  • replied
    Originally posted by The_Reaper77_ View Post
    Can't package a game on 4.19 flex build.
    4.19 Flex from NvPhysX is broken for packaging, I did a PR for this ages ago but nobody from Nvidia merged it:
    https://github.com/NvPhysX/UnrealEngine/pull/523 (PR from 2018 summer)

    My PR branch here: https://github.com/0lento/UnrealEngi...PR-FleX-4.19.2

    to fix the standalone packaging, you at least need to include fixes in this commit: https://github.com/NvPhysX/UnrealEng...cfefd93ee3f41c

    Leave a comment:


  • replied
    Can't package a game on 4.19 flex build.

    UATHelper: Packaging (Windows (64-bit)): ERROR: UBT ERROR: Failed to produce item: D:\ue\UnrealEngine\Engine\Plugins\GameWorks\Flex\Binaries\Win64\Game-Flex-Win64-Shipping.lib
    PackagingResults: Error: UBT ERROR: Failed to produce item: D:\ue\UnrealEngine\Engine\Plugins\GameWorks\Flex\Binaries\Win64\Game-Flex-Win64-Shipping.lib
    UATHelper: Packaging (Windows (64-bit)): ERROR: Command failed (Result:5): D:\ue\UnrealEngine\Engine\Binaries\DotNET\UnrealBuildTool.exe Game Win64 Shipping -Project="X:\2 4.19\Game.uproject" "X:\2 4.19\Game.uproject" -NoUBTMakefiles -remoteini="X:\2 4.19" -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: 'Unreal
    PackagingResults: Error: Command failed (Result:5): D:\ue\UnrealEngine\Engine\Binaries\DotNET\UnrealBuildTool.exe Game Win64 Shipping -Project="X:\2 4.19\Game.uproject" "X:\2 4.19\Game.uproject" -NoUBTMakefiles -remoteini="X:\2 4.19" -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: 'UnrealBuildTool-2019.02.03-23
    PackagingResults: Error: Unknown Error
    Please help

    Leave a comment:


  • replied
    Originally posted by Swdan View Post

    ye. shore capture in sample project is broken.
    upd: get shoreline mat onto your landscape then capture. then reapply your mat
    anyone saw any documentation on waveworks usage?
    hey swadan, thanks for this! never could figure out we had to put their shoreline mat, capture it and back our original material
    actually I did what you said and works, I could finally capture my own shoreline, but there is always a but...

    looks like waveworks cannot understand the shoreline capture from static meshes, my beach is a SM and not a landscape

    And shoreline shape looks like it MUST be a island (I mean, all sides must be connected to a island format, the shape of island could be anything we want, but this have to be like this), I captured my beach static mesh, this is a huge rectangle and the shoreline couldn't understand correctly, this needed to capture only the part on texture border of the beach and not the full rectangle, that's kind bizarre having full retangular foam, lol.

    I did another test, I have a small island static mesh and the shoreline captures it, but... yeah, the foam comes from inside the island to outside, must be the opposite. And waveworks cannot understand the foam around island corners is different from the foam from the beach, it just use the same foam for making this shoreline.

    I wish nvidia did something with more control, like we can paint the shoreline on our static meshes and landscapes, by using a spline or something like this
    and be able to use ocean foam as a material, so we can just drag and drop this foam like a deferred decal or blueprint in order to do a scene composition

    currently it is very limited (and I have absolutely no idea how to make usage of their foam for do that, since i'm not dev)

    Leave a comment:


  • replied
    Originally posted by Devostated View Post
    Hey,
    i'd like to request a 4.21 VXGI 1 version. Alot of people still use a 4.17 branch for using VXGI 1.
    Here are some screenshots for comparison made by Fuze.

    VXGI1: https://imgur.com/a/3fp8gGx
    VXGI2: https://imgur.com/a/z0JsCRO
    VXGI 1 is better than 2. ─░nteresting. 4,21 branch is in some problem. Another branch try please

    Leave a comment:

Working...
X