Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by GalaxyMan2015 View Post
    You need to be logged into your github account and it has to be linked to your UE4 account otherwise you will get a 404 error. All links are still valid.
    how do i link those?

    Comment


      Originally posted by OnlyHorrorOnlyHardcore View Post
      how do i link those?
      https://www.unrealengine.com/ue4-on-github
      NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
      Feel free to Donate if you wish to support me

      Comment


        Originally posted by GalaxyMan2015 View Post
        thank you. now i have to compile it right?

        Comment


          I found this:

          http://on-demand.gputechconf.com/gtc...lumination.pdf

          Hope it helps

          Comment


            Ok I am running into a problem. I had a similar issue building the 4.9.1 build saying an error with the rasterizer...got that fixed and built with no issues, however the flex part of it doesnt seem to be working for me...I am trying to load some levels I made on a previous build and the flex elements don't work anymore. Any ideas?

            Comment


              No idea. Try loading the NVIDIA Flex demo project and see if they work. Or otherwise share your project with me so I can see if its working properly here or not.
              NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
              Feel free to Donate if you wish to support me

              Comment


                Originally posted by GalaxyMan2015 View Post
                No idea. Try loading the NVIDIA Flex demo project and see if they work. Or otherwise share your project with me so I can see if its working properly here or not.
                The Flex demo project I found was in the link provided by CryZenX at https://www.youtube.com/watch?v=Sr7ptXOUHMo

                Works in your build, cheers. Surprisingly fast (my goodness Nvidia really wants to destroy AMD and Intel GPUs with Gameworks).

                One thing though, does anyone know where is the official Nvidia Flex demo project?

                Edit: OK scratch that I found it (USE THIS ONE), it's in the Flex branch at https://github.com/NvPhysX/UnrealEng...eX/FlexProject
                Last edited by srmojuze; 10-05-2015, 03:43 AM.

                Comment


                  Originally posted by GalaxyMan2015 View Post
                  No idea. Try loading the NVIDIA Flex demo project and see if they work. Or otherwise share your project with me so I can see if its working properly here or not.
                  Well to clarify, I had to reformat my computer over the weekend and Flex and everything worked perfectly before then. I have reinstalled UE4 and got the latest builds recompiled without errors but the flex interactivity no longer works...is it possible I missed some critical files outside of unreal? Do we need any files from nvidia for it to work?

                  Comment


                    No you dont need anything outside of the repo. Maybe GPU drivers? As srmojuze reported, FLEX is working for him, and is also working for me, using my build, so it will be a configuration issue with your machine I suspect, especially considering you just reformated.

                    EDIT: One thing that did occur to me, if your running in DX12 mode, FLEX will not work. So make sure your running in DX11 mode.
                    Last edited by GalaxyMan2015; 10-05-2015, 06:33 AM.
                    NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
                    Feel free to Donate if you wish to support me

                    Comment


                      Originally posted by geylangwarrior View Post
                      Well to clarify, I had to reformat my computer over the weekend and Flex and everything worked perfectly before then. I have reinstalled UE4 and got the latest builds recompiled without errors but the flex interactivity no longer works...is it possible I missed some critical files outside of unreal? Do we need any files from nvidia for it to work?
                      On the Nvidia side, I believe you just need the Nvidia GPU drivers with PhysX as well ("full install" of Nvidia drivers). No CUDA needed, that's for sure.

                      Comment


                        Testing out VXGI with emissive materials using actual video files.

                        Was running at 90-120fps constant on my MSI 980 TI but recorded at 1080P @ 60fps
                        Last edited by CharlestonS; 10-05-2015, 06:47 AM.


                        Twitter - @TheCSilverman

                        Ancient Cistern | Advanced Material Pack Ed. 1 | Advanced Material Pack Ed. 2 | Advanced Material Pack Ed. 3 | Texture Pack Ed. 1 | Container Pack Ed. 1 | Road Sign Pack Ed. 1

                        Comment


                          Originally posted by CharlestonS View Post
                          Testing out VXGI with emissive materials using actual video files.
                          Wow. Nice interactivity with video materials to boot. UE4 + VXGI does appear to be the frontrunner for full dynamic GI in games.

                          Has anyone tried VXGI on AMD? Hard to find resources whether it will work well on AMD (probably not the NvPhysX branch anyway?).

                          Update: VXGI + HBAO + FLEX* + WaveWorks* + HairWorks* confirmed working with GalaxyMan latest. Have a good week playing with it all!
                          *At least with Nvidia demo material etc.

                          I thought GameWorks would be really slow but Flex, WaveWorks and HairWorks seem to run OK thus far on my GTX660M. HBAO is not too bad. VXGI is quite different, of course. Certainly requires a Maxwell card to even develop with it.
                          Last edited by srmojuze; 10-05-2015, 12:38 PM.

                          Comment


                            Hi!
                            I wanted to compile the Nvidia version of the engine, but I got stuck at GeneratingProjectFiles.bat. When I run it, it says something about missing .NET Framework 4 and mismatch between processor architect and MSIL. After that,it says Windows SDK 8.1 is missing. After installing Windows SDK, I could open the project files with Visual Studio 2013, but it says it's incompatible with these files... My processor is an AMD FX8150, if it matters.
                            Here's a picture of command prompt:
                            Click image for larger version

Name:	error.jpg
Views:	2
Size:	294.6 KB
ID:	1088743

                            Comment


                              Got it working, thanks GalaxyMan for the update!
                              Anyone got tips though for making the hair look more like in the Hairworks viewer?
                              The hair strands are pretty thick and the materials look off. It also seem to ignore the settings I made in the tool.
                              Project Shinrin | Portfolio

                              Comment


                                Originally posted by CharlestonS View Post
                                Testing out VXGI with emissive materials using actual video files.

                                Was running at 90-120fps constant on my MSI 980 TI but recorded at 1080P @ 60fps
                                Wow great sample. Would you please provide your sample so we can try it out? Thanks.

                                Comment

                                Working...
                                X