Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Alexey.Panteleev View Post
    We just updated the VXGI branch on github to the latest UE 4.8.3 version of the integration, and deleted the VXGI-dev branch. This update includes a number of bug fixes that we discussed in this thread a month or two ago.

    Another update with UE 4.9.0 is coming soon, and it includes new VXGI rendering backends for DX12 (it works!) and DX11 (a much cleaner solution than before), as well as performance improvements for multi-bounce/emissive material voxelization.
    Are you guys going to have some more detailed documentation? I have an 760ti and when I enable VXGI nothing changes.....

    Comment


      Originally posted by RynerLuteTLD View Post
      Are you guys going to have some more detailed documentation? I have an 760ti and when I enable VXGI nothing changes.....
      Are your lights set to contribute to VXGI Indirect Lighting? If so, then do your have r.VXGI.DiffuseTracingEnable and r.VXGI.SpecularTracingEnable checked? Also you do need to have a post process volume enabling them, and you may want it to be unbound.

      Comment


        Originally posted by GalaxyMan2015 View Post
        Cool can't wait for the DX12 backend implementation, just upgraded to 4.9 and DX12 and am missing VXGI and HBAO
        Thanks again GalaxyMan for your builds.

        Originally posted by RynerLuteTLD View Post
        Are you guys going to have some more detailed documentation? I have an 760ti and when I enable VXGI nothing changes.....
        There's some information in the "UE4" section: http://developer.download.nvidia.com...tion_GDC15.pdf
        Last edited by srmojuze; 09-08-2015, 08:48 PM.

        Comment


          Thanks everyone, I will try that and update this if it worked

          Comment


            I'm having a problem with the latest release of VXGI. When I set r.VXGI.MapSize=64, VXGIFinalizeVxgiVoxelization takes 1.58ms. But when I set r.VXGI.MapSize=128 (The Default), VXGIFinalizeVxgiVoxelization takes 106.89ms. VXGIPrepareForVXGIOpacityVoxelization similarly jumps from 0.29ms to 80.24ms. Does VXGI really scale that poorly, or is something wrong with this build? I'm using a 2Gb GTX 770 in the Blueprint FPS default scene.

            Edit: I also noticed that r.VXGI.DebugMode is gone, which makes it hard for me to investigate further.
            Last edited by Blakblt; 09-09-2015, 07:54 PM.

            Comment


              Originally posted by Blakblt View Post
              I'm having a problem with the latest release of VXGI. When I set r.VXGI.MapSize=64, VXGIFinalizeVxgiVoxelization takes 1.58ms. But when I set r.VXGI.MapSize=128 (The Default), VXGIFinalizeVxgiVoxelization takes 106.89ms. VXGIPrepareForVXGIOpacityVoxelization similarly jumps from 0.29ms to 80.24ms. Does VXGI really scale that poorly, or is something wrong with this build? I'm using a 2Gb GTX 770 in the Blueprint FPS default scene.

              Edit: I also noticed that r.VXGI.DebugMode is gone, which makes it hard for me to investigate further.
              I think you might be running out of video memory. The default settings use r.VXGI.StoreEmittanceInHdrFormat = 1, which means float32 emittance on non-Maxwell, i.e. 80 bytes per voxel, or about 1 GB for all voxel textures. With 2 GB total vram, that's a lot. Can you check actual video memory usage with GPU-Z or a similar tool?

              The r.VXGI.DebugMode is replaced with new view options for convenience. You can find them in the viewport menu which usually shows as "Lit" button.

              Comment


                Originally posted by Alexey.Panteleev View Post
                I think you might be running out of video memory. The default settings use r.VXGI.StoreEmittanceInHdrFormat = 1, which means float32 emittance on non-Maxwell, i.e. 80 bytes per voxel, or about 1 GB for all voxel textures. With 2 GB total vram, that's a lot. Can you check actual video memory usage with GPU-Z or a similar tool?

                The r.VXGI.DebugMode is replaced with new view options for convenience. You can find them in the viewport menu which usually shows as "Lit" button.
                I'm away from my computer, so I can't check right now, but I know I disabled StoreEmittanceInHdrFormat, and it didn't help.

                Comment


                  Originally posted by Blakblt View Post
                  I'm away from my computer, so I can't check right now, but I know I disabled StoreEmittanceInHdrFormat, and it didn't help.
                  Ok, I got around to downloading GPU-Z (Great tool btw) and retesting VXGI. All I did was load up the engine, start a new FP Blueprint project, disable static lighting, remove the skylight in the sample scene, and set the directional light to movable and contribute to VXGI Lighting. I Changed nothing else.

                  TEST 1:
                  r.VXGI.MapSize=128
                  r.VXGI.StoreEmittanceInHdrFormat=1

                  GPU Time: 126ms
                  VXGI WS: 104ms
                  Memory Usage: 1856MB

                  TEST 2:
                  r.VXGI.MapSize=128
                  r.VXGI.StoreEmittanceInHdrFormat=0

                  GPU Time: 21ms
                  VXGI WS: 4ms
                  Memory Usage: 1751MB

                  TEST 3:
                  r.VXGI.MapSize=64
                  r.VXGI.StoreEmittanceInHdrFormat=1

                  GPU Time: 19ms
                  VXGI WS: 2ms
                  Memory Usage: 1339MB

                  TEST 4:
                  r.VXGI.MapSize=64
                  r.VXGI.StoreEmittanceInHdrFormat=0

                  GPU Time: 16ms
                  VXGI WS: 1.3ms
                  Memory Usage: 1230MB

                  So apparently HDR emittance was the culprit, I just didn't notice because after changing the setting it took about 15 seconds for the performance to improve. I'm still a little confused as to why it hurt my performance so much. It only appeared to add about 100MB to the memory, and It didn't cap out (the memory usage fluctuated up to 1911MB at one point, 1856MB was just where it sat most of the time).

                  Comment


                    BTW, does anyone have any suggestions as how to scale GI down to mid-range hardware? My workflow doesn't use any real-time lighting, so for low end I just turn off GI and let skylighting do the work, and for high end (say, GTX 760 and up) I can scale the GI to 4ms and still have decent quality, but what would be the best for everything in between? Would I be better off switching to LPV, or lowering the MapSize to 32 and increasing the tracing sparsity to 4?When VXGI is lowered that far it kinda looks like LPV with even lower quality, but designing levels that don't appear different with 2 GI modes isn't a good option either.

                    Comment


                      @Alexey.Panteleev
                      could you tell me where I can download it ?
                      and....could i package project with your version.

                      Comment


                        Originally posted by WuRuiHeng View Post
                        @Alexey.Panteleev
                        could you tell me where I can download it ?
                        and....could i package project with your version.
                        Alexey works on the NVIDIA version, which is located here: https://github.com/NvPhysX/UnrealEngine and the VXGI branch in particular is: https://github.com/NvPhysX/UnrealEngine/tree/vxgi4.8.2
                        NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
                        Feel free to Donate if you wish to support me

                        Comment


                          thank you so much!!!! alexey is a staff of nvidia!!!!!

                          Comment


                            Originally posted by Blakblt View Post
                            So apparently HDR emittance was the culprit, I just didn't notice because after changing the setting it took about 15 seconds for the performance to improve. ... It only appeared to add about 100MB to the memory, and It didn't cap out (the memory usage fluctuated up to 1911MB at one point, 1856MB was just where it sat most of the time).
                            Thanks for the data. It looks like you actually are running out of video memory, although GPU-Z shows it's not full. Just not all the data is resident in video memory, which causes massive swapping to system memory over PCI-E.
                            The actual difference in vidmem requirements between HDR and non-HDR emittance for MapSize=128 is close to 700 MB.

                            Here's what I get on a 4 GB GPU (Win10) in non-Maxwell mode, with a very simple scene in UE4:
                            MapSize=64, HDR=0: 1565 MB
                            MapSize=64, HDR=1: 1652 MB
                            MapSize=128, HDR=0: 2073 MB
                            MapSize=128, HDR=1: 2739 MB

                            Originally posted by Blakblt View Post
                            BTW, does anyone have any suggestions as how to scale GI down to mid-range hardware? My workflow doesn't use any real-time lighting, so for low end I just turn off GI and let skylighting do the work, and for high end (say, GTX 760 and up) I can scale the GI to 4ms and still have decent quality, but what would be the best for everything in between? Would I be better off switching to LPV, or lowering the MapSize to 32 and increasing the tracing sparsity to 4?When VXGI is lowered that far it kinda looks like LPV with even lower quality, but designing levels that don't appear different with 2 GI modes isn't a good option either.
                            Isn't MapSize=64 fast enough?
                            You can also try reducing the number of clipmap levels (r.VXGI.StackLevels) and scale Range accordingly.
                            Setting StackLevels to 1 is an interesting special case, which removes some quality issues that come from the clipmap, such as banding, but some other implicit settings aren't optimized in the currently released version; they will be in the next version.

                            Comment


                              Originally posted by GalaxyMan2015 View Post
                              Alexey works on the NVIDIA version, which is located here: https://github.com/NvPhysX/UnrealEngine and the VXGI branch in particular is: https://github.com/NvPhysX/UnrealEngine/tree/vxgi4.8.2
                              Right; but the latest version is in "VXGI" branch once again, not "vxgi4.8.2". I'll ask the repo maintainer to delete the latter branch to avoid confusion.
                              https://github.com/NvPhysX/UnrealEngine/tree/VXGI

                              Comment


                                Oops my bad. Will make sure to point people to the right one in future
                                NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
                                Feel free to Donate if you wish to support me

                                Comment

                                Working...
                                X