Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by 동서대 View Post
    [ATTACH=CONFIG]53556[/ATTACH] [ATTACH=CONFIG]53557[/ATTACH] [ATTACH=CONFIG]53558[/ATTACH]
    Excuse me. Can i help me?
    I make hair with 3D MAX and Export Unreal Engine 4.
    I'm work export FBX and APX.
    I make Blueprint.
    So, FBX file and APX file was linked to a Blueprint.
    Success, hair put engraft characters about A-Pose.
    But, animated character failed engraft hair.
    Oddly, Nivida Hairworks Viewer program is no problem.
    Success, hair put enfraft animated characters.
    But, Unreal Engine 4 program is big problem.
    Not engrft.

    I don't know.
    Please, help me! [Sob][Sob]

    P.s Sorry not good at English.
    I'm Sorry, and Have a good day. Thank you.
    Your attachments don't work for me, are you sure you are using the same character in UE4 as the one you used to create the hair? Also I think the hair needs to be attached to the skeletal mesh in Blueprint to work, so its worth making sure. You can check out my tech demo located here: https://github.com/GalaxyMan2015/Unr...8_NVIDIA_Techs where I have the Epic character with skinned hair working.
    NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
    Feel free to Donate if you wish to support me

    Comment


      So i recompiled the VXGI branch and made sure to select NO when asked to overwrite files during compile and it worked!

      I only get like 2fps in the Sci-Fi corridor and i can't tell much from the cube so i will probably just wait for my new MSI GTX 980 TIs to get here before i start running tests with it in one of my current projects.

      I am going to try and recompile Flex now as well and see if it works.


      Twitter - @TheCSilverman

      Ancient Cistern | Advanced Material Pack Ed. 1 | Advanced Material Pack Ed. 2 | Advanced Material Pack Ed. 3 | Texture Pack Ed. 1 | Container Pack Ed. 1 | Road Sign Pack Ed. 1

      Comment


        Hi,
        I tried again to build the Unreal Engine 4.8 Gameworks Build with the archive, Galaxyman provided. But after I executed the Setup.bat file, I get the following error. Is there something wrong with the link? It seems that the path or the filename is too long.

        Do I need the commercial version of Visual Studio 2013 or can I use Visual Studio 2013 Express for Windows to compile the Build?

        Click image for larger version

Name:	error.JPG
Views:	1
Size:	37.7 KB
ID:	1084301

        Best regards, Andreas
        Last edited by Maxwell_77; 08-23-2015, 04:40 AM.

        Comment


          FWIW I had issues with VS 2015 Community. Trying the VS 2013 Community version, link is here: https://www.visualstudio.com/en-us/n...munity-vs.aspx

          Comment


            UE4 builds are only compatible with the 2013 edition of VS at the moment, at least last time i checked.

            Originally posted by srmojuze View Post
            FWIW I had issues with VS 2015 Community. Trying the VS 2013 Community version, link is here: https://www.visualstudio.com/en-us/n...munity-vs.aspx


            Twitter - @TheCSilverman

            Ancient Cistern | Advanced Material Pack Ed. 1 | Advanced Material Pack Ed. 2 | Advanced Material Pack Ed. 3 | Texture Pack Ed. 1 | Container Pack Ed. 1 | Road Sign Pack Ed. 1

            Comment


              So i have been messing with WaveWorks and the default material is kind of bland so i decided to add one of my custom water materials to the WaveWorks setup.

              My material adds View Distance LOD to the Tessellation, SubSurface Scattering, Refraction and Depth Bias Visibility. Hopefully there is a 4.8 update to the WaveWorks integration soon so we canhave ScreenSpace Reflections on transparency which seems to be the only shader method WaveWorks supports right now.

              Anyway, here's a quick video clip - 1080p @60fps



              Twitter - @TheCSilverman

              Ancient Cistern | Advanced Material Pack Ed. 1 | Advanced Material Pack Ed. 2 | Advanced Material Pack Ed. 3 | Texture Pack Ed. 1 | Container Pack Ed. 1 | Road Sign Pack Ed. 1

              Comment


                Originally posted by CharlestonS View Post
                UE4 builds are only compatible with the 2013 edition of VS at the moment, at least last time i checked.
                Oh OK cheers for info

                Comment


                  Hi,
                  I have succeeded to build the Gameworks Unreal Engine 4.8 Build. Thanks for your help. :-) But unfortunately the Build do not work. I tested it on my Windows 8.1 and Windows 10 system. I get the following error when I start the Unreal Engine:
                  Click image for larger version

Name:	error2.jpg
Views:	1
Size:	21.0 KB
ID:	1084356

                  Did I forgot something? I have no explanation for this error.

                  Best regards, Andreas

                  Comment


                    You need to recompile the ShaderCompilerWorker program, can be found under Programs in your visual studio solution explorer.
                    NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
                    Feel free to Donate if you wish to support me

                    Comment


                      Ah, ok. Thank you very much. :-)

                      Comment


                        @GalaxyMan The Build works !!! Fantastic. :-) Thank you very much. I noticed that I can only see the VXGI lighting when I push the play button. In my editor window everything is dark. (Lit mode) What should I do to solve this?

                        Best regards, Andreas

                        Comment


                          Make sure your post processing volume is unbound or your inside the PP volume in the editor. I have seen no issues with seeing VXGI in the editor. But will check for myself a bit later.
                          NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
                          Feel free to Donate if you wish to support me

                          Comment


                            The problem occurs in the first VXGI map of the NVTechDemos (VXGIExample) . My PostprocessVolume is set to unbound. But in my viewport everything is black.

                            Comment


                              Is also a Flex example project somewhere available?

                              Comment


                                The Tech Demos in my branch are mine, one of the VXGI maps has animated glowing balls, this will not work in the editor, as it uses a blueprint to change the colors. And currently I have not got a Flex demo, but you can take the Flex demo from the NVIDIA branch and convert to 4.8 and use in my branch
                                NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
                                Feel free to Donate if you wish to support me

                                Comment

                                Working...
                                X