Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by iuhiuh View Post
    packaging with my project works too, no flickering nothing http://prntscr.com/7nylmn
    Will that's fantastic news then!

    Comment


      Originally posted by Alexey.Panteleev View Post
      The latest development version of VXGI (will be released soon) supports environment maps for both diffuse and specular tracing, with tints.

      How do you want it to interact with skylights?
      In the master branch, skylights recently had an update that allows you to blend between environment maps, which would be useful for any situation that calls for a changing sky color (weather effects or day/night cycle being the obvious ones).

      Skylights when basing a scene off of VXGI also encounter a few problems when it comes to occlusion. Without DFAO to help it out, shadows don't get the same kind of occlusion that other lights would with VXGI, and makes it look a bit flat. The problem surfaces even more if a scene is partially indoors and partially outdoors, like if there's a building with a wall gone, where you can't outright disable the skylight since that would make all the shadows outdoors black, but keeping it on tints the entire interior of the building the color.

      Of course, having the skylight bounce and transmit lighting data would be nice as well, if an object is in shadow currently then it doesn't get -any- bounce light from below, even in the slightest, no matter how bright the shadow may be from the skylight.

      Skylights also don't contribute to the specular reflections as they are right now, it only shows the diffuse reflections if you look at an object that's using them. Makes it look a little weird, even adding an environment map to the specular (the option there currently) just fixes the background, with the objects casting shadows being pitch black where the shadows hit.

      Treating the skylight like an area light somehow (no idea if it would be too expensive to be viable) would help things. Ignoring the problems with reflections, missing out on that larger ambient occlusion does hurt the scene a lot. VXGI is already capable of producing results that have it, ideally it would also work for skylights.

      For an example, attached is an image of how things look now, if an object is inside a shadow. I have the skylight turned all the way up to 10 to exaggerate the effect a bit.

      https://dl.dropboxusercontent.com/u/...vxgi_black.png
      Last edited by Zero-Night; 07-02-2015, 04:30 PM.

      Comment


        hi,

        first thanks for these cool features. ive downloaded the turbulence branch and compiled it without errors. when i want to start the editor it crashes and gives me this error messages:

        Unknown exception - code 00000001 (first/second chance not available)

        Assertion failed: GPhysXFoundation [File:\UnrealEngine-Turbulence-4.7.6\Engine\Source\Runtime\Engine\Private\PhysicsEngine\PhysLevel.cpp] [Line: 407]

        KERNELBASE + 37901 bytes
        UE4Editor_Core!FOutputDeviceWindowsError::Serialize() + 285 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
        UE4Editor_Core!FOutputDevice::Logf__VA() + 248 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
        UE4Editor_Core!FDebug::AssertFailed() + 1079 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\core\private\misc\outputdevice.cpp:224]
        UE4Editor_Engine!InitGamePhys() + 220 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\engine\private\physicsengine\physlevel.cpp:407]
        UE4Editor!FEngineLoop::PreInit() + 7812 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\launch\private\launchengineloop.cpp:1219]
        UE4Editor!GuardedMain() + 251 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\launch\private\launch.cpp:110]
        UE4Editor!GuardedMainWrapper() + 26 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
        UE4Editor!WinMain() + 249 bytes [d:\unrealengine-turbulence-4.7.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
        UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

        i dont know nothing about coding. could someone plz help me. ive compiled as dev editor win64 and btw ive an amd card if that helps. thx


        ok i found the reason. ive said yes in the setup process stupid me. now the editor starts fine but there is the next problem. when i start the sample maps the emitters start emitting particles in a sphere but nothing else happens. there is no motion from those grids etc. what im doing wrong?are you able to sim fluids like gases in the newest flex branch? thx
        Last edited by olek; 07-03-2015, 06:00 PM.

        Comment


          hey galaxy one problem with your branch is the reflections, i could fix that problem in normal 4.8 ue4 branch turning the higehst AA on but even turning it on it doesnt fix it in your branch... whats causing it?
          http://prntscr.com/7oi61t when moving the camera does that issues..

          edit : shadow flickering aswell when they are much more hairworks models ( didnt happen with default branch )
          https://www.youtube.com/watch?v=AfZZjwK0OWE
          Last edited by iuhiuh; 07-04-2015, 03:56 PM.

          Comment


            Originally posted by iuhiuh View Post
            hey galaxy one problem with your branch is the reflections, i could fix that problem in normal 4.8 ue4 branch turning the higehst AA on but even turning it on it doesnt fix it in your branch... whats causing it?
            http://prntscr.com/7oi61t when moving the camera does that issues..

            edit : shadow flickering aswell when they are much more hairworks models ( didnt happen with default branch )
            https://www.youtube.com/watch?v=AfZZjwK0OWE
            It is likely a conflict between 4.8 and Nvidia code, Nvidia haven't officially ported it all to 4.8 yet so glitches will be very likely indeed!


            Also I am away on holiday now for 6 days, So i will be back to help out with any issues soon!

            Comment


              Originally posted by olek View Post
              ...the editor starts fine but there is the next problem. when i start the sample maps the emitters start emitting particles in a sphere but nothing else happens. there is no motion from those grids etc. what im doing wrong?...
              I've also got the same problem right now. The Turbulence 4.7.6 branch compiled with no errors, the editor launched without a hitch, but the sample maps show emitters with no working turbulence effects. I tried creating my own level map using the sample assets and a simple emitter from the starter content, but couldn't get any of the field samplers to work that way either. The only exceptions were the noise and attractor FS modules from within cascade, which worked fine, even though the same field samplers didn't work when placed directly in the scene via the FieldSamplerActor. I'm new to this so may be missing something simple, but so far I'm not seeing those awesome effects I've been salivating over.

              Comment


                Originally posted by Robert Gleaden View Post
                It is likely a conflict between 4.8 and Nvidia code, Nvidia haven't officially ported it all to 4.8 yet so glitches will be very likely indeed!


                Also I am away on holiday now for 6 days, So i will be back to help out with any issues soon!
                ok take your time and enjoy your holiday

                Comment


                  So I'm more the artist/engine tinkerer for my company and not a programmer (I know some but not anywere pro or anything) and I am really still new to GitHub etc etc. So my question is the release version of the nVidia/EpicGames if I am understanding is the version that has all of the GameWorks stuff in it but is based on 4.7.6? Just wondering cause I just converted our stuff to the newest 4.8.1 and I really like some of the features in 4.8 but the GameWorks would help out alot...I am just wondering which version to choose I'm assuming "Release" has all prior ones in it since in the comments it said release was merged with 4.7.6? Sorry for the somewhat dorky questions but like I mentioned I am very new to GitHub and still learning to code. I more an artist but I am trying to learn I just don't want to download/setup/compile "the wrong" version cause I selected the wrong branch. Hopefully that makes since. It's been a stressfull day.
                  Demented owner and founder of NeoSpawn Games
                  Current Project: Project Yami (place holder title) Next-Gen Fighter using UE4
                  FanPage: www.facebook.com/NeoSpawnGames
                  Official(under construction): www.neospawngames.net
                  Personal FB: http://www.facebook.com/Keiyentai
                  LinkedIn Profile: http://www.linkedin.com/in/Keiyentai

                  Comment


                    OK I got my answer and also thank you Galaxyman for the quick reply. I noticed a few people mentioning the flickering Deferred decals. I had the same issue since 4.4 and we use Deffered Decals for blood effects. Well I did some searching and even with DBuffer Decals on in the Editor Settings you still get flicker and baked lights are a problem but I found a fix which for some odd reason is the only way it works. It was "supposedly" fixed in 4.6 I think but I have had to do the following since but it works and does not mess anything up.

                    Go to C:\Program Files\Epic Games\4.8 (or the version you are using)\Engine\Config and you should see a BaseEngine.ini file
                    Double click it and it should open up in notepad or what ever text editor you use. Use the Find ctrl+f in notepad and type [system and hit next
                    It should hightlight [SystemSettings]

                    You should see: [SystemSettings]
                    ; NOTE THAT ANY ITEMS IN THIS SECTION WILL AFFECT ALL PLATFORMS!!!

                    and possibly some other commands but in 4.8.1 that is all that seems to be there.

                    Now add the following 3 lines

                    r.EarlyZPassMovable=1
                    r.EarlyZPass=2
                    r.DBuffer=1

                    under the first line and save then close. Open the engine and load your project and no DbufferDecals and regular Translucant ones will work with baked lights and have no flicker. I hope this helps and I can show how it looks too.
                    https://www.dropbox.com/s/auahoihkxq...Blood.jpg?dl=0 All the blood are deferred decals using DBuffer with those 3lines added. I will see if I can find a couple more but that was I want to say vanilla 4.5 or 4.6
                    Demented owner and founder of NeoSpawn Games
                    Current Project: Project Yami (place holder title) Next-Gen Fighter using UE4
                    FanPage: www.facebook.com/NeoSpawnGames
                    Official(under construction): www.neospawngames.net
                    Personal FB: http://www.facebook.com/Keiyentai
                    LinkedIn Profile: http://www.linkedin.com/in/Keiyentai

                    Comment


                      Noticed a bug in Galaxyman's build that isn't present in the release build. If normal CSM cascades + far shadow cascades = 5 or higher, the normal shadow cascades start to vanish closer to the camera. I'll try and see if I can find the commit that fixes it.

                      Edit: I'm clueless. If it was a bug present in the official build at any point and not just one that came up as a result of the Gameworks changes, it might have been fixed without a commit description specifically about that.
                      Last edited by Zero-Night; 07-07-2015, 03:27 PM.

                      Comment


                        I cant seem to clone th repository from git hub. I keep getting an error saying that Git could not clone the repository and that the connection reset. I'm a bit of a Git noob, so if anybody could help it would be greatly appreciated, thanks

                        Comment


                          I have done some research online and I think the problem is Gits timeout, I have a reliable yet not so fast internet so I was wondering does anybody here know how to change this timeout value as I cant seem to find it

                          Comment


                            Seems to be working now, I tried cloning it through PowerShell instead of the GitHub for Windows app

                            Comment


                              still waiting clean branch

                              Comment


                                Wow these are seriously impressive technologies! Thanks to Nvidia for implementing them! and thank you to Galaxyman2015 for bundling them into one branch! I've got everything up and working, but I noticed that tessellation doesn't seem to be supported in your branch Galaxyman2015. I searched for a solution but didn't see one.

                                Comment

                                Working...
                                X