Announcement

Collapse
No announcement yet.

NVIDIA GameWorks Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by 01767456513parag View Post
    Hi GalaxyMan2015,
    This Is My Problem....

    https://forums.unrealengine.com/show...terial-Problem

    By Default I Having This Problem......

    What Just I Did is...

    1. Download The Source Code From GitHub
    2. Run Setup And After Finish Download I Generate The Project File
    3. Compile It And Open The Editor And Create A Third Person Project...
    4. Just Drag And Drop The Material On The Floor.... And This Problem Appears...

    Please Help Me.....
    Does this have anything to do with my branch or the NVIDIA branch of UE4? There is an answer in that thread already. It is not actually an issue, its just the nature of UV's since they switched from BSP to static meshes (In BSP you could scale the texture on the surface, Static Meshes you cannot). You need to do as stated in the thread and modify the material to adjust the scaling. If this is not the issue (or it directly relates to NVIDIA or my branch) then please describe the issue in as much detail as possible.
    NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
    Feel free to Donate if you wish to support me

    Comment


      Originally posted by ankaZY View Post
      please!! i don't know why to imput hair.apx 导入'C:\Users\Devuser.Devuser-PC\Desktop\haiddr.apx'失败。创建资源'/Game/白虎/huren/haiddr'失败
      Maybe the asset was exported with old version of HairWorks.

      Comment


        Originally posted by lagdog View Post
        are there plans for a different method for grooming and creating curves other than shave and a haircut in maya for hairworks? that program is pretty outdated and clunky.
        if hair works just wants curves, a way to arrange those curves on the mesh with any plugin or program and for hairworks to accept it would be the best.
        for example being able to use zbrushes hair system to groom then create curves from it in maya, then importing that into hair works.
        I think you can do it by manually setting up a hair asset structure.

        Comment


          Hi,
          Is someone working on an exporter or a plugin for Blender, which can export splines or guide to hairworks viewer and UE4 ??

          Comment


            LOL, Galaxy i found the problem what was causing the memory downclock.. and it happend in 3ds max aswell so for sure it wasnt your branch,
            what i did is i went to Nvidia control panel and then change PhysX to CPU.. and THAT fixed my problem.. maybe its driver issues since its the first driver with GTX 980Ti :]
            hope nvidia going to fix it and again THX all the hard work galaxy

            edit :
            Titan X clock in 3dsMax.
            This is a very old issue going back years and it's caused by the Physx plugin. A quick fix is to go into your Nvidia Control Panel and under the Configure SLI, Surround, Physx settings, change the Physx setting to CPU.

            Or if you would like to keep Physx to use GPU (if you game), you can go into your 3ds max/stdplugs folder and scroll down to the physx.dlm file, rename it to physx.bak and restart 3ds max. You will be unable to use MassFX though by forcing the Physix plugin 3dmax to be disabled this way.
            Last edited by iuhiuh; 06-19-2015, 08:21 PM.

            Comment


              Hey guys, i was just wondering if anyone using the Turbulence branch has noticed how the particles seem to freak out when you move the camera around. It looks like the particle system resets after a few seconds and goes back to normal but as soon as you move the camera it freaks out again. If anyone else is seeing the same behaviour is there a simple fix? I am using a first person template pawn to run around with.

              Thanks guys.

              Comment


                zakman dont know how its looking like for you but here a video how it looks like
                https://www.youtube.com/watch?v=6A8awnIkb7E

                Comment


                  Hey iuhiuh, It looked the same for me before I made a new game mode and used a first person pawn. The problem only shows up when i'm using that pawn. If I remove the pawn and just fly around (it is set up this way by default), then I don't have any issues.

                  Comment


                    GalaxyMan2015, Thanks for the great efforts, dude.

                    Just tested your last 4.8 all-in-one build. All is great, except that VXGI Specular didn't work at all. I used a copy of a project made with Nvidia's 4.7.5 build, and it used to work flawlessly on that.

                    Any ideas??

                    Comment


                      It's been about a month now since we got our hands on that first sample of hairworks. Any word on any developments? Can't wait to see it with some more lighting features.

                      Comment


                        Originally posted by supermtf20 View Post
                        GalaxyMan2015, Thanks for the great efforts, dude.

                        Just tested your last 4.8 all-in-one build. All is great, except that VXGI Specular didn't work at all. I used a copy of a project made with Nvidia's 4.7.5 build, and it used to work flawlessly on that.

                        Any ideas??
                        I've been trying to debug what may be the same problem. Specular works fine in the editor, but in the game it takes a lot more time to produce an incorrect result. Diffuse works fine in both. If I change the ReflectionApply shader to just output the VXGI specular buffer, this is what it outputs in game vs editor:

                        Click image for larger version

Name:	vxgiGame.png
Views:	1
Size:	885.1 KB
ID:	1080198
                        Click image for larger version

Name:	vxgiEditor.png
Views:	1
Size:	718.8 KB
ID:	1080199
                        Andrew - Twitter - Web

                        Comment


                          Just Realized that you have to remove ALL reflection captures from scene in order for VXGI reflections to work.

                          Very strange, and it was never mentioned in Nvidia's UE4 VXGI documents.

                          Comment


                            Originally posted by supermtf20 View Post
                            Just Realized that you have to remove ALL reflection captures from scene in order for VXGI reflections to work.

                            Very strange, and it was never mentioned in Nvidia's UE4 VXGI documents.
                            Yeah I do recall having to do a similar thing actually, so when im testing VXGI, I have a level that has SSR turned off, no sphere reflections, and a skylight with a tiny intensity if any at all.
                            NVIDIA GameWorks merged branch (v4.9.2) (v4.12.5) (v4.13 p2)
                            Feel free to Donate if you wish to support me

                            Comment


                              I have just noticed that in the latest vxgi release, SSRs don't seem to be be working at all - even when turning off vxgi.
                              Is this the same with everyone else?

                              Comment


                                what? im on Galaxy man's build and its working perfect. Speculars reflections are all working..
                                Pursuit of Realistic Cinematic scene.

                                Comment

                                Working...
                                X