Announcement

Collapse
No announcement yet.

Cannot launch UnrealEngine Editor 4 on Fedora 31 after successful build

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot launch UnrealEngine Editor 4 on Fedora 31 after successful build

    After a successful build on Fedora 31, I am getting the following error in terminal log when launching the editor. This happens at around 96% of the launch.

    INTEL-MESA: error: ../src/intel/vulkan/anv_device.c:2760: GPU hung on one of our command buffers (VK_ERROR_DEVICE_LOST)
    [2020.03.23-17.03.13:389][ 2]LogVulkanRHI: Error: VulkanRHI::vkQueueSubmit(Queue, 1, &SubmitInfo, Fence->GetHandle()) failed, VkResult=-4
    at /home/johndoe/src/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanQueue.cpp:71
    with error VK_ERROR_DEVICE_LOST
    Fatal error: [File:/home/johndoe/src/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanUtil.cpp] [Line: 772]
    VulkanRHI::vkQueueSubmit(Queue, 1, &SubmitInfo, Fence->GetHandle()) failed, VkResult=-4
    at /home/johndoe/src/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanQueue.cpp:71
    with error VK_ERROR_DEVICE_LOST
    Signal 11 caught.
    Malloc Size=65538 LargeMemoryPoolOffset=65554


    Hardware Specs:

    Core(TM) i5-6200U CPU @ 2.30GHz
    with built-in processor Graphics Adapter HD Graphics 520

    Tried relaunching a couple of times and also increasing fs.notify.max_user_watches to around 1M. Didn't work. Anyone has had this experience? Any ideas?


    #2
    I don't know about the issue, but your GPU is below the minimum requirements to run UE4

    Comment


      #3
      I am running UE4 on a Macbook with similar CPU and built-in GPU. Since the error seems Vulkan-related, does Vulkan require special hardware specs?

      Comment


        #4
        I think for some Intel HD graphics chips, you need special drivers for Vulkan to be enabled. This might help:

        https://steamcommunity.com/app/22141...7264188882438/

        Comment


          #5
          Thanks Neoptolemus, installing vulkan-related packages like vulkan-tools, vulkan-loader, vulkan-headers, vulkan-validation-layers, and vulkan-loader-devel did not help.

          I think the following code is where the error occurs:

          Code:
          UE_LOG(LogVulkanRHI, Fatal,TEXT("%s failed, VkResult=%d\n at %s:%u \n with error %s"),
          ANSI_TO_TCHAR(VkFunction),(int32)Result,ANSI_TO_TCHAR(Filename), Line,*ErrorString);
          }
          File location:
          [File:UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanUtil.cpp] [Line: 772]

          Comment

          Working...
          X