Announcement

Collapse
No announcement yet.

Trouble to set up my Project with Pixel Streaming in 4.24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble to set up my Project with Pixel Streaming in 4.24

    Hi guys,

    I was reading all the new info added to the documentation of the new Pixel Streaming release but now my project doesn´t work properly because now the webRTC proxy folder doesn´t exist...


    In the previous version in 4.23.1 I followed all the steps to setup in LocalHost and everything works fine my workflow to set up the server was:

    1.- Start STUN Server
    Code:
    Listening at 0.0.0.0:19302
    2.- Start AWS TURN Server
    Code:
    Listening internally at 0.0.0.0:19303
    3.- Start de AWS with TURN
    Code:
    npm WARN cirrus-webserver@0.0.1 No repository field.
    npm WARN cirrus-webserver@0.0.1 No license field.
    
    audited 308 packages in 1.693s
    found 2 vulnerabilities (1 low, 1 moderate)
      run `npm audit fix` to fix them, or `npm audit` for details
    Running: node.exe cirrus --peerConnectionOptions="{ \"iceServers\": [{\"urls\": [\"stun:34.90.210.57:19302\",\"turn:34.90.210.57:19303\"], \"username\": \"MYUSERNAME\", \"credential\": \"MYCREDENTIALS"}] }" --publicIp=34.90.210.57
    09:29:25.625 configFile .\config.json
    09:29:25.635 Config: {
            "UseFrontend": false,
            "UseMatchmaker": false,
            "UseHTTPS": false,
            "UseAuthentication": false,
            "LogToFile": true,
            "HomepageFile": "player.htm",
            "AdditionalRoutes": {},
            "peerConnectionOptions": "{ \"iceServers\": [{\"urls\": [\"stun:34.90.210.57:19302\",\"turn:34.90.210.57:19303\"], \"username\": \"MYUSERNAME\", \"credential\": \"MYCREDENTIALS"}] }",
            "publicIp": "34.90.210.57"
    }
    09:29:25.637 No --PixelStreamingMonitorPort specified (or is 0). Running unmonitored.
    09:29:25.719 peerConnectionOptions = {"iceServers":[{"urls":["stun:34.90.210.57:19302","turn:34.90.210.57:19303"],"username":"MYUSERNAME","credential":"MYCREDENTIALS"}]}
    09:29:25.747 WebSocket listening to Streamer connections on :8888
    09:29:25.748 WebSocket listening to Players connections on :80
    09:29:25.749 Http listening on *: 80
    4.- Start WebRTC proxy

    5.- Open UE4 and run the server

    6.- Drop the IP in my web browser and works fine


    So wich is the problem now? That in 4.24 the WebRTC release 70 is already included in UE4 and I don´t know how to set it up. So my project doesn´t work now...

    Please anybody know how could I fix it for this version?

    Thanks!
    Last edited by noted1; 12-18-2019, 05:31 AM.

    #2
    Hello:

    Free server open for anyone like to connet and show your UE4 project., easily just setup Parameters from

    Unreal Editor, Under the Level Editor > Play category, find the Additional Launch Parameters setting, and set its value to -AudioMixer -PixelStreamingIP=65.52.189.204 -PixelStreamingPort=8889.

    Click image for larger version

Name:	ue4_editor_preferences_play.jpg
Views:	1068
Size:	121.2 KB
ID:	1711205
    More detail please check step how to connect free server
    http://renderstreaming.com/connect

    follow us https://forums.unrealengine.com/comm...gin-developing

    Comment


      #3


      I just published a video tutorial showing exactly how to setup remote Pixel Streaming in UE 4.24+
      Hopefully, it will be handy for you.
      No need for external services or other stuff.

      Enjoy

      Nazzareno Giannelli
      CTO | Senior 3D Artist
      myD3SIGN Ltd

      +39 335 13 12 044
      Skype: nazza87
      nazzareno@myd3sign.com
      www.nazzarenogiannelli.com

      Comment


        #4
        Cyberglobe mind looking at this ? https://forums.unrealengine.com/unre...ixel-streaming
        VR/AR Development [Portfolio | YouTube | LinkedIn]

        Comment

        Working...
        X