Announcement

Collapse
No announcement yet.

Client side lag when sprinting?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Client side lag when sprinting?

    Hey! So i have now tried so many times now to get sprint my clients to sprint smoothly but it looks like they are rubberbanding or lagging, the replication is there but actually running around is really laggy. Is there any easy solution for this? or what? The Server sees the client run perfectly and the client sees the server run perfectly. But it's the actual playing as client that is laggy/rubberbanding.


    I have been reading about this to use event tick just don't know how i would set that up in a correct way
    Also something about that the Character Movement is not replicated or idk

    Something is going on thats not supposed to happend! Could really use some help! I'm kind of new to unreal blueprints, i know basics so if you reply try be as tutorial ish. Looking up unreal problems is not the easiest! But hope my luck could be here to solve the issue!



    #2
    Are you setting the max walk speed on the server as well? If it is only set on the client, the client may simulate a faster speed locally, and rubber-band when the player's position is corrected to the actual value recognized on the server.
    Marketplace Assets

    Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
    Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
    Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

    Comment

    Working...
    X