Announcement

Collapse
No announcement yet.

Packaging project for Linux outputs nothing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Packaging project for Linux outputs nothing

    Hi all,

    I am actually new to UnrealEngine, and am not a game developer myself. I have been given the source of a particular simulator which I have performed a build on and can successfully open via Unreal Editor. I can even play the simulator from within Unreal Editor, so I know that's not an issue. Now, I need to create an executable for this game which can be copied around to other Linux machines where it can be played without needing the Unreal Editor. This is the part I am having trouble with.

    So far, I have followed two separate tutorials and tried to package for Linux, but once the "Packaging for Linux" message on the bottom right corner goes away, the directory I specified to package to is empty. Even during the packaging process, the directory remain completely empty. I have tried building every part first individually (lighting, maps, path), and then the whole thing at once. I have set the lighting to production, the build configuration to shipping, and removed all supported platforms except Linux. The icon, name description, etc... were already filled out since this is project was created beforehand. The staging directory was initially set to C;\ but since Linux doesn't have a file system like that, I just set it to my home directory. Afterwards, I selected File > Package Project > Linux then selected a new folder in my home directory. At that point the "Packaging for Linux" message comes up, and there are no errors in the log except for one:

    LogHttp: Warning: 0x7f05fc891f00: request failed, libcurl error: 35 (SSL connect error)

    The packaging finishes, but the directory is completely empty.

    I have also read in the forum that running as admin is necessary, but it is impossible to run Unreal editor with root privileges, so that's not an option.

    Please let me know what I'm doing wrong since I'm really new to this.

    Thanks in advance.

    #2
    I would check to see if the build was placed in ProjectFolder/Saved/StagedBuilds, ProjectFolder/Build, or ProjectFolder/Binaries .
    Marketplace Assets

    Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
    Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
    Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

    Comment


      #3
      Originally posted by Jamendxman3 View Post
      I would check to see if the build was placed in ProjectFolder/Saved/StagedBuilds, ProjectFolder/Build, or ProjectFolder/Binaries .
      Hi, where do you mean by ProjectFolder? Is it the place where the uproject file is? Because there is no folder called StagedBuild, and the Build and Binaries folders contain no executables.

      Also, I should mention that at the end of the packaging process the message logs shows an error: 'Unknown error'

      Comment


        #4
        Inside the project folder, yes. Unknown error means the packaging failed. Somewhere in the logs, there should be an indication as to what caused failure. I would start a new thread and post those logs to get that sorted out.
        Marketplace Assets

        Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
        Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
        Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

        Comment

        Working...
        X