Announcement

Collapse
No announcement yet.

Corrupt blueprints?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Update: I found a sort-of solution. Turns out that my anim blueprint was corrupt and I had to restore it, undoing a fair amount of work that I had done.
    https://forums.unrealengine.com/deve...rupt-blueprint

    Leave a comment:


  • replied
    Update:
    I've tried moving my blueprints to a different project and opening them and they crashed that instance of unreal as well. I'm at a loss as what to do. It seems my blueprints are just corrupt.

    Leave a comment:


  • started a topic Corrupt blueprints?

    Corrupt blueprints?

    I'm pretty new to Unreal and these forums as I've only recently come over from Unity so forgive me if I put this in the wrong category.
    I have a project that I've been working on for the past week or so and while there isn't a TON of stuff in it, I've still put a fair amount of time into it.
    Yesterday I was working on it just fine no problem. Today, when I got on and opened the project everything went fine until I tried to either;
    A) Opening either my character class blueprint or my animation blueprint
    B) Playtesting the game in the viewport (with the play button)
    C) Compiling the game
    D) Right-clicking either of the before mentioned blueprints in the content browser
    The engine would crash, giving me the crash report window.
    I'm at a loss here. I can still select things in the viewport or in the world outliner and edit them in the details pane but I can't edit my blueprints or test my game.
    Is this a common problem? Or did I somehow mess something up?
    Any help would be nice. I really don't want to have to figure out how to salvage all my assets and blueprints and import them to a new project or something.

    I've found that creating new blueprints and opening them works fine. Also, older blueprints that I haven't edited in a while also still work fine. The engine crashes when I open the two blueprints I've been working on lately; my character class blueprint and my animation blueprint, you know, the two with everything I've done so far. The project doesn't seem to be corrupted or anything but these two blueprints seem to have something wrong with them which is frustrating considering how much time I've spent in them. Please, any help would be appreciated.
Working...
X