Announcement

Collapse
No announcement yet.

Pixel streaming client server connection problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Pixel streaming client server connection problem

    I'm not able to get connected to the server using web server and proxy server setup provided https://docs.unrealengine.com/en-us/...PixelStreaming
    this works perfectly locally but not on a client-server setup or at least I can't get it working.
    Is there anyone who could help me with this?
    World's First Integrated Visualisation Solution: www.vastview.com.au
    World's Finest UE4 Assets: www.ue4asset.com

    #2
    Hey PersoDeath, how are you hosting the client-server - did it display any errors? Or maybe even just the web inspector tools and see if any error are outputted there for you verify what’s wrong.
    Last edited by Filmstorm; 11-21-2018, 06:59 AM. Reason: Left out the “you”

    Comment


      #3
      Ue4, webserver and proxy sever all are on an aws windows server 2016 ec2 instance.
      The only error as far as I see is Kiceconnectionfailed!
      World's First Integrated Visualisation Solution: www.vastview.com.au
      World's Finest UE4 Assets: www.ue4asset.com

      Comment


        #4
        Any progress on this front? I'm trying with an AWS G3 EC2 instance. I've got pixel streaming working locally on the server itself, and I can access the server from my local client, but it fails the same was as above. I've tried both the normal setup batch files as well as the AWS batch setup files, and the AWS + TURN batch files, no luck.
        Cameron Abt
        Founding Partner
        Atlas Bay VR

        Atlas Bay VR Logo

        Comment


          #5
          Originally posted by Cameron Abt View Post
          Any progress on this front? I'm trying with an AWS G3 EC2 instance. I've got pixel streaming working locally on the server itself, and I can access the server from my local client, but it fails the same was as above. I've tried both the normal setup batch files as well as the AWS batch setup files, and the AWS + TURN batch files, no luck.
          Hey Cameron Abt , which AWS instance have you used?

          Comment


            #6
            Originally posted by Edwar_Rojas View Post

            Hey Cameron Abt , which AWS instance have you used?
            I used the "g3s.xlarge" type instance (https://aws.amazon.com/ec2/instance-types/g3/). I had to make sure the STUN server was running as well as the TURN server, using the batch scripts provided.
            Cameron Abt
            Founding Partner
            Atlas Bay VR

            Atlas Bay VR Logo

            Comment


              #7
              Try making sure that the ports you're using for STUN and TURN are open to both UDP and TCP traffic.

              Comment


                #8
                Hi, i have the same problem.

                I used this AIM: "Microsoft Windows Server 2016 with NVIDIA GPU driver for G3 Locale English AMI provided by Amazon" with g3.4xlarge Instance.
                In the NVIDIA graphic settings there was displayed a Tesla M40 graphic card.
                I opened following ports in the AWS security group AND in Windows Firewall:
                TCP: 80. 443, 3389, 8888, 19302, 19303
                UDP: 8888, 19302, 19303

                First I tried the STUN and TURN server which are provided in the packaged game. Nothing happens. No WebRCT stream was visible in Browser.
                Then, I tried the same setup that I used for my Workstation behind a NAT:
                • STUN: stun1.l.google.com:19302
                • TURN: I rent a cheap cloud instance (3 EUR/Month) with Ubuntu 16.04 and install coTurn on this machine (https://github.com/coturn/coturn)
                That works like a charm in the office. I could access the WebRTC even with mobile phone. Only clients behind proxys had connection problems.

                But with AWS i couldn't see a stream. I didn't had a connection error in WebRCT Proxy, because I was able to watch on the separate coTurn server my address binding.

                Do anyone have some suggestions?

                Comment


                  #9
                  Originally posted by rgbfreak View Post
                  Hi, i have the same problem.

                  I used this AIM: "Microsoft Windows Server 2016 with NVIDIA GPU driver for G3 Locale English AMI provided by Amazon" with g3.4xlarge Instance.
                  In the NVIDIA graphic settings there was displayed a Tesla M40 graphic card.
                  I opened following ports in the AWS security group AND in Windows Firewall:
                  TCP: 80. 443, 3389, 8888, 19302, 19303
                  UDP: 8888, 19302, 19303

                  First I tried the STUN and TURN server which are provided in the packaged game. Nothing happens. No WebRCT stream was visible in Browser.
                  Then, I tried the same setup that I used for my Workstation behind a NAT:
                  • STUN: stun1.l.google.com:19302
                  • TURN: I rent a cheap cloud instance (3 EUR/Month) with Ubuntu 16.04 and install coTurn on this machine (https://github.com/coturn/coturn)
                  That works like a charm in the office. I could access the WebRTC even with mobile phone. Only clients behind proxys had connection problems.

                  But with AWS i couldn't see a stream. I didn't had a connection error in WebRCT Proxy, because I was able to watch on the separate coTurn server my address binding.

                  Do anyone have some suggestions?
                  on aws use turn batch file written for aws. Just lunch all batch file writen specially for aws turn. And it will work out of the box. And will be accessible from all crome firefix browser from any device in any part of the world
                  Need help or work to be done?
                  Contact Info

                  Comment


                    #10
                    Hello,
                    i've an UE4 application on EC2 / GPU ... Pixel Streaming ok.
                    But the sound is not stream if i shutdown my rdp connexion.
                    So, i've installed Virtual Audio Cable... and ok... no sound via RDP when i connect - but sound via Pixel Streaming... good.
                    But if i shutdown rdp again... no sound in Pixel Streaming.
                    What have you done ?
                    My blog about video game development and game engines (FR + Translation)
                    My books about Unreal Engine 4 & Blender Game Engine (FR only)
                    Facebook - Twitter - Youtube

                    Comment


                      #11
                      Has there been any resolution to this yet? I was able to get the pixel streaming to work perfectly on my local network across all my devices, but when I set up port forwarding to my desktop I end up stuck at the same page as the OP. The link even works when I'm connected to my wifi, but as soon as I use cellular service, it just gets stuck trying to connect to the server. Seems like a lot of people have been posting this same problem, but no one has found a work around for it. Click image for larger version

Name:	IMG_2418.PNG.png
Views:	167
Size:	67.9 KB
ID:	1694834

                      Comment

                      Working...
                      X