Announcement

Collapse
No announcement yet.

Setting up Perforce (Solved)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Setting up Perforce (Solved)

    I have a Windows 10 laptop I am going to use as a dedicated server for Perforce. I have Windows 7 Desktop that I will be working from. I have no experience with setting up Perforce. I seem to be doing some fundamentally simple thing wrong and cant get it set up right. I am not even sure it I'm even installing the right applications in the right places for what I am trying to setup. Any advice on what to do will help immensely.
    Last edited by Seed 37; 04-01-2018, 02:44 PM.

    #2
    Hey there Seed 37!

    Here is a tutorial series that should point you in the right direction. https://www.youtube.com/watch?v=HOaDZEG49Z4

    Simulacrum Game | Play The Alpha | Caldera Entertainment | Twitter | ArtStation

    Comment


      #3
      Hi SE_JonF, Thanks for the speedy reply. I have watched and fallowed that tutorial and while I got a better understanding of perforce it seemed to be slightly outdated and I could not get it to work right. I have also read tutorials and watched the few videos I could find, spent some time over the last 2 weeks trying to get this set up right.

      I am currently trying to fallow this Link

      I guess a good question to start with is; What program do I need to install on the laptop first? p4v p4d p4s.
      Last edited by Seed 37; 03-27-2018, 08:51 AM.

      Comment


        #4
        Made some progress this morning.

        I installed p4d to the laptop then p4v (Said I can't use DVCS hope I don't need it) and I got it to connect with p4admin. But I cannot connect from the desktop. When I installed p4d I made it localhost:1666. When I try to connect I use ***.**.***.***:1666 and get this error.

        Connect to server failed; check $P4PORT.
        TCP connect to ***.**.***.***:1666 failed.
        connect: ***.**.***.***:1666: WSAETIMEDOUT


        -Edit-
        Almost there,
        It was a firewall problem on the laptop Solved Here.
        Last edited by Seed 37; 03-27-2018, 04:03 PM. Reason: Progress

        Comment


          #5
          Got most everything set up now for the project. I haven't bin able to get the ignore list setup right yet.

          my ignore list is

          # Ignore project files in the root
          *.sln
          !*\*.sln
          .vs
          *.suo
          *.opensdf
          *.sdf
          *.pdb
          *-Debug.dll
          *.xcodeproj
          .\Makefile
          .\CMakeLists.txt
          .\.ue4dependencies

          ipch\*

          # Derived data cache should never be checked in
          Engine\DerivedDataCache\*

          # Engine intermediates
          Engine\Intermediate\*
          Engine\Plugins\*\Intermediate\*

          # Intermediate folders created for various C# programs
          Engine\Source\Programs\*\obj\*

          # Saved folders for programs should not be checked in
          Engine\Programs\*\Saved\*
          Engine\Programs\UnrealBuildTool\*

          # Intermediate folders for programs should not be checked in
          Engine\Programs\*\Intermediate\*

          # Ignore any saved local files
          Engine\Saved\*

          # Ignore any build receipts
          Engine\Build\Receipts\*

          # Ignore Unix backup files
          *~

          # Ignore Mac desktop services store files
          .DS_Store

          # Ignore crash reports
          crashinfo--*

          # Ignore linux project files
          *.user
          *.pro
          *.pri
          *.kdev4

          # Ignore project-specific files
          HowWorldsEnd\Binaries\*.pdb
          HowWorldsEnd\Binaries\*-Shipping.*
          HowWorldsEnd\Build\Receipts\*
          HowWorldsEnd\DerivedDataCache\*
          HowWorldsEnd\Intermediate\*
          HowWorldsEnd\Saved\*
          HowWorldsEnd\*.sln

          I copy and pasted this one and changed the project filepath then ran the command line but when i test it by reconcile offline work on the Saved folder it marks all of them for add.

          Comment


            #6
            Be sure to setup typemap on the server (your laptop) see https://docs.unrealengine.com/en-us/...ntrol/Perforce

            As for p4ignore, did you run:
            p4 set P4IGNORE=.p4ignore.txt on the client?
            https://www.casualdistractiongames.com

            Comment


              #7
              Just double checked the typemap and that is set up right as far as I know.
              re ran p4 set P4IGNORE=.p4ignore.txt just to be sure

              Also the folder structure is like this;
              Click image for larger version  Name:	Capture.PNG Views:	1 Size:	40.8 KB ID:	1452370



              This is from my desktop PC the Depot is on the laptop.
              the only files i actually added was everything in HowWorldsEnd except the saved folder
              I did not add the UE_4.19 yet.

              also do you have to run p4 set P4IGNORE=.p4ignore.txt every time you change the .p4ignore.txt file?
              Last edited by Seed 37; 03-29-2018, 10:58 AM. Reason: Picture edit

              Comment


                #8
                I did not have the full file path name in the ignore file. I also copy/pasted the typemap from https://docs.unrealengine.com/en-us/...ntrol/Perforce just in case.

                Click image for larger version

Name:	Capture2.PNG
Views:	919
Size:	52.6 KB
ID:	1452442
                Ill edit later as solved once I test a few things.

                Notes
                1) Check all firewalls including your router for Initial connection problems.
                2) File Path Names Are Important.
                3) Watch or read the entire tutorial series first, including comments. Then start.

                Tutorials and Information I used to set this up.

                https://docs.unrealengine.com/en-us/...ntrol/Perforce
                https://www.youtube.com/watch?v=HOaDZEG49Z4
                https://allarsblog.com/2017/04/05/po...-source-build/


                Thank you SE_JonF and OptimisticMonkey for the feedback.

                Comment


                  #9
                  Hey Seed 37 ,

                  It looks like you had some success setting up your Perforce server.

                  I wanted to ask if the ignore list you pasted above has behaved well for you? Did you edit it further after posting?

                  Cheers.

                  Comment

                  Working...
                  X