Announcement

Collapse
No announcement yet.

Steam App ID Not Working...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Steam App ID Not Working...

    I have successfully gone through the Steam Greenlight process and I have received my Steam App ID for Riders of Asgard. I have also successfully integrated the Steam Online Subsystem as well as the Advanced Sessions plugin and everything works fine when I am using the default App ID of 480.

    As soon as add my Steam App ID nothing seems to work.

    Is there some trick to using your own Steam App ID?
    Quinton Delpeche
    Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

    #2
    I'm also stuck on this Issue. Did you ever figure it out?

    Comment


      #3
      No I did not come right ... I am still not able to test my game using my provided Steam APP ID.
      Quinton Delpeche
      Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

      Comment


        #4
        Originally posted by qdelpeche View Post
        No I did not come right ... I am still not able to test my game using my provided Steam APP ID.
        Sorry to hear that. Its disheartening for anyone looking ahead to launch.
        Had hoped by now there would be a simple reliable roadmap for Steam...
        Yet here we are in 2017 & the usual Steam probs continue to trip devs up.

        Comment


          #5
          I have run into this problem too.
          Full Time UE4 Tutor! www.tesla-dev.com
          Watch, Learn & Create using my tutorials here: *https://www.youtube.com/playlist?lis...8Zjziv4gUqjLZ_*

          Comment


            #6
            [MENTION=1883]Tesla[/MENTION] and [MENTION=665020]xiaoshumiao[/MENTION] and [MENTION=5085]bigpapaleo[/MENTION] ... do you think this is a Steam problem or an Unreal Engine problem. I have tried a few other things and yet I am still not able to test it. My next step is to try the Steam Setup Utility, but at the moment I am not too optimistic.

            I would like to hear from other developers who have released a Steam game using Unreal Engine.

            EDIT: I posted a question on the Steamworks Development group ... will see what responses I get there.
            Last edited by qdelpeche; 01-12-2017, 12:16 AM.
            Quinton Delpeche
            Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

            Comment


              #7
              Okay ... it is as I suspected ... you need to have your base packages up on Steam first as Steam doesn't know you have the game in your library.

              If you don't have your standard packages, you don't own a copy of your game, and the API isn't going to initialize. Generally the first thing to do after creating an app is to check whether the standard packages are present, otherwise you're going to have headaches.

              Note that packages aren't the same as depots; check your related items page and see if you have a store package up top and a yellow and a red package near the bottom.
              So, I will spend some time getting this all working and I will even get a demo of Riders of Asgard up on Steam. Hopefully then I can move forward, so many hoops. 8-}
              Quinton Delpeche
              Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

              Comment


                #8
                Okay ... so to everyone who is having this problem, it turns out that sometimes the default packages don't get created and you need to get Steam to add them. There is a quick way to check and I have added some screenshots to show you what you should be looking for.

                Log on to your Steam Partner page and go to the main page of your game.

                Check if you have something similar to the below image listed at the top of the page:
                Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	16.0 KB
ID:	1121274

                If you don't then you need to contact Steam Partner Support to get it added. You can confirm it is added by clicking on the link below, on the same page:

                Click image for larger version

Name:	Capture_1.PNG
Views:	1
Size:	7.9 KB
ID:	1121275


                And then looking for these entries near the bottom of the resulting page:

                Click image for larger version

Name:	Capture_2.PNG
Views:	1
Size:	21.4 KB
ID:	1121276


                If all that is there then your default packages are correct and it should all work. If none of those entries are there, contact Steam Partner Support and they will quickly add it for you. I got mine added by joining the Steamworks Development Group (http://steamcommunity.com/groups/steamworks) and asking for help there: http://steamcommunity.com/groups/ste...3248270856551/

                Steamworks Partner Support saw my post, checked my app and added the packages for me ... and so now when I am testing my game with Steam logged in and the Steam subsystem configured, I finally have this:

                Click image for larger version

Name:	20170113064708_1.jpg
Views:	1
Size:	203.6 KB
ID:	1121277


                [MENTION=5085]bigpapaleo[/MENTION] [MENTION=11397]franktech[/MENTION] [MENTION=665020]xiaoshumiao[/MENTION] [MENTION=1883]Tesla[/MENTION] So for those of you struggling with this, it was a Steam problem and not an Unreal Engine problem and the only way to get it resolved is to get in touch with Steam Partner Support. I must also reiterate that this doesn't always happen.
                Quinton Delpeche
                Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

                Comment


                  #9
                  Kudos! Cheers and good luck with Riders of Asgard...

                  Comment


                    #10
                    NICE!! I'm out of town right now. I'll try it out soon. Thanks for sharing!!

                    Comment


                      #11
                      It worked! Thank you for your help [MENTION=22376]qdelpeche[/MENTION]!!!

                      Comment


                        #12
                        [MENTION=5085]bigpapaleo[/MENTION]: Glad you came right and I am glad I could help. 8-}
                        Quinton Delpeche
                        Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

                        Comment


                          #13
                          Hi [MENTION=22376]qdelpeche[/MENTION] I actually haven't had this problem but I'm facing some different issues with steam, maybe you could help me out, I'll link you to my thread so I don't high jack yours https://forums.unrealengine.com/show...or-non-c-users

                          thanks in advance

                          Skywalker "this is not going to go the way that you think" PORTFOLIO

                          Comment


                            #14
                            Thanks for the solution. I will try doing this as soon as I can.

                            Comment

                            Working...
                            X