Announcement

Collapse
No announcement yet.

[FREE] ThirdPerson Action Platformer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Substance SHIFT View Post
    Hello guys, i just downloaded this and its not working on my UE 4.15 features barly working, the climbing doesnt do animation when climbing ( not like shown in video)
    and the grappling hook doesnt work even if i press the button
    only thing working ( changing characters - duble jump - and first person mode) ANY HELP APPRECHATED
    Hey there,

    Currently the animations are not included because they are from Mixamo and the Marketplace (Kubold), so I cannot include them. However another dev is working on custom animations for the template that will be included when they are ready . Keep an eye on this thread for the update with all animations included and working!!

    Leave a comment:


  • replied
    Originally posted by razmaz51 View Post
    yea I got it going , thanks for your help. and instead of changing the collision on my character , I changed the collision on the teleports to match my character.
    Glad you got it working

    Leave a comment:


  • replied
    Hello guys, i just downloaded this and its not working on my UE 4.15 features barly working, the climbing doesnt do animation when climbing ( not like shown in video)
    and the grappling hook doesnt work even if i press the button
    only thing working ( changing characters - duble jump - and first person mode) ANY HELP APPRECHATED

    Leave a comment:


  • replied
    yea I got it going , thanks for your help. and instead of changing the collision on my character , I changed the collision on the teleports to match my character.

    Leave a comment:


  • replied
    Originally posted by razmaz51 View Post
    Ok so thanks , that worked , sort of. So in teleport bp I casted to my character and in settings , set his collision to "pawn" (like the template character). if I put 2 teleports out on a level , set teleport 1 to go to teleport 2 , and teleport 2 to go to teleport 1, it works , I step on teleport 1 , it takes me to teleport 2, then almost immediately back to teleport 1. then the 2nd time I step on teleport 1 , it takes me to teleport 2 and he stays there. if I set teleport 2 to " none " , then teleport 1 takes me to teleport 2 , then it throws me off about 20 feet randomly out on the level and gives me this error. ----------------------------------- Blueprint Runtime Error: Accessed None trying to read property TeleportTo from function: 'ExecuteUbergraph_TeleportBP' from node: SetActorLocation in graph: EventGraph in object: TeleportBP with description: Accessed None trying to read property TeleportTo---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Does teleport 2 have to be set to something?It works ok if I just set teleport 2 to go to teleport 2.
    Make sure each teleport references each other (Teleport 1 -> Teleport 2, Teleport 2 -> Teleport 1). Then Make Teleport 2 Inactive (Make Active boolean false). Im at work so going by memory, but I think thats how I set them up. Basically, make the first teleport the Player will use Active and the other Inactive.

    Let me know if that works

    Leave a comment:


  • replied
    only other thing is , setting collision to "pawn" breaks some of my project things. as my character is set to " world dynamic".

    Leave a comment:


  • replied
    Ok so thanks , that worked , sort of. So in teleport bp I casted to my character and in settings , set his collision to "pawn" (like the template character). if I put 2 teleports out on a level , set teleport 1 to go to teleport 2 , and teleport 2 to go to teleport 1, it works , I step on teleport 1 , it takes me to teleport 2, then almost immediately back to teleport 1. then the 2nd time I step on teleport 1 , it takes me to teleport 2 and he stays there. if I set teleport 2 to " none " , then teleport 1 takes me to teleport 2 , then it throws me off about 20 feet randomly out on the level and gives me this error. ----------------------------------- Blueprint Runtime Error: Accessed None trying to read property TeleportTo from function: 'ExecuteUbergraph_TeleportBP' from node: SetActorLocation in graph: EventGraph in object: TeleportBP with description: Accessed None trying to read property TeleportTo---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Does teleport 2 have to be set to something?It works ok if I just set teleport 2 to go to teleport 2.
    Last edited by razmaz51; 07-10-2018, 09:24 PM.

    Leave a comment:


  • replied
    Originally posted by razmaz51 View Post
    i tried , but it made no difference. the collision box on it wont even let me on it. if i shrink the box I can get on but don't do nothin. thanks for help
    Hey there,

    Its been a while since I've looked at the code so I cant recall exactly. But, it sounds like you need to change the collision settings on your character and teleport trigger. Make sure you match collision settings of your character to the character that comes with the template. Also, take a look at the teleportBP code and change any reference to the original character to yours.

    Hope this helps!

    Leave a comment:


  • replied
    i tried , but it made no difference. the collision box on it wont even let me on it. if i shrink the box I can get on but don't do nothin. thanks for help
    Last edited by razmaz51; 07-09-2018, 09:21 PM.

    Leave a comment:


  • replied
    r u using the player character from this or from your project? If yours make sure you change the casting in the teleport BP.

    Leave a comment:


  • replied
    Is it possible to use some of the blueprints in another project? I migrated over and portal or teleport dont seem to work with my character. When i try to step on teleport the overlap box acts like a blocking volume and wont let me on it. Portal , he just walks up to it , dont do anything.

    Leave a comment:


  • replied
    thanks for replying. please let us know if you get the anims in. I had better luck with medifire this time.
    Last edited by razmaz51; 07-09-2018, 05:39 PM.

    Leave a comment:


  • replied
    Originally posted by razmaz51 View Post
    did you ever get the animations in this? also is mediafire link the only place to get this? no less than 27 bloatwares and adwares.
    Hey there,

    I'm working with a dev to add custom animations and things are coming along nicely. I don't have a specific date, but hopefully very soon . As far as Mediafire, are you having any issues? I'm thinking about creating a Github account and hosting everything there!

    Thanks for the comment!

    Leave a comment:


  • replied
    did you ever get the animations in this? also is mediafire link the only place to get this? no less than 27 bloatwares and adwares.
    Last edited by razmaz51; 07-07-2018, 11:52 AM.

    Leave a comment:


  • replied
    Originally posted by Ozcorps View Post
    Much love for the project
    would you mind i scout over and remake in tutorial form..
    im bored and you have a lot of functions here...
    so wanna give back like you have


    let me know
    Thanks again

    PSS.. gonna test in latest Version and ill let yah know issues if any arise
    Hey Ozcorps,

    I don't mind at all! Feel free to go through the Blueprints and make tutorials out of them

    Leave a comment:

Working...
X