Announcement

Collapse
No announcement yet.

Large useful blueprint function library (Morepork Games)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    This is absolutely awesome.
    Thank you for sharing this.

    Comment


      #47
      First off, Thank you!
      In a 16.1 project, I've opened and saved MoreporkMacrosActor and MoreporkMacros, yet I still get a compile errors here:

      Get All Actors Renderable
      Location is within Volume

      Click image for larger version

Name:	MorePork_Compile_Error.jpg
Views:	1
Size:	300.9 KB
ID:	1129723
      Click image for larger version

Name:	MorePork_Compile_Error2.jpg
Views:	1
Size:	282.4 KB
ID:	1129724
      Jonah Hawk
      Associate Partner
      Design Visualization
      ZGF Architects LLP
      Portland - Seattle - LA - DC - NYC - Vancouver, BC
      Architect 50 #1

      Comment


        #48
        Thanks for the pics - I'll replace those with collapsed nodes, but I won't be at a PC for a while - in the mean time if you'd like to fix it yourself you can place new versions of those macros - the first one is the "Is Empty" macro and the second is the "Compare Class" Macro. Then recompile and should be all good
        Dev Blog
        Twitter: @TheRealSpoonDog
        150 FREE Blueprint functions for your project

        Comment


          #49
          Thanks for the quick fix.

          Fantastic work, really cuts down on the clutter.
          Jonah Hawk
          Associate Partner
          Design Visualization
          ZGF Architects LLP
          Portland - Seattle - LA - DC - NYC - Vancouver, BC
          Architect 50 #1

          Comment


            #50
            So I've unzipped and copied the .uassets into my content folder, but they're not showing up in the editor?

            I'm using 4.15.3.

            Comment


              #51
              This helped me in 4.16

              Comment


                #52
                Thank you so much!!!

                Comment


                  #53
                  I just installed 16.2 because I couldn't find the blueprint actors in the content browser as well, but the problem still remains. I'm not sure why it doesn't see them. Any ideas?

                  Comment


                    #54
                    I just installed 16.2 because I couldn't find the blueprint actors in the content browser as well, but the problem still remains. I'm not sure why it doesn't see them. Any ideas?
                    I think your engine installation may be confused for some reason - try this:

                    1. With the editor closed, remove my functions from your project, then delete your Intermediate & Saved folders
                    2. Open the editor
                    3. Add my functions to your project again - you should see the content browser update after you've pasted them in explorer

                    (you may have to do the macro fixes mentioned above too)
                    Dev Blog
                    Twitter: @TheRealSpoonDog
                    150 FREE Blueprint functions for your project

                    Comment


                      #55
                      Originally posted by Spoondog View Post
                      Thanks for the pics - I'll replace those with collapsed nodes, but I won't be at a PC for a while - in the mean time if you'd like to fix it yourself you can place new versions of those macros - the first one is the "Is Empty" macro and the second is the "Compare Class" Macro. Then recompile and should be all good
                      Seems there are more of those dead macros, e.g. in Frame Delay, Fade With Notification.
                      My understanding is that it is a reference issue between the 4 files?
                      Could you maybe upload a project where you have the library set up, then we could just migrate the files.
                      Last edited by Cpt.Trips; 11-22-2017, 08:09 PM.
                      [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
                      [Free][Script] Automate Download of Mixamo Animations
                      [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

                      Comment


                        #56
                        Originally posted by Cpt.Trips View Post

                        Seems there are more of those dead macros, e.g. in Frame Delay, Fade With Notification.
                        My understanding is that it is a reference issue between the 4 files?
                        Could you maybe upload a project where you have the library set up, then we could just migrate the files.
                        Thanks for the heads up - it's just macros or functions that have another MPG macro in them.. I'll add those to the list to fix up for next release. Sorry for the delay I'm pretty booked up, and yea maybe uploading a project might be better next time.

                        If you want to fix them locally in the mean time - just re-place the "ForLoop Wait" macro in the Frame Delay, and re-place them "Fade" macro in the Fade With Nofitication:

                        Click image for larger version

Name:	framedelay.PNG
Views:	10
Size:	51.3 KB
ID:	1395753

                        Click image for larger version

Name:	fadewithnotif.PNG
Views:	7
Size:	135.1 KB
ID:	1395754
                        Dev Blog
                        Twitter: @TheRealSpoonDog
                        150 FREE Blueprint functions for your project

                        Comment


                          #57
                          Haven't looked through all of it, I suspect there might be more broken macros. Project upload would be the best solution.
                          [Marketplace] Loading Screen System (ᴘʀᴏᴘᴇʀ ʟᴏᴀᴅɪɴɢ sᴄʀᴇᴇɴs, ɴᴏᴡ ᴡɪᴛʜ ᴘʀᴏɢʀᴇss ʙᴀʀs)
                          [Free][Script] Automate Download of Mixamo Animations
                          [VłĐɆØ] Performance: BP vs C++ vs Blueprint Nativization

                          Comment


                            #58
                            I concur, sample project would be probably most foolproof.
                            I tried to place it to 4.18 project and got few errors. Then I decidet to read the manual. Made new 4.16.3 project, opened and saved nodes in correct order. Still got errors. Here are the screenshots, hopefully it will help.
                            Oh, and thank you for this library. Haven't tried it yet because of the errors but the list of nodes seems super useful. Thanks!


                            Last edited by Harcarik; 12-10-2017, 08:20 PM.

                            Comment


                              #59
                              I was able to get it working in a 4.17.2 custom source build. Should pretty much apply to Epic Launcher install as well, for 4.16 and up. Just go back and read the thread, the fixes are there. It's only 4 pages

                              Thanks by the way, always nice to expand the arsenal of tools! You rock Spoondog !

                              Comment


                                #60
                                You are almost correct and I was mostly wrong. I managed to fix 2 of three issues, thanks for pointing it that out. There is still one invalid macro instance shown in the last image I posted (MorePorkUMGfade). Could you please tell me the name of that macro? Thank you.

                                Comment

                                Working...
                                X