Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by MagnusAnder View Post
    Hi. thanks for the plugin.
    I had the voice working in my project in 4.15 but I can't get it to work in 4.16.3
    Any idea what the issue might be? any changes or things i need to do?
    I got it working again. I was playing around with the new audio stuff some time ago and I guess that was what broke it.

    Comment


      Originally posted by mordentral View Post

      What subsystem are you using? Also are you actually hosting a session first? Its working fine for me.
      Subsystem would be Steam?

      I am inside a Session with 'LobbyGameMode', than I try to send a change of the 'Extra Settings' at the the same Game Mode with Get Session Settings, but it always go to 'On Failure'.
      =============

      Ok, while writing this I found out that in Standalone with Steam open it works, everything is ok everyone.

      Comment


        Originally posted by HeliaXDemoN View Post

        Subsystem would be Steam?

        I am inside a Session with 'LobbyGameMode', than I try to send a change of the 'Extra Settings' at the the same Game Mode with Get Session Settings, but it always go to 'On Failure'.
        =============

        Ok, while writing this I found out that in Standalone with Steam open it works, everything is ok everyone.
        Steam doesn't actually host a session unless you are in packaged or standalone, this is because in PIE and PIE in seperate window the EDITOR itself hosts a session outside of the session system for simulating network play.

        Generally you want to run in standalone to test for steam stuff.


        Consider supporting me on patreon

        My Open source tools and plugins
        Advanced Sessions Plugin
        VR Expansion Plugin

        Comment


          Originally posted by eXi View Post
          Nice! Though i won't use this. Still waiting for Epic to release this for BPs themself. Can't put a project on the Market with a Plugin in it. :/
          is this still correct cant put a project on the market with plugins, if so why is that?

          Comment


            Originally posted by crazykiwiman View Post

            is this still correct cant put a project on the market with plugins, if so why is that?
            He had a "Marketplace" project for he wanted to sell, requiring it to support a third party plugin let alone back before plugins could even be in the marketplace wasn't going to happen.

            He wasn't talking about a game or program.


            Consider supporting me on patreon

            My Open source tools and plugins
            Advanced Sessions Plugin
            VR Expansion Plugin

            Comment


              I've been having a problem with the Create Session Node on this. Basically, it outputs an error in the log "Steam: Cannot Create Session Game, Session Already Exists." Anyone else having these problems? Using the normal Create Session works, and so does all the other Advanced nodes, such as Find Session.

              Comment


                Originally posted by Discodude16 View Post
                I've been having a problem with the Create Session Node on this. Basically, it outputs an error in the log "Steam: Cannot Create Session Game, Session Already Exists." Anyone else having these problems? Using the normal Create Session works, and so does all the other Advanced nodes, such as Find Session.
                Where are you calling it / has it already been called once?


                Consider supporting me on patreon

                My Open source tools and plugins
                Advanced Sessions Plugin
                VR Expansion Plugin

                Comment


                  I'm using AdvancedSessions with Steam on Windows and am able to Create and Join a session successfully, however the session state on the client always returns "Pending" when calling GetSessionState. The host returns "In Progress" as the session state. I can see the other player and replication is working fine. I'm wondering why the call to GetSessionState always returns pending on the client. Is that normal? If not, then what might I be doing wrong.

                  Comment


                    Originally posted by mordentral View Post

                    Where are you calling it / has it already been called once?
                    Ive been calling it in a non-replicated function in the game instance, and this is only being called once. It does work if I replace it with the normal Create session node if that helps.

                    thanks for the reply!

                    Comment


                      Originally posted by AlfornoOne View Post
                      I'm using AdvancedSessions with Steam on Windows and am able to Create and Join a session successfully, however the session state on the client always returns "Pending" when calling GetSessionState. The host returns "In Progress" as the session state. I can see the other player and replication is working fine. I'm wondering why the call to GetSessionState always returns pending on the client. Is that normal? If not, then what might I be doing wrong.
                      Yea...clients only ever set it to pending in the subsytem code from a brief glance.

                      Its primarily used on the server side to know when to end a server.



                      Consider supporting me on patreon

                      My Open source tools and plugins
                      Advanced Sessions Plugin
                      VR Expansion Plugin

                      Comment


                        Originally posted by Discodude16 View Post

                        Ive been calling it in a non-replicated function in the game instance, and this is only being called once. It does work if I replace it with the normal Create session node if that helps.

                        thanks for the reply!

                        You have to be calling it twice somehow, that warning is specifically when there is already a created session and the actual create session code is the exact same between my nodes and the standard ones.

                        Did you check to see if there is a working session up?


                        Consider supporting me on patreon

                        My Open source tools and plugins
                        Advanced Sessions Plugin
                        VR Expansion Plugin

                        Comment


                          Huh, after tinkering a bit and trying to find a second Create Session node...it started working.

                          Anyways thanks for the assistence mordentral

                          Comment


                            Hey,

                            I seem to have a problem that occured out of nowhere. We've been playtesting via steam appid 480 no problem in June, but now if I try the same build it doesn't work. Is the sdk version change responsible for it? We've still got 132 there but 141 is out now and I'm wondering if it's the problem.

                            In case it's not, there's only one warning regarding steam in the logfiles:

                            AdvancedSteamFriendsLog:Warning: STEAM Couldn't be verified as initialized

                            This means the SteamAPI_Init() failed but gives no additional errors.

                            Thanks!

                            Comment


                              Originally posted by Ragir View Post
                              Hey,

                              I seem to have a problem that occured out of nowhere. We've been playtesting via steam appid 480 no problem in June, but now if I try the same build it doesn't work. Is the sdk version change responsible for it? We've still got 132 there but 141 is out now and I'm wondering if it's the problem.

                              In case it's not, there's only one warning regarding steam in the logfiles:

                              AdvancedSteamFriendsLog:Warning: STEAM Couldn't be verified as initialized

                              This means the SteamAPI_Init() failed but gives no additional errors.

                              Thanks!
                              Do you have SteamVR installed and if so is SteamVR Home Beta enabled?

                              Because it breaks the steam subsystem in builds that aren't downloaded from steam itself currently.


                              Consider supporting me on patreon

                              My Open source tools and plugins
                              Advanced Sessions Plugin
                              VR Expansion Plugin

                              Comment


                                Originally posted by mordentral View Post

                                Do you have SteamVR installed and if so is SteamVR Home Beta enabled?

                                Because it breaks the steam subsystem in builds that aren't downloaded from steam itself currently.
                                No, I don't think so, nothing major changed on my system since June,but I will try to check on another computer tomorrow and report back, thanks for the answer

                                Comment

                                Working...
                                X