Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by MASSIVE Can View Post
    [MENTION=4285]mordentral[/MENTION] Hi, I'm using 4.17 VXGI version how can I use Advanced Sessions plugin? When I copy plugin files to plugins folder of project I have an error like that: [ATTACH=CONFIG]152648[/ATTACH]
    How can I fix this error?
    You are on a custom engine branch, I cannot pre-build binaries for custom branches as there is no official binary version of them.

    You have to manually compile the plugin on that branch from visual studio.


    Consider supporting me on patreon

    My Open source tools and plugins
    Advanced Sessions Plugin
    VR Expansion Plugin

    Comment


      well how can I manually compile the plugin? I'm kinda new at Visual Studio.

      Comment


        Originally posted by MASSIVE Can View Post
        well how can I manually compile the plugin? I'm kinda new at Visual Studio.
        Open up your project in visual studio and compile it for development editor. Then you should be able to launch as normal.


        You should really familiarize yourself with the compilation process if you are going to be using a custom engine branch though.


        Consider supporting me on patreon

        My Open source tools and plugins
        Advanced Sessions Plugin
        VR Expansion Plugin

        Comment


          I have a problem with my game right now and I don't know if it has somethign to do with the plugin. And I can't seem to fix it : (
          So maybe someone can take a look at it.

          I will explain the process right here.
          The player makes a server, then a client joins the server when they are ready, the game starts so that is the part where the servertravel occurs. while traveling the client disconnects. I didn't have this problem in 4.16 but in 4.17 this problem occurs.

          I hope somebody can help me with this because I am stuck now : (

          I have also reproduced this problem and that worked fine. Migrating also doesn't help.
          And also I have upgraded this project from 4.16 to 4.17

          The gamelogdisconnecterror is the log from the client and the other one is from the server.

          I can see that there is something wrong with the playerstate but i dont know what.

          Regards. Lex
          [link text][1]
          [link text][2]


          [1]: /storage/temp/210352-seeinginthedark-2.log
          [2]: /storage/temp/210294-gamelogdisconnecterror.log

          Comment


            Originally posted by mordentral View Post
            Open up your project in visual studio and compile it for development editor. Then you should be able to launch as normal.


            You should really familiarize yourself with the compilation process if you are going to be using a custom engine branch though.
            thank you it worked

            Comment


              Originally posted by Kwatskop View Post
              I have a problem with my game right now and I don't know if it has somethign to do with the plugin. And I can't seem to fix it : (
              So maybe someone can take a look at it.

              I will explain the process right here.
              The player makes a server, then a client joins the server when they are ready, the game starts so that is the part where the servertravel occurs. while traveling the client disconnects. I didn't have this problem in 4.16 but in 4.17 this problem occurs.

              I hope somebody can help me with this because I am stuck now : (

              I have also reproduced this problem and that worked fine. Migrating also doesn't help.
              And also I have upgraded this project from 4.16 to 4.17

              The gamelogdisconnecterror is the log from the client and the other one is from the server.

              I can see that there is something wrong with the playerstate but i dont know what.

              Regards. Lex
              [link text][1]
              [link text][2]


              [1]: /storage/temp/210352-seeinginthedark-2.log
              [2]: /storage/temp/210294-gamelogdisconnecterror.log
              Nothing to do with the plugin, and I have heard of this before and its been reported on answerhub.


              Consider supporting me on patreon

              My Open source tools and plugins
              Advanced Sessions Plugin
              VR Expansion Plugin

              Comment


                At me all work, but I need to cause to find session every second, for reception of sessions, and it can not find them.

                Comment


                  Hey Mordental. I had wanted to see if you know anything about doing this with Advanced Sessions:
                  What I'm looking to do is go ahead and see if someone is in a lobby or in the map itself. The way I'm handling things is that they don't have to wait for people to join and can directly get into the action. But the difficulties I'm having is checking to see if someone is in the lobby menus waiting for people to join or in-game itself. If you have any knowledge on this, it's be a big help. Thank you!
                  "Let's see if your bite is as big as your bark" -Mark Welch, Lurking in the Shadows.

                  Comment


                    Hi everyone! Is it possible to package 32bit game with this plugin? With win64 builds I have no problems, but with 32 I have this:

                    UATHelper: Packaging (Windows (32-bit)): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Subversion\MyProject\Binaries\Win32\MyProject-Win32-Shipping.exe

                    I cant make 32bit builds only when plugin enabled

                    There is also full build log:
                    Attached Files

                    Comment


                      And also i tried to package C++ project when Advanced Sessions located in project folder and i got this:

                      UATHelper: Packaging (Windows (32-bit)): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Subversion\MyProject\Plugins\AdvancedSessions\AdvancedSteamSessions\Binaries\Win32\UE4-AdvancedSteamSessions-Win32-Shipping.lib

                      Comment


                        Originally posted by Cyber Light View Post
                        Hi everyone! Is it possible to package 32bit game with this plugin? With win64 builds I have no problems, but with 32 I have this:

                        UATHelper: Packaging (Windows (32-bit)): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Subversion\MyProject\Binaries\Win32\MyProject-Win32-Shipping.exe

                        I cant make 32bit builds only when plugin enabled

                        There is also full build log:
                        Yes? I have a 32bit shipping build using it right now as well as it having compiled into 32bit for the binary releases.

                        Are you running from source or the pre-compiled?


                        Consider supporting me on patreon

                        My Open source tools and plugins
                        Advanced Sessions Plugin
                        VR Expansion Plugin

                        Comment


                          Still can't use 'Get Session Settings'. Always go to 'On Failure'.

                          Tried get the session at the GameInstance and GameMode of the game and a lot others blueprints.

                          Comment


                            Originally posted by HeliaXDemoN View Post
                            Still can't use 'Get Session Settings'. Always go to 'On Failure'.

                            Tried get the session at the GameInstance and GameMode of the game and a lot others blueprints.
                            What subsystem are you using? Also are you actually hosting a session first? Its working fine for me.


                            Consider supporting me on patreon

                            My Open source tools and plugins
                            Advanced Sessions Plugin
                            VR Expansion Plugin

                            Comment


                              Hi. thanks for the plugin.
                              I had the voice working in my project in 4.15 but I can't get it to work in 4.16.3
                              Any idea what the issue might be? any changes or things i need to do?

                              Comment


                                Hi Mordentral,
                                Im fairly new to UE4, however ive been programming for a while. I had created an entire working server and had things going fine last night based on your plugin and following the guide on youtube by Pyrodev. However, today i made some type of change that im not sure of, and my client can no longer find servers anymore. I worked very hard to backtrack and find my mistake but have not been able to.

                                Today I have given up after hours of debugging. I completed started from scratch following the videos over again, and im still unable to get a connection to the created servers. Im pretty much at a loss at this point...

                                Do you or anyone else have an idea as to what i could do to fix/debug? If needed ill supply screenshots of what i have thus far. thanks so much for your time.

                                -Mishtiff

                                Comment

                                Working...
                                X