Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Worlf View Post

    Nope.I changed AppID 632 and set "max results" 1000 or 0 dont work this.

    He is not looking for a server, he goes to the 'Find session Advanced' in 'Failed'. That is, he has no problem finding the server, but the problem is to start looking for them.
    I don't believe there is a pathway in that node that returns in Failure that doesn't log an error to the output. Did you check the log for an error message?

    Leave a comment:


  • replied
    Originally posted by Surikat229 View Post

    The plugin is enabled, everything is configured, AppId is specified. In Standalone Game plugin works, there is an interface Steam. Collect game in .exe and the plugin no hearing nor the spirit! In log files there are no errors associated with the plugin (except the Steam API is disabled). I don't know what to do, my game needs a Steam interface!!!
    What engine version are you on? In prior to 4.22 you had to ship an appID.txt file with shipping builds for the steam subsystem to function.


    Also the steam subsytem being disabled doesn't have anything to do with the plugin and obviously has to be resolved before it could function outside of a fallback interface.

    Leave a comment:


  • replied
    Originally posted by mordentral View Post

    In what way? It wouldn't package if the plugin wasn't there to package, the nodes would throw an error.
    The plugin is enabled, everything is configured, AppId is specified. In Standalone Game plugin works, there is an interface Steam. Collect game in .exe and the plugin no hearing nor the spirit! In log files there are no errors associated with the plugin (except the Steam API is disabled). I don't know what to do, my game needs a Steam interface!!!

    Leave a comment:


  • replied
    Originally posted by mordentral View Post

    Well it is likely because you are limiting results to 2 and are using the default AppID of 480, you will be getting lists of all users of 480 back from that without a filter but it won't be returning any valid sessions for you in the first two since it doesn't know how to filter to your specific servers.

    If you set up an extra setting to look for / host with it won't be returning any sessions without it so you can get the results down to something that will pass the limit of 2 requirement. Orrrrrr, not limiting it to 2 or using your own app ID would work.
    Nope.I changed AppID 632 and set "max results" 1000 or 0 dont work this.

    He is not looking for a server, he goes to the 'Find session Advanced' in 'Failed'. That is, he has no problem finding the server, but the problem is to start looking for them.
    Last edited by Worlf; 08-19-2019, 02:50 AM.

    Leave a comment:


  • replied
    Originally posted by Surikat229 View Post
    Hi guys. I have such trouble like NaVv666. There's have solutions?
    In what way? It wouldn't package if the plugin wasn't there to package, the nodes would throw an error.

    Leave a comment:


  • replied
    Originally posted by Worlf View Post
    Hello friend i am back! Say me please, why am i getting print "Filed find!"?What am I doing wrong?
    Well it is likely because you are limiting results to 2 and are using the default AppID of 480, you will be getting lists of all users of 480 back from that without a filter but it won't be returning any valid sessions for you in the first two since it doesn't know how to filter to your specific servers.

    If you set up an extra setting to look for / host with it won't be returning any sessions without it so you can get the results down to something that will pass the limit of 2 requirement. Orrrrrr, not limiting it to 2 or using your own app ID would work.

    Leave a comment:


  • replied
    Hello friend i am back! Say me please, why am i getting print "Filed find!"?What am I doing wrong?

    Leave a comment:


  • replied
    Hi guys. I have such trouble like NaVv666. There's have solutions?

    Leave a comment:


  • replied
    Originally posted by Drwho11 View Post

    can you plz explain better at what you mean each time i close my project after getting it working it breaks and to fix it i have to delete the plugin folder make it all over restart my pc then open the project and then the thing only tells me one plugin is not working and then it will compile it its self

    Never Had this problem back in the day.
    Which plugin? The SteamSessions one? I patched that yesterday, you either need to re-download the 4.22 pre-packaged binaries in the OP post or the latest source code from the repository.

    Leave a comment:


  • replied
    Originally posted by mordentral View Post

    He downloaded the latest 4.22 pre-packaged binaries Zip file.
    can you plz explain better at what you mean each time i close my project after getting it working it breaks and to fix it i have to delete the plugin folder make it all over restart my pc then open the project and then the thing only tells me one plugin is not working and then it will compile it its self

    Never Had this problem back in the day.

    Leave a comment:


  • replied
    Hi guys i have a problem, everything works fine in the editor but when i package the game then the game behave like there was no plugin there. Any solutions? I will add that i did same game with changing adv. sessions to normal then packaged the game and everything worked fine.

    Leave a comment:


  • replied
    Originally posted by Drwho11 View Post

    what did you do to get it to work i cant get mine to work and i do not understand how to compile?
    He downloaded the latest 4.22 pre-packaged binaries Zip file.

    Leave a comment:


  • replied
    Originally posted by Worlf View Post

    Its work, thank you very much!
    what did you do to get it to work i cant get mine to work and i do not understand how to compile?

    Leave a comment:


  • replied
    Originally posted by mordentral View Post

    That IS the error? If you are downloading the source copies of the plugin then you need to manually compile it in Visual Studio, otherwise it is not going to load and that error message shows.

    That being said it appears that the current pre-built package has a bad copy of the advanced steam sessions module, I will recompile that one to fix it there. Made a change to my test project that seems to have excluded that module from compilation.

    *Edit* Reuploaded the prebuilt for 4.22
    Its work, thank you very much!

    Leave a comment:


  • replied
    Originally posted by mordentral View Post

    They don't just delete the binaries, if it was working yesterday then it should still be, but you can re-download the pre-built for 4.22 in case you somehow deleted it.
    i did not change anything with binaries i do not even know what that means my plugins are still in the plugins folder.

    Leave a comment:

Working...
X