Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Andrea92 View Post
    I have the same problem, LAN works perfectly, when they are not the find session retourn 0 ... I have 4.14.3 ... how do I fix? in previous versions it worked everything perfect ... thanks for the work done
    I'll recompile the binaries for 4.14.3 and re-upload, it might still be 4.14.2 in the zip currently, sometimes the upload fails to complete.

    *Edit* Yea I checked the upload date and the last one didn't complete, it was a month before 4.14.3 (4.14.2), lots of the recent hotfixes require plugin recompiles or it lists as a different engine version.

    Should be ok now?
    Last edited by mordentral; 01-23-2017, 08:30 PM.


    Consider supporting me on patreon

    My Open source tools and plugins
    Advanced Sessions Plugin
    VR Expansion Plugin

    Comment


      Originally posted by mordentral View Post
      I'll recompile the binaries for 4.14.3 and re-upload, it might still be 4.14.2 in the zip currently, sometimes the upload fails to complete.

      *Edit* Yea I checked the upload date and the last one didn't complete, it was a month before 4.14.3 (4.14.2), lots of the recent hotfixes require plugin recompiles or it lists as a different engine version.

      Should be ok now?
      Hi ... sorry I'm late !! I did several tests and the plugin does not work without steam and I can not find the server, with active steam instead works perfectly ...

      Comment


        Originally posted by Andrea92 View Post
        Hi ... sorry I'm late !! I did several tests and the plugin does not work without steam and I can not find the server, with active steam instead works perfectly ...
        Sorry that was a little confusing, do you mean that you can't find non LAN sessions if steam isn't enabled?

        If so then that is correct behavior, the default subsystem has to be LAN, you need another subsystem like steam for non lan connections.

        If you meant that steam has to be running then yea...if steam is set to your default subsystem then it has to be running in order to work.


        Consider supporting me on patreon

        My Open source tools and plugins
        Advanced Sessions Plugin
        VR Expansion Plugin

        Comment


          Yeah just re-tested over steam using latest upload on 4.14.3 and everything worked fine...


          Consider supporting me on patreon

          My Open source tools and plugins
          Advanced Sessions Plugin
          VR Expansion Plugin

          Comment


            *OMG IT WORKS FORGER ABOUT THIS*

            Great plugin and all, however I cant seem to be able to get it to work. Ive tried literally a dozen times now (trust me ive counted) making the project and packaging it, sending it to a friend. Either 1. it finds a session, doesnt show it in the server browser. or 2. It does show it, but i am not able to join when clicked. or 3. No sessions are found.

            Im really tired right now, I know that the plugin works for pretty much everyone, but I will just be using the default create a session/join for now. But this is just a preemptive THANK YOU for making this, as I will be using it in the future but for me its just not working at the moment lol :T
            Last edited by joswayski; 01-28-2017, 09:23 PM.

            Comment


              Originally posted by mordentral View Post
              Sorry that was a little confusing, do you mean that you can't find non LAN sessions if steam isn't enabled?

              If so then that is correct behavior, the default subsystem has to be LAN, you need another subsystem like steam for non lan connections.

              If you meant that steam has to be running then yea...if steam is set to your default subsystem then it has to be running in order to work.
              I did a bit of confusion between LAN subsystem and steam, this is the right way to how it should work, thanks for the clarification ...

              Comment


                Greetings. Is there any way to get how many players are in a session with steam? Currently all found sessions display 1 player, regardless of the actual amount.
                ______________________________________________
                https://www.facebook.com/madhousesoftware
                Where sanity is a virtue

                Comment


                  I have a bit of a problem. I can see listen servers when I look for sessions, but I can't see a dedicated server. I feel like I probably did something wrong, but this is how I did it.

                  I am using Steam. The level blueprint of the default server map calls the Create Advanced Session node with dedicated checked and presence unchecked. After creating the session I use Open Level to open the map I want players to join. So the dedicated server should be creating a dedicated session, but other players cannot find it when they search for games using Find Advanced Session which is set to look for dedicated servers as well as listen servers.

                  What could I be doing wrong? Any help would be appreciated.

                  Comment


                    [MENTION=4285]mordentral[/MENTION] I've added few functions which I found useful in my own project.

                    https://bitbucket.org/mordentral/adv...netid-and/diff

                    Comment


                      Originally posted by CriErr View Post
                      [MENTION=4285]mordentral[/MENTION] I've added few functions which I found useful in my own project.

                      https://bitbucket.org/mordentral/adv...netid-and/diff
                      Looks good, will pull them in, though there might be a better way to compare the ids.


                      Consider supporting me on patreon

                      My Open source tools and plugins
                      Advanced Sessions Plugin
                      VR Expansion Plugin

                      Comment


                        Originally posted by mordentral View Post
                        Looks good, will pull them in, though there might be a better way to compare the ids.
                        I'm new to c++ and I didn't manage to understand the whole underlying structure of subsystems and unique id, so there are sure might be one.

                        Comment


                          Just a quick question, I'm on 4.14.3 and whenever I enable the plugin in the plugin setting, my game lags to 15fps in when I click play; doesn't matter if it's in the viewport or standalone. I tried to bring down graphics, but that isn't the issue. It works fine at 160fps without it enabled. Any idea why? All I did is put the plugin in the plugin folder and clicked enable, then did this: :/
                          Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	80.8 KB
ID:	1122234
                          Edit: So it turns out that that plugin works fine as long as I don't have the Profile Picture thing connected to the return node. Any idea why this might cause the game to lag?
                          Last edited by Kaptain-Wiz; 01-29-2017, 08:03 PM.

                          Comment


                            Where this function is? If its in UI and you just bind picture to function, it called every tick.
                            Last edited by CriErr; 01-29-2017, 08:16 PM.

                            Comment


                              It is a binding of an Image in the Widget Blueprint

                              Comment


                                Originally posted by CriErr View Post
                                Where this function is? If its in UI and you just bind picture to function, it called every tick.
                                Maybe calling it every tick is the problem, how do I put a delay on that or something so that it's not called every tick? I know that you can't put a delay in a function so.

                                Comment

                                Working...
                                X