Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by mordentral View Post
    There shouldn't be an issue with that, are you sure you assigned the correct game instance in your project settings?
    Thx a lot mordentral i totally forgot to set the game instance in the project settings. Now it works!

    Comment


      does it work for android devices?

      Comment


        I am trying to avoid adding steam specific code to the plugin, there are only a few exceptions so far and I have to have them not compiled on non steam platforms. It would be better for the base subsystems to support authentication access, there is already a pull request for the engine up on github to support it (steam authentication) and they are redoing parts of the subsystems anyway at the moment.
        So you not going to add SteamCloud, SteamAuthentication to the plugin.
        Did you hear something about a Engine Release date for those things?

        Otherwise I have to create a Plugin on my own for those things.

        Cheers
        Last edited by KAISERslin; 09-28-2016, 03:02 AM.

        Comment


          Originally posted by KAISERslin View Post
          So you not going to add SteamCloud, SteamAuthentication to the plugin.
          Did you hear something about a Engine Release date for those things?

          Otherwise I have to create a Plugin on my own for those things.

          Cheers
          SteamAuth is a current pull request on GitHub, I think it is slated for 4.14, I don't feel like re-writing a bunch of what will already be implemented soon anyway. I will probably provide blueprint access to it when it comes however.

          Steam cloud has an interface for it already in engine, the only reason I didn't add support for it is because of how much blueprint work I would have to add for specifically handling Files which is a plugin in itself.
          Last edited by mordentral; 09-28-2016, 09:02 AM.


          Consider supporting me on patreon

          My Open source tools and plugins
          Advanced Sessions Plugin
          VR Expansion Plugin

          Comment


            yes it worked on my android devices ))) thanks

            Comment


              Originally posted by Dr_Jerm View Post
              Just a follow up: voice issues are resolved in 4.13! Cheers.
              Just as an update, when there are more than 2 players (3-4) the voice issues emerge again (choppy voice). Logs:

              Code:
              [2016.10.04-03.28.06:947][147]LogNet:Warning: Network saturated
              [2016.10.04-03.28.06:947][147]LogNet:Warning: Dropped 1 packets due to congestion in the voicechannel
              [2016.10.04-03.28.06:993][149]LogNet:Warning: Network saturated
              [2016.10.04-03.28.06:993][149]LogNet:Warning: Dropped 1 packets due to congestion in the voicechannel

              Comment


                We have updated our project from 4.11 to 4.13 (update too), now it shows us:

                16.10.06-19.18.23:649][186]LogLinker:Warning: Can't find file '/Script/OnlineSubsystemSteam'
                [2016.10.06-19.18.23:650][186]LogUObjectGlobals:Warning: Failed to load '/Script/OnlineSubsystemSteam': Can't find file '/Script/OnlineSubsystemSteam'
                [2016.10.06-19.18.23:650][186]LogLinker:Warning: Can't find file '/Script/OnlineSubsystemSteam'

                any idea how to fix this?
                @CarstenZarbock - Follow me on Twitter, thank you

                Comment


                  Originally posted by KrautPotato View Post
                  We have updated our project from 4.11 to 4.13 (update too), now it shows us:

                  16.10.06-19.18.23:649][186]LogLinker:Warning: Can't find file '/Script/OnlineSubsystemSteam'
                  [2016.10.06-19.18.23:650][186]LogUObjectGlobals:Warning: Failed to load '/Script/OnlineSubsystemSteam': Can't find file '/Script/OnlineSubsystemSteam'
                  [2016.10.06-19.18.23:650][186]LogLinker:Warning: Can't find file '/Script/OnlineSubsystemSteam'

                  any idea how to fix this?
                  Clean the project and rebuild, make sure you have the 4.13 version of the plugin.

                  Also SteamSubsystem is a plugin in 4.13, you'll have to make sure it is ticked on in your projects plugins in editor.


                  Consider supporting me on patreon

                  My Open source tools and plugins
                  Advanced Sessions Plugin
                  VR Expansion Plugin

                  Comment


                    Originally posted by mordentral View Post
                    Clean the project and rebuild, make sure you have the 4.13 version of the plugin.

                    Also SteamSubsystem is a plugin in 4.13, you'll have to make sure it is ticked on in your projects plugins in editor.
                    Made a mistake in the initial post, should have been "(plugin too)". I downloaded the 4.13 plugin and replaced it.

                    It's a pure BP project so i can't clean / rebuild it from VS, but i've deleted the saved / Intermediate folders and made a full rebuild on packaging.
                    Still not working. And the Steam Overlay is only working if i start the build out of steam. At 4.11 i could start the exe anywhere and it was working. Is this normal?

                    My DefaultEngine.ini

                    Code:
                    [/Script/Engine.GameEngine]
                    !NetDriverDefinitions=ClearArray
                    +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")
                    
                    [OnlineSubsystem]
                    DefaultPlatformService=Steam
                    PollingIntervalInMs=20
                    
                    [OnlineSubsystemSteam]
                    bEnabled=true
                    SteamDevAppId=480
                    GameServerQueryPort=27015
                    bRelaunchInSteam=false
                    GameVersion=1.0.0.0
                    bVACEnabled=1
                    bAllowP2PPacketRelay=true
                    P2PConnectionTimeout=90
                    
                    [/Script/Engine.RendererSettings]
                    r.Streaming.PoolSize=1500
                    
                    [/Script/OnlineSubsystemSteam.SteamNetDriver]
                    NetConnectionClassName=/Script/OnlineSubsystemSteam.SteamNetConnection
                    @CarstenZarbock - Follow me on Twitter, thank you

                    Comment


                      Originally posted by KrautPotato View Post
                      Made a mistake in the initial post, should have been "(plugin too)". I downloaded the 4.13 plugin and replaced it.

                      It's a pure BP project so i can't clean / rebuild it from VS, but i've deleted the saved / Intermediate folders and made a full rebuild on packaging.
                      Still not working. And the Steam Overlay is only working if i start the build out of steam. At 4.11 i could start the exe anywhere and it was working. Is this normal?

                      My DefaultEngine.ini

                      Code:
                      [/Script/Engine.GameEngine]
                      !NetDriverDefinitions=ClearArray
                      +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")
                      
                      [OnlineSubsystem]
                      DefaultPlatformService=Steam
                      PollingIntervalInMs=20
                      
                      [OnlineSubsystemSteam]
                      bEnabled=true
                      SteamDevAppId=480
                      GameServerQueryPort=27015
                      bRelaunchInSteam=false
                      GameVersion=1.0.0.0
                      bVACEnabled=1
                      bAllowP2PPacketRelay=true
                      P2PConnectionTimeout=90
                      
                      [/Script/Engine.RendererSettings]
                      r.Streaming.PoolSize=1500
                      
                      [/Script/OnlineSubsystemSteam.SteamNetDriver]
                      NetConnectionClassName=/Script/OnlineSubsystemSteam.SteamNetConnection
                      You need to go to Plugins window and enable "OnlineSubsystemSteam" and "OnlineSubsystem", I am not sure about this one but I think you also need to enable "OnlineFramework".

                      Edit:
                      Click image for larger version

Name:	XWf2Yz2.png
Views:	1
Size:	124.3 KB
ID:	1116312
                      Click image for larger version

Name:	Q2lx7I9.png
Views:	1
Size:	124.1 KB
ID:	1116313
                      Last edited by Blue man; 10-06-2016, 05:00 PM.
                      Assets: Military Ammunition (Released)
                      Plugins: BlueManBPFunctionLibrary C++ plugin (Free), Blue Man Vehicle AI Plugin (Released), Air Resistance C++ Plugin (WIP), Blue Man Vehicle Physics Plugin (Marketplace)
                      Projects: Giants Of Destruction

                      Comment


                        Originally posted by Blue man View Post
                        You need to go to Plugins window and enable "OnlineSubsystemSteam" and "OnlineSubsystem", I am not sure about this one but I think you also need to enable "OnlineFramework".

                        Edit:
                        [ATTACH=CONFIG]112801[/ATTACH]
                        [ATTACH=CONFIG]112802[/ATTACH]
                        Thank you so much, it's working!
                        Feeling a little bit dumb, but happens.

                        Thanks guys!
                        @CarstenZarbock - Follow me on Twitter, thank you

                        Comment


                          Originally posted by Blue man View Post
                          You need to go to Plugins window and enable "OnlineSubsystemSteam" and "OnlineSubsystem", I am not sure about this one but I think you also need to enable "OnlineFramework".
                          Thanks for giving him pictures, was at work when he asked


                          Consider supporting me on patreon

                          My Open source tools and plugins
                          Advanced Sessions Plugin
                          VR Expansion Plugin

                          Comment


                            Okay, now i've got another problem, and again, no idea whats going on.
                            Had to work on 4.11, and thought i can port it to 4.13 like yesterday.

                            Replaced the Plugins, activated the plugins in the settings, and i can't package it. 4.11 is working though.

                            http://pastebin.com/Ek2wGCHq

                            Code:
                            UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: VictoryBPLibrary.generated.cpp
                            UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(16): error C2007: #define syntax
                            UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(21): error C2007: #define syntax
                            UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(26): error C2007: #define syntax
                            UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(31): error C2007: #define syntax
                            UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(36): error C2007: #define syntax
                            UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(41): error C2007: #define syntax
                            (...)

                            Seems weird because there are errors of the victory plugin, too.

                            e/ okay working now. What i did:
                            - Started the 4.11 project with 4.13 to upgrade
                            - Failed because Plugins
                            - Replaced Plugins with new versions
                            - opened project
                            - started build
                            - enable plugins (as above)
                            - started build again
                            -> working

                            before:
                            - deleted saved + intermediate folder
                            - replaced plugins with newest ones
                            - startet upgrade
                            - build
                            -> failed.

                            No idea whats going on. But at least it's working.
                            Last edited by KrautPotato; 10-07-2016, 06:57 AM.
                            @CarstenZarbock - Follow me on Twitter, thank you

                            Comment


                              Has anyone managed to get Dedicated server working with this plugin?

                              Comment


                                I have successfully got player user name using this plugin, but after packaging, tha call seems to fail. I have followed the instructions in this page

                                https://wiki.unrealengine.com/Plugin...With_Your_Game

                                How can I make sure the plugin has been packaged successfully? Any hints will be helpful.

                                I am using Steam subsystem btw.

                                Comment

                                Working...
                                X