Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hello again!
    finally I made it work in a PS4

    I have one question [MENTION=4285]mordentral[/MENTION]: when I use the "Find Sessions Advance" node with an array of filters (I'm creating a session using "Key=LEVEL / Value=1" and searching with "Key=LEVEL / Value=0") it finds the session created with the different value in the filter, so I still have to use the node "Filter Session Result" in order to get only the sessions with the Value that I want... So the question is if there is a way to filter the results while doing the search and not before (what is the different between "Find Sessions" and "Find Sessions Advance"? or: why "Find Sessions Advance" receives an array of filters?).

    Thank you very much!

    Edit: I finally have it, after doing a release it seems to work OK. After using "Find Sessions Advance", it is no needed to use "Filter Session Result" because the sessions are already filtered.
    Last edited by MaXi; 06-06-2016, 07:28 AM.

    Comment


      Originally posted by Vul Sil View Post
      I need to transfer NET ID'd Between players so I converted the Net ID to a string because transferring the struct NET ID fails. The problem is, is that I can't convert the string back into a NET ID to use for nodes such as the "Get Friend Avatar".
      Don't transfer it, access the net id of a player from the player state array. It is already replicated and there is a "PlayerNetIDFromPlayerState" node in the plugin. The string representation isn't always convertible to a net ID either depending on platform. Sending a net ID over RPC "should" be possible? But I haven't tested as it shouldn't be done.


      Originally posted by Daniel.Wenograd View Post
      When loading the plugin for 4.12 on the Github build, it gives these error messages:

      [ATTACH=CONFIG]96368[/ATTACH]

      [ATTACH=CONFIG]96369[/ATTACH]

      [ATTACH=CONFIG]96370[/ATTACH]

      Meanwhile, if I use the binary release from the launcher, it works perfectly. Any ideas on how to fix it?
      Your attachments don't work, but a self compiled engine version will require that the plugin be re-compiled as it is technically a different engine.


      Originally posted by MaXi View Post
      Hello again!
      finally I made it work in a PS4

      I have one question [MENTION=4285]mordentral[/MENTION]: when I use the "Find Sessions Advance" node with an array of filters (I'm creating a session using "Key=LEVEL / Value=1" and searching with "Key=LEVEL / Value=0") it finds the session created with the different value in the filter, so I still have to use the node "Filter Session Result" in order to get only the sessions with the Value that I want... So the question is if there is a way to filter the results while doing the search and not before (what is the different between "Find Sessions" and "Find Sessions Advance"? or: why "Find Sessions Advance" receives an array of filters?).

      Thank you very much!

      Edit: I finally have it, after doing a release it seems to work OK. After using "Find Sessions Advance", it is no needed to use "Filter Session Result" because the sessions are already filtered.
      I kept the local filtering node in case you wanted to run some things like user filters on the results without re-downloading the server list. The pre-filter is better on bandwidth and search time and should be used if possible when first searching.
      Last edited by mordentral; 06-06-2016, 08:23 AM.


      Consider supporting me on patreon

      My Open source tools and plugins
      Advanced Sessions Plugin
      VR Expansion Plugin

      Comment


        mordentral, quick question.

        Do I still need to take the usual steps of compiling the engine and setting up a seperate launcher for dedicated server support or is there a way by using the plugin?
        So far no luck

        Thanks =)
        Last edited by TimSkijwalker; 06-06-2016, 04:57 PM.

        Comment


          I seem to be having some strange issues with using the plugin that I am sure I am doing something strange. I had the sessions working fine on the internet and LAN. I migrated to advanced sessions plugin as a temp solution to set up naming servers and extra settings that it comes with. I have no problem searching and finding servers created in LAN but once I uncheck LAN and search. I can't seem to find the server at all. I have the server computer ports forward on router and firewall off for testing. Still can't find it. I am not using any steam new drivers and am using the Null IpNetDriver as I don't want to rely on steam servers as of yet. I can post more info if needed. I just want to know that others are possibly doing the same thing I am doing and are getting out of LAN and finding servers without the steam drivers.

          Thanks

          Comment


            Originally posted by TimSkijwalker View Post
            mordentral, quick question.

            Do I still need to take the usual steps of compiling the engine and setting up a seperate launcher for dedicated server support or is there a way by using the plugin?
            So far no luck

            Thanks =)

            This doesn't change the dedicated server procress at all.


            Originally posted by dougbott View Post
            I seem to be having some strange issues with using the plugin that I am sure I am doing something strange. I had the sessions working fine on the internet and LAN. I migrated to advanced sessions plugin as a temp solution to set up naming servers and extra settings that it comes with. I have no problem searching and finding servers created in LAN but once I uncheck LAN and search. I can't seem to find the server at all. I have the server computer ports forward on router and firewall off for testing. Still can't find it. I am not using any steam new drivers and am using the Null IpNetDriver as I don't want to rely on steam servers as of yet. I can post more info if needed. I just want to know that others are possibly doing the same thing I am doing and are getting out of LAN and finding servers without the steam drivers.

            Thanks
            Well outside of searching LAN it doesn't know how to find servers for the NullDriver.....there is no backbone server hosting references. It is for direct IP connections, you can use OPEN with an IP to connect when not searching LAN.


            Alternatively someone made a host/client NULL subsystem subset somewhere in this section of the forums that allows you to define your own master server to send host instances back to you, you could use that instead.


            Consider supporting me on patreon

            My Open source tools and plugins
            Advanced Sessions Plugin
            VR Expansion Plugin

            Comment


              Originally posted by mordentral View Post

              Well outside of searching LAN it doesn't know how to find servers for the NullDriver.....there is no backbone server hosting references. It is for direct IP connections, you can use OPEN with an IP to connect when not searching LAN.


              Alternatively someone made a host/client NULL subsystem subset somewhere in this section of the forums that allows you to define your own master server to send host instances back to you, you could use that instead.
              Thanks for the info. I guess I'll just go straight to steam then since it's where we were going anyways. Thanks for the info and your work on this plugin.

              Comment


                So slightly unrelated to the plugin, i'm trying to write my own leaderboard nodes but I'm having a really hard time figuring out how callbacks work with blueprint nodes, i'm looking at your callback Proxy classes and I was wondering if you would mind walking me through whats going on here? or if there is just something really basic to get execution pins linked to callbacks?

                EDIT: nevermind, i figured it out eventually
                Last edited by GotSomePills; 06-08-2016, 09:20 AM.

                Comment


                  Why does my Editor crashes on compile?

                  Comment


                    Originally posted by Xilest View Post
                    Why does my Editor crashes on compile?
                    I am having a very similar issue here. I updated yesterday to 4.12.1 and only certain blueprints seem to crash on compile. I narrowed it down to any blueprints that are associated with Advanced Sessions. I don't know if it's a fluke or not. But we also don't have a new 4.12.1 update of the plugin. Though I haven't had issues in the past just updating the engine and not the plugin. This might seem to be a 4.12.1 update that conflicted with the Advanced Sessions plugin. Anyways else having issues after updating to 4.12.1?

                    mordentral? Test or update incoming?

                    Thanks.

                    Comment


                      Originally posted by dougbott View Post
                      I am having a very similar issue here. I updated yesterday to 4.12.1 and only certain blueprints seem to crash on compile. I narrowed it down to any blueprints that are associated with Advanced Sessions. I don't know if it's a fluke or not. But we also don't have a new 4.12.1 update of the plugin. Though I haven't had issues in the past just updating the engine and not the plugin. This might seem to be a 4.12.1 update that conflicted with the Advanced Sessions plugin. Anyways else having issues after updating to 4.12.1?

                      mordentral? Test or update incoming?

                      Thanks.
                      I'm not updating to 4.12.1 because there is a crash in that version effecting a lot of projects, it is likely that you ran into it. 4.12.2 is slated to fix it.

                      https://answers.unrealengine.com/que...o-project.html

                      4.12.2 should be out soon, they said ASAP fix for the crash, it appears to be a problem with ForEach nodes, and since you likely run through server results with that you'd get it.


                      Consider supporting me on patreon

                      My Open source tools and plugins
                      Advanced Sessions Plugin
                      VR Expansion Plugin

                      Comment


                        Sounds good. Thanks for your efforts. I guess it was just chance that advanced sessions nodes were attached to most of the BP I tested for crashing. Hopefully they get a fix out soon. Sounds like by the end of the week.

                        Cheers.

                        Comment


                          Confirmed. The 4.12.2 Hot fix, fixed all previous crashes I was having.

                          Comment


                            Originally posted by dougbott View Post
                            Confirmed. The 4.12.2 Hot fix, fixed all previous crashes I was having.
                            Recompiling the binaries and updating for the Blueprint Only projects right now.

                            *Edit* Uploaded
                            Last edited by mordentral; 06-09-2016, 01:25 PM.


                            Consider supporting me on patreon

                            My Open source tools and plugins
                            Advanced Sessions Plugin
                            VR Expansion Plugin

                            Comment


                              Failed to Build Android Package? Tried the 4.12.0 Plugin with 4.12.0 engine version the other day, and now on 4.12.2 engine with the latest AdvancedSession plugin. Always Failed. Does anybody encounter the same problem?

                              Comment


                                Originally posted by Xilest View Post
                                Failed to Build Android Package? Tried the 4.12.0 Plugin with 4.12.0 engine version the other day, and now on 4.12.2 engine with the latest AdvancedSession plugin. Always Failed. Does anybody encounter the same problem?
                                Can't really help you without the log to know what it failed at, but it may need to exclude some steam specific includes. Android sessions have some caveats I think, I haven't built for it before but there are multiple threads mentioning extra steps that have to be taken for the default sessions nodes to work.
                                Last edited by mordentral; 06-13-2016, 01:21 PM.


                                Consider supporting me on patreon

                                My Open source tools and plugins
                                Advanced Sessions Plugin
                                VR Expansion Plugin

                                Comment

                                Working...
                                X