Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by mordentral View Post

    Sessions shouldn't stop "being advertised" no, but that is on the subsystem providers end.
    I forgot that I save the Session too and try reconnect and the player can't enter the game anymore.

    Leave a comment:


  • replied
    Originally posted by Demonrras View Post
    When I trying to finish/close a connected client with the server session in dedicated server...The console of server keep the saying the same msglog:

    AdvancedSessionsLog: Warning: GetLocalPlayerNameFromController Bad Player Controller!

    What I need to do to fix this and make correct disconnection of clients???
    You are running a node on the server for the disconnected clients controller. You must be saving them out seperately for some reason? And on tick are checking it?

    Leave a comment:


  • replied
    Originally posted by HeliaXDemoN View Post
    Question about the time the session get advertise to other players. Some times when we are testing the game for a long time and someone leave the game.

    The player can't find the session again. The engine stop advertise the game after some time?

    If I use Update Session the session will go back to be advertise?
    Sessions shouldn't stop "being advertised" no, but that is on the subsystem providers end.

    Leave a comment:


  • replied
    Question about the time the session get advertise to other players. Some times when we are testing the game for a long time and someone leave the game.

    The player can't find the session again. The engine stop advertise the game after some time?

    If I use Update Session the session will go back to be advertise?

    Leave a comment:


  • replied
    When I trying to finish/close a connected client with the server session in dedicated server...The console of server keep the saying the same msglog:

    AdvancedSessionsLog: Warning: GetLocalPlayerNameFromController Bad Player Controller!

    What I need to do to fix this and make correct disconnection of clients???

    Leave a comment:


  • replied
    Originally posted by mordentral View Post

    Its not intended for c++ use, there is little to no reason to use it in C++ as it is just exposing the C++ backend anyway, and most of the blueprint nodes are async blueprint objects and are awkward to use in C++. Its not tagged with the _API macro to expose it to c++ for that very reason.

    It would actually be far faster and cleaner to just straight up use the C++ yourself.
    Sure thing, thanks for helping.

    Leave a comment:


  • replied
    Originally posted by XynanXDB View Post
    This plugin is awesome but how do I use it in C++ even though I have added the module dependency on build.cs and target.cs, it still doesn't work. Please help
    Its not intended for c++ use, there is little to no reason to use it in C++ as it is just exposing the C++ backend anyway, and most of the blueprint nodes are async blueprint objects and are awkward to use in C++. Its not tagged with the _API macro to expose it to c++ for that very reason.

    It would actually be far faster and cleaner to just straight up use the C++ yourself.

    Leave a comment:


  • replied
    This plugin is awesome but how do I use it in C++ even though I have added the module dependency on build.cs and target.cs, it still doesn't work. Please help

    Leave a comment:


  • replied
    Hi, thanks for this plugin, it looks like it's filling a need in the community.

    Leave a comment:


  • replied
    hi, Unreal engine crash, and i have this error "AdvancedSessionsLog: Warning: GetNetPlayerIndex received a bad PlayerController!" in the crash log, i use the 4.22 version, when i use the 4,21version this error not exist, whay can i do? sorry for my bad enlgish

    Leave a comment:


  • replied
    Hey everyone, I am having a problem that I was hoping I could get some help with.

    I have a project that, suddenly, I cannot connect to other players, whether it be 2 instances on my computer or to my laptop with the same build as me. Strangely, my friend can connect to other instances running on his computer and to my other friend that has the same build, it's just that I cannot connect to other sessions. I went back to previous builds where it was working but still no luck. When I launch the game in a build or as standalone it says im playing "Spacewar" and I can Shift-Tab into steam, but I cannot join sessions. Anyone else have the same problem?

    Leave a comment:


  • replied
    i think you can make some good money by selling this on the marketplace

    Leave a comment:


  • replied
    mordentral thanks for your help, and as it usually goes dumb simple solution. I missed the top line you're supposed to paste into the DefaultEngine.ini. Now it works like a champ!

    Leave a comment:


  • replied
    Originally posted by BiGiRON1999 View Post
    mordentral thanks for responding.

    I have tested also without the loading screen, same issue though. Could it possibly have something to do with how the plug-in is installed? Just really weird how it works perfectly with steam closed.
    No, the plugin doesn't have anything to do with the level loading, check your log for errors.

    Leave a comment:


  • replied
    mordentral thanks for responding.

    I have tested also without the loading screen, same issue though. Could it possibly have something to do with how the plug-in is installed? Just really weird how it works perfectly with steam closed.

    Leave a comment:

Working...
X