Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Blue man View Post
    I just test my game with a friend and Event "On sessionInviteAccepted" does nothing, I am using test Id 480.
    Where? In the player controller or the game instance? The event works, I use it.


    Consider supporting me on patreon

    My Open source tools and plugins
    Advanced Sessions Plugin
    VR Expansion Plugin

    Comment


      I am using it in a player controller.
      Assets: Military Ammunition (Released)
      Plugins: BlueManBPFunctionLibrary C++ plugin (Free), Blue Man Vehicle AI Plugin (Released), Air Resistance C++ Plugin (WIP), Blue Man Vehicle Physics Plugin (Marketplace)
      Projects: Giants Of Destruction

      Comment


        Here are some pictures. I will try it again with someone else.
        http://imgur.com/9GKaE6m&EQK5mrB&XTQyPw8&PA8kFJK
        Assets: Military Ammunition (Released)
        Plugins: BlueManBPFunctionLibrary C++ plugin (Free), Blue Man Vehicle AI Plugin (Released), Air Resistance C++ Plugin (WIP), Blue Man Vehicle Physics Plugin (Marketplace)
        Projects: Giants Of Destruction

        Comment


          Are you getting the event in GameInstance triggered? Also what subsystem are you using?


          Consider supporting me on patreon

          My Open source tools and plugins
          Advanced Sessions Plugin
          VR Expansion Plugin

          Comment


            I am using Steam, I am not sure, I need ti try it again. This time I will place the Event in the GameInstance. I think it has to do something with the test ID (480).
            Assets: Military Ammunition (Released)
            Plugins: BlueManBPFunctionLibrary C++ plugin (Free), Blue Man Vehicle AI Plugin (Released), Air Resistance C++ Plugin (WIP), Blue Man Vehicle Physics Plugin (Marketplace)
            Projects: Giants Of Destruction

            Comment


              Hey, we are having issues with finding ANY sessions for few days now. I checked MultiplayerShootout on 4.11.1 and it also has issues finding any sessions (even from different games). It occurs for me and my friend, we live in different countries (Germany / Poland ). Any clue what might be wrong?
              www.dawidniemiec.com

              Comment


                Originally posted by vebski View Post
                Hey, we are having issues with finding ANY sessions for few days now. I checked MultiplayerShootout on 4.11.1 and it also has issues finding any sessions (even from different games). It occurs for me and my friend, we live in different countries (Germany / Poland ). Any clue what might be wrong?
                If it is with steam then it is probably because of the Region Lock on App ID 480. If you had your own App ID for steam (got greenlit) then you wouldn't be region locked.


                Consider supporting me on patreon

                My Open source tools and plugins
                Advanced Sessions Plugin
                VR Expansion Plugin

                Comment


                  I downloaded the Spacewar test app and it seems like it also has issues. Server browser does not display any servers at all, but if I search for lobbies it finds all of them.
                  It worked about a month ago (we could use server browser with no problems), either region lock is a new thing or id 480 has issues with master server.
                  www.dawidniemiec.com

                  Comment


                    Originally posted by vebski View Post
                    I downloaded the Spacewar test app and it seems like it also has issues. Server browser does not display any servers at all, but if I search for lobbies it finds all of them.
                    It worked about a month ago (we could use server browser with no problems), either region lock is a new thing or id 480 has issues with master server.
                    It's been working fine for me today.

                    Metahusk: A 501(c)(3) Creative Development Cooperative
                    Projects | Forums | Repositories | Nonprofit | Donate

                    Comment


                      Originally posted by Parvan View Post
                      It's been working fine for me today.
                      For us it still does not work, I managed to see 1 server from UK for a while but thats all. We managed to get around this with invite system so for now its not an issue I guess
                      www.dawidniemiec.com

                      Comment


                        for the record, i'm running on the old 4.11.1 build before the hotfix for dedicated servers.

                        Suggestion:

                        in void UAdvancedSessionsLibrary::GetSessionSettings, add:

                        bAllowInvites = settings->bAllowInvites;
                        bAllowJoinInProgress = settings->bAllowJoinInProgress;

                        to the function and references to the deceleration, otherwise when using getSessionSettings and UpdateSession you can never fill in the bools with current data

                        Comment


                          Originally posted by GotSomePills View Post
                          for the record, i'm running on the old 4.11.1 build before the hotfix for dedicated servers.

                          Suggestion:

                          in void UAdvancedSessionsLibrary::GetSessionSettings, add:

                          bAllowInvites = settings->bAllowInvites;
                          bAllowJoinInProgress = settings->bAllowJoinInProgress;

                          to the function and references to the deceleration, otherwise when using getSessionSettings and UpdateSession you can never fill in the bools with current data
                          Yeah I made a note of that after the last update. Its probably worth rebuilding 4.11.2 with it instead of waiting for 4.12. I'll set it to recompile all 10 binaries while I work.


                          *Edit* Uploaded with that change
                          Last edited by mordentral; 05-27-2016, 01:25 PM.


                          Consider supporting me on patreon

                          My Open source tools and plugins
                          Advanced Sessions Plugin
                          VR Expansion Plugin

                          Comment


                            Any plans of adding the ability to get a game's name? For example, now you can see if a person is playing a game and/or playing the same game, but there's no way of getting the name of the game they're currently playing? It's a little bit nitpicky, and would really only serve a purpose for a friend's list. But it would be a welcome addition.

                            Comment


                              Originally posted by mordentral View Post
                              Yeah I made a note of that after the last update. Its probably worth rebuilding 4.11.2 with it instead of waiting for 4.12. I'll set it to recompile all 10 binaries while I work.


                              *Edit* Uploaded with that change
                              I just haven't updated my engine to 4.11.2 yet, the Project will probably stay with 4.11 from here on too so i'll just add to the plugin as I need it once we do the hotfix update

                              Comment


                                Hi mordentral,
                                first of all, I would to thank you for this amazing work.

                                I've been "playing" with this pluging with a PC project in the last few days and I've seen how it works moreless. In this project I've been able to create and join sessions, look for steam friends, invite them to play etc.
                                The problems come when exporting this project to ps4. First, and the less important: in AdvancedFriendsLibrary::RequestSteamFriendInfo a nullptr is returned (but it should be a boolean).
                                And there appear other errors of this type: Command line : error: L0039: reference to undefined symbol `SteamAPI_Init' in file "D:\Unreal\OnlineTest\Plugins\AdvancedSessions\Binaries\PS4\OnlineTest-AdvancedSessions.a(AdvancedFriendsLibrary.cpp.o)"

                                I have searched but not found anything about this plugin working on ps4... Is it possible?

                                Thank you very much.

                                Comment

                                Working...
                                X