Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    You are getting the session flags overflow without passing anything in to "Extra Settings"? That is caused when the server settings string that is passed to Steam is longer than the 2048 character limit. I don't believe that the default is ever anywhere near that high, it should require some custom settings being passed in to overflow that, if it reaches the cap it stops adding keys to the settings string.

    Is your SS the exact setup you used or do you actually pass in extra settings as well?


    Also sorry, I looked back and I had a post that said "Check Presence", I meant "Un-check Presence" (edited the post so that others wouldn't get confused), it isn't compatible with dedicated servers, that was my bad not checking my post closely enough.
    Last edited by mordentral; 02-12-2016, 09:44 AM.


    Consider supporting me on patreon

    My Open source tools and plugins
    Advanced Sessions Plugin
    VR Expansion Plugin

    Comment


      Ok so unchecking presence works to allow the server to run. I don't pass any extra settings. That screens hot was the way it was when I got those warnings yesminus the fact use presence was off. Couldn't find session. And ports are forwarded.
      Last edited by Vindomire; 02-12-2016, 10:49 AM.

      Comment


        And your dedicated is on a different computer from the one you are trying to find it from? It cannot be the same computer.


        Consider supporting me on patreon

        My Open source tools and plugins
        Advanced Sessions Plugin
        VR Expansion Plugin

        Comment


          Yes. My other computer is a server setup with windows 2008 r2 and a basic gfx card that can't run games. But runs dedicated servers fine.

          Comment


            im going to start a basic first person example and do some testing, make sure it isnt my project.

            Comment


              Same Problem on Fresh Project.
              Click image for larger version

Name:	936791a3fc.jpg
Views:	1
Size:	30.3 KB
ID:	1100436

              find session:
              Click image for larger version

Name:	5548b327d4.png
Views:	1
Size:	264.9 KB
ID:	1100437

              Create Session:
              Click image for larger version

Name:	e189951959.png
Views:	1
Size:	115.8 KB
ID:	1100438

              Server Output:
              Click image for larger version

Name:	a9a8076e45.png
Views:	1
Size:	25.2 KB
ID:	1100439

              odd thing about the output is i didnt think the server created a player. but apparently it did and then tried to find a session lol...

              Comment


                completely removed steam, rebuilt the account architecture from teh ground up and the dedi/client relationship works as intended... thanks for your help but maybe i need to leave steam out of the equation until dedis are properly supported.

                Comment


                  Ok I have a question. I am running UE version 4.10.0 with FleX Integration. After extracting the files (version 4.10.2) to the appropriate location, I tried to load up my project. At 70% it gave me an error. Will this version not work with my UE4 version?
                  Click image for larger version

Name:	Blah.png
Views:	1
Size:	26.3 KB
ID:	1100522

                  Comment


                    Originally posted by MemnochGRI View Post
                    Ok I have a question. I am running UE version 4.10.0 with FleX Integration. After extracting the files (version 4.10.2) to the appropriate location, I tried to load up my project. At 70% it gave me an error. Will this version not work with my UE4 version?
                    [ATTACH=CONFIG]78636[/ATTACH]
                    Do you not have a compiler installed? Custom versions of the engine need a compiler installed in order to re-compile the plugin for that version on load.


                    Consider supporting me on patreon

                    My Open source tools and plugins
                    Advanced Sessions Plugin
                    VR Expansion Plugin

                    Comment


                      I have visual studio 2013 installed (I think that's the version, I'm currently at work). Not trying to sound completely unfamiliar with programming, but it's been some time since I've done any actual c++ coding :/

                      Comment


                        Unless you're speaking of a different compiler

                        Comment


                          Originally posted by MemnochGRI View Post
                          Unless you're speaking of a different compiler
                          4.10 requires VS 2015 now.


                          Consider supporting me on patreon

                          My Open source tools and plugins
                          Advanced Sessions Plugin
                          VR Expansion Plugin

                          Comment


                            Well darn, I missed that part >.< Thanks for the info mordentral! Will give that a go and see what I get. Thanks again.

                            Comment


                              Hey there, sorry to bother you guys again, but I had a question again about the Plugin. I installed VS2015 with all the features, but when I went to load my project I got the same error again.
                              Do I need to rebuild my engine (4.10.0 with flex integration) in order for it to work? I appreciate any help and thanks in advance.

                              Comment


                                Originally posted by MemnochGRI View Post
                                Hey there, sorry to bother you guys again, but I had a question again about the Plugin. I installed VS2015 with all the features, but when I went to load my project I got the same error again.
                                Do I need to rebuild my engine (4.10.0 with flex integration) in order for it to work? I appreciate any help and thanks in advance.
                                It "should" recompile by itself with everything working. But the project can't be pure blueprint to recompile a plugin. If you add an empty c++ class from the editor menu it should work then.


                                Consider supporting me on patreon

                                My Open source tools and plugins
                                Advanced Sessions Plugin
                                VR Expansion Plugin

                                Comment

                                Working...
                                X