Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I have a problem trying to enable voice. I have configured the configuration file according to the settings you said. Set it to false in push to talk. Packed it up and ran the game on two computers. As a result, all the sound effects in the game were cleared, but no voice was heard. Does ue4.25 not support this voice system?

    Comment


      Originally posted by Zzwel View Post
      I have a problem trying to enable voice. I have configured the configuration file according to the settings you said. Set it to false in push to talk. Packed it up and ran the game on two computers. As a result, all the sound effects in the game were cleared, but no voice was heard. Does ue4.25 not support this voice system?
      It IS ue4's voice system, the plugin only calls c++ functions on the back end that normally aren't exposed to blueprints. If it was breaking in multiplayer then you had network saturation, ue4 is running their default VOIP through the normal packet system so it counts towards client bandwidth, you would have to raise the client max bandwidth from defaults usually.

      You can also test that its picking things up with OSS.VoiceLoopback 1 to have it locally play back the voice.


      Consider supporting me on patreon

      My Open source tools and plugins
      Advanced Sessions Plugin
      VR Expansion Plugin

      Comment


        Put up the 4.26 pre-packaged binaries, 4.25 and 4.26 didn't not require source changes so there is no new branch, master works for both.


        Consider supporting me on patreon

        My Open source tools and plugins
        Advanced Sessions Plugin
        VR Expansion Plugin

        Comment


          Originally posted by mordentral View Post

          It IS ue4's voice system, the plugin only calls c++ functions on the back end that normally aren't exposed to blueprints. If it was breaking in multiplayer then you had network saturation, ue4 is running their default VOIP through the normal packet system so it counts towards client bandwidth, you would have to raise the client max bandwidth from defaults usually.

          You can also test that its picking things up with OSS.VoiceLoopback 1 to have it locally play back the voice.
          Thank you for your help. I have read a lot of your replies about VR development and respect you very much.I've found the cause of my problem.UE4.25 Added a noise gate to outgoing VoIP audio that can be controlled with the CVAR voice.MicNoiseGateThreshold.Its default value is so high that it will be mute without setting it.Thank you again.

          Comment


            I want to know why my friend right-click to join the game but won't enter the room. If you click join outside the game, it will open the game and won't join. If you click in the game to join the game, there is no response.
            2. Information about you before “I want to know why my friend right-click to join the game but won't enter the room. If you click join outside the game, it will open the game and won't join. If you click in the game to join the game, there is no response.” How do I verify to get Ping? Which blueprint node to use?

            Comment


              I have been using UE 4.25.3. I added plugins to the engine. I added the .ini config to a couple of projects (one with an almost empty project and the other one is a big one). In the almost empty one, I can reach steam overlay with no issue but with the complex one.
              I receive 'LogSteamShared: Warning: SteamAPI failed to initialize, conditions not met.' when I open the big project in the engine. Naturally packaging it doesn't change anything. I don't understand why conditions are not met in my real project but works just fine with the dummy one. Any ideas anyone?

              Comment


                Hello,
                i setup this Plugin and made a Lobby now i have a Problem if i join to a lobby i dont have a GameMode only the host have a GameMode i set the GameMode in ProjectSettings and WorldSettings
                Click image for larger version

Name:	CreateSession.PNG
Views:	249
Size:	93.2 KB
ID:	1841285 ​​ Click image for larger version

Name:	JoinSession.PNG
Views:	233
Size:	104.0 KB
ID:	1841287Click image for larger version

Name:	Settings.PNG
Views:	236
Size:	160.9 KB
ID:	1841286

                Comment


                  Originally posted by Nukerbinary View Post
                  I have been using UE 4.25.3. I added plugins to the engine. I added the .ini config to a couple of projects (one with an almost empty project and the other one is a big one). In the almost empty one, I can reach steam overlay with no issue but with the complex one.
                  I receive 'LogSteamShared: Warning: SteamAPI failed to initialize, conditions not met.' when I open the big project in the engine. Naturally packaging it doesn't change anything. I don't understand why conditions are not met in my real project but works just fine with the dummy one. Any ideas anyone?
                  I've seen complaints about 4.25 and steam not always loading correctly, however I have never had the issue myself so can't really provide a solid answer.
                  Originally posted by Tryto1 View Post
                  Hello,
                  i setup this Plugin and made a Lobby now i have a Problem if i join to a lobby i dont have a GameMode only the host have a GameMode i set the GameMode in ProjectSettings and WorldSettings​
                  You may want to read up on the engine network documentation, GameMode isn't a replicated class and it only exists on the servers end.


                  Consider supporting me on patreon

                  My Open source tools and plugins
                  Advanced Sessions Plugin
                  VR Expansion Plugin

                  Comment





                    You may want to read up on the engine network documentation, GameMode isn't a replicated class and it only exists on the servers end.
                    [/QUOTE]


                    Ahh okay this makes sense but how I can use a function from there I have in my game mode a function "UpdateServer" this function reload the player list in my session

                    Comment





                      Ahh okay this makes sense but how I can use a function from there I have in my game mode a function "UpdateServer" this function reload the player list in my session
                      You can call that on the server side, just not on the client.


                      Consider supporting me on patreon

                      My Open source tools and plugins
                      Advanced Sessions Plugin
                      VR Expansion Plugin

                      Comment


                        Tried packaging a game recently and although the message log states that the project packaged correctly, the final packaged folder has the binaries subfolder missing. Due to this, the .exe for the game just doesn't do anything when executed.

                        This only happens when the Advanced Steam Sessions plugin is enabled.

                        Comment


                          Originally posted by W a f f l e z View Post
                          Tried packaging a game recently and although the message log states that the project packaged correctly, the final packaged folder has the binaries subfolder missing. Due to this, the .exe for the game just doesn't do anything when executed.

                          This only happens when the Advanced Steam Sessions plugin is enabled.
                          I have the same problem

                          Comment


                            Originally posted by AlexSvarog View Post

                            I have the same problem
                            :/ Still haven't fixed it but If I find a solution, I'll let you know.

                            Comment


                              Originally posted by W a f f l e z View Post

                              :/ Still haven't fixed it but If I find a solution, I'll let you know.
                              What engine version? and using the pre-built binaries i assume


                              Consider supporting me on patreon

                              My Open source tools and plugins
                              Advanced Sessions Plugin
                              VR Expansion Plugin

                              Comment


                                Originally posted by mordentral View Post

                                What engine version? and using the pre-built binaries i assume
                                My engine version is 4.26
                                And if I understand correctly (referring to the plugin), yes.

                                Comment

                                Working...
                                X