Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ah, as it turns out it was Gamelift's SDK initializing at the same time as we were trying to create the server. We unhooked that and now it works. The SDK must be doing something with creating sessions or something like that that interfered with Create Session Advanced.

    Weird!

    Comment


      Hey mordentral, any idea why this project that was uploaded by a Dev don't have the '9999 Ping' problem but any other have? Me and my co-worker tested the very small project and we were getting normal ping. I did a empty Project making everything very similar of the Dev's one but I got ~200 ping(?), this is REALLY strange.

      The project: https://www.dropbox.com/s/rnzdntyeb4...9Test.zip?dl=0

      From this Discussion: https://answers.unrealengine.com/que...868/index.html

      Comment


        Originally posted by HeliaXDemoN View Post
        Hey mordentral, any idea why this project that was uploaded by a Dev don't have the '9999 Ping' problem but any other have? Me and my co-worker tested the very small project and we were getting normal ping. I did a empty Project making everything very similar of the Dev's one but I got ~200 ping(?), this is REALLY strange.

        The project: https://www.dropbox.com/s/rnzdntyeb4...9Test.zip?dl=0

        From this Discussion: https://answers.unrealengine.com/que...868/index.html
        Ping isn't even passed through from the steam lobby system, which is why the problem exists in the first place and why people are manually pinging.


        Consider supporting me on patreon

        My Open source tools and plugins
        Advanced Sessions Plugin
        VR Expansion Plugin

        Comment


          Hello! Why i have this defferent error? My version 4.22.3 and version plugin 4.22 .Why error? Please help me.
          Last edited by Worlf; 08-12-2019, 02:15 AM.

          Comment


            Hi have a bit of a problem i ben working on trying to use this but i keep ruining into a problem that when i enable it then i reload the project it keeps telling me The Following Modules are missing or bult with a defferent engine version and im useing 4.22.3

            Comment


              Originally posted by Drwho11 View Post
              Hi have a bit of a problem i ben working on trying to use this but i keep ruining into a problem that when i enable it then i reload the project it keeps telling me The Following Modules are missing or bult with a defferent engine version and im useing 4.22.3
              Did you download the 4.22 version? And/or are you trying to build it for a platform that I can't? (Android/Mac).


              Consider supporting me on patreon

              My Open source tools and plugins
              Advanced Sessions Plugin
              VR Expansion Plugin

              Comment


                UPDATE:

                I don’t understand how to solve the version error on 4.22.3. I reinstalled Unreal Engine, I downloaded the plugin from bitbucket. Nothing helps. Who solved the problem on 4.22.3, please tell me the solution. Thank you!



                Originally posted by mordentral View Post

                Did you download the 4.22 version? And/or are you trying to build it for a platform that I can't? (Android/Mac).

                The same problem with the same versions. I do not do any android and so on. The error occurs the same after adding the plugin to the Plugins folder in the project.


                p.s. It is unfortunate that the moderation of posts occurs at the speed of a sleepy turtle, otherwise our problems could be solved much faster.
                Last edited by Worlf; 08-12-2019, 04:31 AM.

                Comment


                  Originally posted by Worlf View Post
                  UPDATE:

                  I don’t understand how to solve the version error on 4.22.3. I reinstalled Unreal Engine, I downloaded the plugin from bitbucket. Nothing helps. Who solved the problem on 4.22.3, please tell me the solution. Thank you!






                  The same problem with the same versions. I do not do any android and so on. The error occurs the same after adding the plugin to the Plugins folder in the project.


                  p.s. It is unfortunate that the moderation of posts occurs at the speed of a sleepy turtle, otherwise our problems could be solved much faster.
                  Then you have a source copy of the plugin, and you need to compile it with visual studio if you downloaded the source copy. Development Editor target build will make it launch into the editor just fine without the IDE.


                  Consider supporting me on patreon

                  My Open source tools and plugins
                  Advanced Sessions Plugin
                  VR Expansion Plugin

                  Comment


                    Originally posted by mordentral View Post

                    Then you have a source copy of the plugin, and you need to compile it with visual studio if you downloaded the source copy. Development Editor target build will make it launch into the editor just fine without the IDE.
                    Does this solve the problem of not matching versions? I need to compile myself to make it work. You are somehow silent about the error ...

                    Comment


                      Originally posted by Worlf View Post

                      Does this solve the problem of not matching versions? I need to compile myself to make it work. You are somehow silent about the error ...
                      That IS the error? If you are downloading the source copies of the plugin then you need to manually compile it in Visual Studio, otherwise it is not going to load and that error message shows.

                      That being said it appears that the current pre-built package has a bad copy of the advanced steam sessions module, I will recompile that one to fix it there. Made a change to my test project that seems to have excluded that module from compilation.

                      *Edit* Reuploaded the prebuilt for 4.22
                      Last edited by mordentral; 08-12-2019, 02:57 PM.


                      Consider supporting me on patreon

                      My Open source tools and plugins
                      Advanced Sessions Plugin
                      VR Expansion Plugin

                      Comment


                        Well Rip i just tryed to open my project that was working yesterday and now and yes i am ruining 4.22 Download Version on Windows Project.
                        Last edited by Drwho11; 08-12-2019, 05:39 PM.

                        Comment


                          Originally posted by Drwho11 View Post
                          Well Rip i just tryed to open my project that was working yesterday and now and yes i am ruining 4.22 Download Version on Windows Project.
                          They don't just delete the binaries, if it was working yesterday then it should still be, but you can re-download the pre-built for 4.22 in case you somehow deleted it.


                          Consider supporting me on patreon

                          My Open source tools and plugins
                          Advanced Sessions Plugin
                          VR Expansion Plugin

                          Comment


                            Originally posted by mordentral View Post

                            They don't just delete the binaries, if it was working yesterday then it should still be, but you can re-download the pre-built for 4.22 in case you somehow deleted it.
                            i did not change anything with binaries i do not even know what that means my plugins are still in the plugins folder.

                            Comment


                              Originally posted by mordentral View Post

                              That IS the error? If you are downloading the source copies of the plugin then you need to manually compile it in Visual Studio, otherwise it is not going to load and that error message shows.

                              That being said it appears that the current pre-built package has a bad copy of the advanced steam sessions module, I will recompile that one to fix it there. Made a change to my test project that seems to have excluded that module from compilation.

                              *Edit* Reuploaded the prebuilt for 4.22
                              Its work, thank you very much!

                              Comment


                                Originally posted by Worlf View Post

                                Its work, thank you very much!
                                what did you do to get it to work i cant get mine to work and i do not understand how to compile?

                                Comment

                                Working...
                                X