Announcement

Collapse
No announcement yet.

Advanced Sessions Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Austin_WGames View Post
    When trying to build for Dedicated Server, it fails to produce item UE4Server-AdvancedSessions-Win64-Shipping.lib

    This could most likely be an error on my end, but I'd like to see if the issue can be pinpointed down easily.
    You need to build it yourself in visual studio, I can't pre-compile for source builds.


    Consider supporting me on patreon

    My Open source tools and plugins
    Advanced Sessions Plugin
    VR Expansion Plugin

    Comment


      Does it have a Steam Matchmaking?

      Comment


        Currently failing at using this to host/find a dedicated server.

        Server:
        https://i.imgur.com/dkUbCMQ.png
        Client (ignore the "Min Slots Available: 100", it's currently 0):
        https://i.imgur.com/YHSc1Nu.png

        Currently, it constantly prints "Found 0 sessions". I had more stuff in place with filters but I was worried I was filtering out my results. Turns out there was just 0 results regardless. Server is reporting the session is created successfully.

        Edit: I'm guessing there's an issue with my Find Sessions Advanced because I should be finding sessions from other people too, right?

        Edit2: I'm launching both the server manually from the command line
        Last edited by Chumble; 05-21-2018, 07:15 PM.

        Comment


          I mean this one https://partner.steamgames.com/doc/f...er/matchmaking

          Comment


            Originally posted by Dj EKI View Post
            The plugin doesn't implement any of the match making features no.

            Also the matchmaking "lobbies" are what UE4 uses for its steam listen servers to begin with.


            Consider supporting me on patreon

            My Open source tools and plugins
            Advanced Sessions Plugin
            VR Expansion Plugin

            Comment


              Originally posted by Chumble View Post
              Currently failing at using this to host/find a dedicated server.

              Server:
              https://i.imgur.com/dkUbCMQ.png
              Client (ignore the "Min Slots Available: 100", it's currently 0):
              https://i.imgur.com/YHSc1Nu.png

              Currently, it constantly prints "Found 0 sessions". I had more stuff in place with filters but I was worried I was filtering out my results. Turns out there was just 0 results regardless. Server is reporting the session is created successfully.

              Edit: I'm guessing there's an issue with my Find Sessions Advanced because I should be finding sessions from other people too, right?

              Edit2: I'm launching both the server manually from the command line
              Do you have the ports open for the dedicated server? Dedicated servers don't use the NAT punchthrough that lobbies do.


              Consider supporting me on patreon

              My Open source tools and plugins
              Advanced Sessions Plugin
              VR Expansion Plugin

              Comment


                Originally posted by mordentral View Post

                Do you have the ports open for the dedicated server? Dedicated servers don't use the NAT punchthrough that lobbies do.
                No, but as I was running it locally and connecting with 127.0.0.1 it shouldn't be needed.

                If I were to just execute a client (without launching a server) and run a "Find sessions advanced" using the Steam subsystem, shouldn't I expect to see a number of sessions hosted on Steam using that appid all over the world? Or will it only find sessions created using the same executable that I have? I'm not sure how that works.

                For now, I changed my subsystem to null and was able to get it working but I will eventually need to make it work with Steam. Also, sorry for the delayed response - I subscribed to this thread but wasn't notified of a response.

                Comment


                  Originally posted by Chumble View Post

                  No, but as I was running it locally and connecting with 127.0.0.1 it shouldn't be needed.

                  If I were to just execute a client (without launching a server) and run a "Find sessions advanced" using the Steam subsystem, shouldn't I expect to see a number of sessions hosted on Steam using that appid all over the world? Or will it only find sessions created using the same executable that I have? I'm not sure how that works.

                  For now, I changed my subsystem to null and was able to get it working but I will eventually need to make it work with Steam. Also, sorry for the delayed response - I subscribed to this thread but wasn't notified of a response.
                  Yeah this thread broke for notifications, I barely get any either.

                  The sessions are filtered out by the build ID (changes each packaging) by default with the subsystem, so no, you wouldn't see them return, however it will log in the console a big list of rejected sessions if you don't have a filter in place.



                  Consider supporting me on patreon

                  My Open source tools and plugins
                  Advanced Sessions Plugin
                  VR Expansion Plugin

                  Comment


                    Within the latest version 4.19, packaging the project, doesn´t matter which one, developing or shipping, works only on win 64, but doesn´t package on win32.

                    Saying it´s missing "mspdbcore.dll". I´ve tested within the previous version, and works, but i can´t decrease the version of my project, it´s too big.

                    I´ve tried to find on internet the solution, but didn´t find.

                    What i need to do to get it works?

                    Comment


                      Originally posted by BrunoChaves View Post
                      Within the latest version 4.19, packaging the project, doesn´t matter which one, developing or shipping, works only on win 64, but doesn´t package on win32.

                      Saying it´s missing "mspdbcore.dll". I´ve tested within the previous version, and works, but i can´t decrease the version of my project, it´s too big.

                      I´ve tried to find on internet the solution, but didn´t find.

                      What i need to do to get it works?
                      Has nothing to do with my plugin, however there is already a bug report up for it.

                      https://issues.unrealengine.com/issue/UE-59150

                      Its an incompatibility with the newest visual studio version


                      Consider supporting me on patreon

                      My Open source tools and plugins
                      Advanced Sessions Plugin
                      VR Expansion Plugin

                      Comment


                        hi, the plugin works fine for 480 id but for unique steam ID .. Multiplayer is not working... cannot find server to be more specific .. pls help?

                        Comment


                          Originally posted by RaviTeja1212 View Post
                          hi, the plugin works fine for 480 id but for unique steam ID .. Multiplayer is not working... cannot find server to be more specific .. pls help?
                          App id doesn't effect how the engines subsystems work and the plugin doesn't deal with the app id. You must have something misconfigured or your app id isn't correctly set if it is a shipping build.


                          Consider supporting me on patreon

                          My Open source tools and plugins
                          Advanced Sessions Plugin
                          VR Expansion Plugin

                          Comment


                            ok .. i didn't tried to modify any nodes. I used your plugin like the way in video .. it worked with 480 id .. we connected and played the game. So, you are saying maybe fault is on the side of steam ID (configuring the unique ID and packages)?
                            video link : https://www.youtube.com/watch?v=1gs9Q63VrQg

                            Comment


                              Thanks For Helping!!!!!

                              Comment


                                Thanks, I used open ip address always works good ,but find sessions always returns 0 results,dose anyone can help me ?

                                Comment

                                Working...
                                X