Announcement

Collapse
No announcement yet.

UE4Duino - Arduino to UE4 plugin Release!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unfortunately it's still not working. I tried again all version. Same with your project:

    The following modules are missing or build with a different engine version:

    UE4Editor-UE4DUINO.dll

    Would you like to rebuild them now?


    Error: ProjectTitle could not be compliled. Try rebuilding from source manually.

    Strange thing is, I can see you project under "my projects" with a 4.11 tag on it.

    Comment


      my project wouldn't require a plugin module,

      Comment


        even by deteting binary and intermediate of the plugin, he must regenerate the solution, so delete that and please right click on your project and regenerate all

        Comment


          Aron, after step 5 make a right click on your .uproject file and hit "generate visual studio project files".

          Comment


            Hello

            Hello everyone

            This plugin has a big problem I have not solved .. this plugin does not work if you can not package the final project ..

            Click image for larger version

Name:	Capture1.PNG
Views:	2
Size:	6.1 KB
ID:	1112105

            I wonder if anyone has managed to package your project successfully.

            is that Velocityx is working on it, maybe someone else can support their contribution.

            Comment


              Originally posted by Appsite GmbH View Post
              Aron, after step 5 make a right click on your .uproject file and hit "generate visual studio project files".
              Awesome! Thanks!

              I had to solve two issues: Windows SDK 8.1 was missing and Common Tools for Visual C++ 2015 was also not installed. After adding these components it was possible to "generate visual studio project files" and step 6 and 7 worked.

              Now Windows 10 64bit with Unreal 4.12 and UE4Duino_4_10 is running.

              Thanks again.

              Comment


                Hello [MENTION=486358]AronBaron[/MENTION]
                You tried to package your project using UE4Duino?
                It works well?

                I do not know anyone who has managed to package the proeycto and well-functioning UE4Duino
                If you managed to solve this, could you tell us how you did it?


                Thanks..

                Comment


                  Hi, Is there a version of this plugin that is compatible with UE4 v 4.12.5. Thanks!

                  Comment


                    Hi,

                    no sorry. I never tried to package my project. I only got the plugin running.

                    Comment


                      Originally posted by KaranMonster View Post
                      Hi, Is there a version of this plugin that is compatible with UE4 v 4.12.5. Thanks!
                      You can use plugin version 4_10 and do some manual modifications steps, see page 6 of this thread. I couldn't find a version that worked with 4.12 right away .

                      Comment


                        ok i got my microcontroller from the mail today,i'll start doing stuff for it tommorow

                        Comment


                          Hello [MENTION=4260]Velocityx[/MENTION]

                          I hope that you achieve solve this problem ..

                          The ideal is to compile the game using this plugin.

                          I'm not a programmer but if you need help with something, I will gladly'm willing to Collaborart ..

                          Comment


                            [MENTION=4260]Velocityx[/MENTION] what does the "f**ck serial" node do?

                            Comment


                              i had issues getting the code to work because the old one worked cause it got itself slow enought for the buffer not to empty before it got filled,so i was wondering why it didn't work for me so i made a function to pull the buffer on command amd thats how i found out i needed to use a function that the plugin didn't have because it was so slower,basically that node is just a debug node,but all my debug stuff is normally curse words XD

                              Comment


                                Originally posted by Stupzow View Post
                                Hello guys,
                                I recompiled UE4Duino for 4.12Preview and it works.
                                So here is the short instruction how to do it by yourself:
                                1. Create new project in UE4.12
                                2. Add new C++ class (None->next)
                                3. Save project
                                4. Close it
                                5. Create folder "Plugins" in the project folder and put here UE4Duino plugin
                                6. Open again your project and UE will ask you to recomplile UE4Duino plugin - you should press YES.
                                7. When recompilation will be done, you can close UE and copy UE4Duino from that project to other project. It will work.

                                I'm sure this method is useful with UE4.11.

                                Hope it will be helpful
                                Wchich plugin version i tried with 4.10 but didn't recompile

                                Comment

                                Working...
                                X