Announcement

Collapse
No announcement yet.

UE4Duino - Arduino to UE4 plugin Release!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi all,

    first of all, it looks like a greate plugin, I am searching for something like this for 2 months. I have the same Problem, that I could not receive enything, but maybe it is because of win10. I have tryed with UE4Duin-versieGidi.zip, but still no input.

    Could someone give me a hint in wich direction to go?

    thanks!

    Comment


      Gang,

      The place to start here is to really take a lot of time and read through this thread. You have to understand that this plugin is still in development. I highly suggest that you pick an earlier version of the plugin and run it on an older build of UE4 i.e. 4.9 - for windows 10 if you are experiencing problems. The plugin doesn't package yet and cutting edge engine builds aren't going to really matter when you are playing around with this.

      As far as learning to code with this plugin and where to start - IMO you should be trying to use the plugin at first to turn on and off a light on your board. That is the equivalent of "Hello World" in programming. Plenty of examples of that on this thread. If you do have a problem your code - I also suggest you post both your blueprint and the C Arduino code for others to look at.

      @JVR1 - Look at other blueprints for your connection in event start. It looks to me yours is going to print to Serial Print Ready even if your aren't connected. You need a branch like other blueprints on here show. You should tell us what version of the plugin and OS you are using, as well as provide your C code. At least someone would be able to recreate it and pinpoint your problems that way. You provided very little info and I would say your BP is shaking to begin with i.e you need branches - separate out your read (don't include write(what are you writing anyway?)) add lots of logging.

      Good lucks peeps!
      Indie Dev @http://www.numicus.com - Click to download Mac's Trophy Trout Video Game Demo

      Comment


        Hi guys, I need to know something. IS IT POSSIBLE TO PACK THIS INTO A GAME?

        I'm working for a company right now that wants me to make some custom controllers. Turns out I've finished the job only now I can't actually package the build.

        IS IT POSSIBLE TO TRULY USE THIS FOR PUBLISHING? Or is this for experiments only? What's the game plan here?

        How can I build this game?

        Does anyone know of an alternative way to build cheap custom controllers for the unreal engine?

        Am I really stuck here?

        It doesn't matter what version of the engine this works on


        IS THERE A ENGINE / PLUGIN combo that can actually be used in production??

        I need help immediately, thank you.

        Comment


          [MENTION=302341]AndreDoumad[/MENTION] - I am sorry to say that at the moment packaging isn't working with this plugin. I have been trying to find time to look into it, but have been busy with regular work.

          I will let you know if there is any change as soon as I get time to get it working...it has been mentioned several times in the thread that it has packaging problems, but I am really sorry that you are stuck after getting your project to work with the plugin.
          http://www.fusionlabz.com

          Comment


            Answer by plangton to AndreDoumad in another thread TROUBLE WITH ARDUINO and PLUGINS in general!:
            Originally posted by plangton View Post
            in case you use a plugin that does not give you the source file you cannot pack your game neither use the C++ version of ue4 projects.
            it is an engine limitation and not yet resolved

            Comment


              Trying this plugin with UE4.9/UE4.10, win7/win10, real com ports and virtual com ports. Result is the same - sending from engine is Ok and receiving isnt Ok =)

              I think engine cant start thread with read functions properly. See the log msg above from UE4.10 on win10.



              LogTemp: THREAD STARTED!!
              LogTemp: SERIAL PORT OPENED!!
              PIE: Info Play in editor start time for /Game/ThirdPersonBP/Maps/UEDPIE_0_ThirdPersonExampleMap -0.195
              LogBlueprintUserMessages: Late PlayInEditor Detection: Level '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap:PersistentLevel' has LevelScriptBlueprint '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap:PersistentLevel.ThirdPersonExampleMap' with GeneratedClass '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap_C' with ClassGeneratedBy '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap:PersistentLevel.ThirdPersonExampleMap'
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//ThreadTest///Thread_12e8_0///####STATCAT_Advanced#### old //STATGROUP_Threads//ThreadTest///Thread_3e0_0///####STATCAT_Advanced####
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              etc...
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: [BP_GameMode_C_4]
              LogBlueprintUserMessages: Early EndPlayMap Detection: Level '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap:PersistentLevel' has LevelScriptBlueprint '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap:PersistentLevel.ThirdPersonExampleMap' with GeneratedClass '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap_C' with ClassGeneratedBy '/Game/ThirdPersonBP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap:PersistentLevel.ThirdPersonExampleMap'
              LogTemp: THREAD CLOSED!!
              LogTemp: SERIAL PORT CLOSED!!
              *there is no warning Warning: MetaData mismatch. on UE4.9, but still have only one side data transfer...

              ps. im using USB-TTL conventers and radio modules. One is on my notebook and another is on my PC with engine. Communication working good in comport terminals.

              What solutions for this problem can i try? Maybe windows7 and win10 on my PC was bad and something bloked it?
              Last edited by progressive; 03-05-2016, 03:27 PM.

              Comment


                Hi [MENTION=34167]grizly32[/MENTION] ,

                Thanks for the update!

                Could you please help me to take UE4Duino over to MacOS or give me some tricks on how to do it? I appreciate it very much. :-)

                Best,

                Mike.

                Comment


                  The Version of plugin to Unreal 4.10 not work in windows 10. Connect to board but no receive the data. Someone else is having this problem?

                  Comment


                    Originally posted by AndreDoumad View Post
                    Hi guys, I need to know something. IS IT POSSIBLE TO PACK THIS INTO A GAME?

                    I'm working for a company right now that wants me to make some custom controllers. Turns out I've finished the job only now I can't actually package the build.

                    IS IT POSSIBLE TO TRULY USE THIS FOR PUBLISHING? Or is this for experiments only? What's the game plan here?

                    How can I build this game?

                    Does anyone know of an alternative way to build cheap custom controllers for the unreal engine?

                    Am I really stuck here?

                    It doesn't matter what version of the engine this works on


                    IS THERE A ENGINE / PLUGIN combo that can actually be used in production??

                    I need help immediately, thank you.
                    AndreDoumad, I have the same problem now! It seems that the project can't be packed into a game. I use Unreal Engine 4.10.4. Have you solved the problem?

                    Comment


                      Hello everyone!
                      I'm new to Arduino and I have a little trouble using this Plugin.
                      My Arduino sends data every second (for testing a single 1), which gets displayed when you open the seriel monitor in the Arduino IDE.
                      When I open Unreal it says that the Serial Port is open, but the ReadSerial Node seems not to receive data.
                      Click image for larger version

Name:	blueprints.jpg
Views:	1
Size:	85.8 KB
ID:	1103247
                      This is my level blueprint, I use win10 by the way

                      Thanks, tjung

                      Comment


                        Hello everyone,
                        Tjung, I have the same problem. Looks like port is open but dont receive any data:
                        Click image for larger version

Name:	UE4DuinoDontRead.PNG
Views:	1
Size:	172.9 KB
ID:	1103737

                        Comment


                          I would suggest trying to use an event other than the "Event Tick" to try to call for data and see if you have any. I had issues with event tick and instead used the forward movement event to get the code to work. Perhaps something similar just to see if the data is coming in will work for you. Additionally is the "tx" led on your arduino on when you are running your game?

                          - John

                          Comment


                            Hi everyone!

                            The issue was really funny.
                            Analog pins numbers on my Arduino UNO begins with A0,A1,A2 and so on. So in plugin I set Port Num 2 and got no data at all, moreover, I could open serial monitor or plotter in ArduinoIDE during running UE project.
                            Then I realized port number 2 wasn't open, so I set Port Number 3 in UE4Duino and it begin receive data! So in UE4Duino port numbers starts with 1 not 0 like in Arduino.

                            Here is screenshot:
                            Click image for larger version

Name:	UE4DuinoReadWorks.PNG
Views:	1
Size:	186.8 KB
ID:	1103883

                            [MENTION=77505]John Michael[/MENTION] thank you for your quick response. I tried your advices but the problem was not in Event Tick. Tx led is blinking on my arduino.

                            I really hope that it will be helpfull for somebody, because UE4Duino works fine and it is pretty cool plugin.
                            [MENTION=34167]grizly32[/MENTION] thanks for sharing your work. Please mark this moment in your tutorial if you will do it. Also the plugin is not compatible with UE 4.11. If you will have time, would you please fix it?? Thank you in advance.

                            Thanks!
                            Last edited by Stupzow; 04-05-2016, 01:58 PM.

                            Comment


                              [MENTION=333220]Stupzow[/MENTION] for your future reference as well as the future reference of anyone using this plugin, the Port Number is not referring to the Analog input port on your board, that port should be called by your Arduino code. The port number this plugin refers to is the serial port of your computer. In order to know which port your arduino is being seen on you will need to follow: Windows Start Menu -> Control Panel -> Hardware and Sound -> Device Manager -> "Ports" and the COM number is the port you are transmitting data over.

                              My experience with UE4duino is that this COM Port needs to have a Port number that is a single digit or it will not be able to open the port. This is important because from time to time your computer will reassign the COM Port numbers. Maybe [MENTION=34167]grizly32[/MENTION] may have more insight as to why this is the case.

                              - John

                              Comment


                                [MENTION=77505]John Michael[/MENTION] thanks for explanation, now I understand. So it seems I was lucky to found port I needed

                                But how can I divide data in UE from 2 sensor connected to one Arduino board?
                                Last edited by Stupzow; 04-05-2016, 04:40 PM.

                                Comment

                                Working...
                                X