Announcement

Collapse
No announcement yet.

Learning Templates [Blueprint Power]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    @adam.tarr57 , I don't see the possibility to have to duplicated tile , the for loop is creating tiles from top left and stops when it reach the tile (size*size) - 2
    Website [ LINK ]
    Twitter [ LINK ]
    Support ! [ LINK ]

    Comment


      Originally posted by Mhousse1247 View Post
      @adam.tarr57 , I don't see the possibility to have to duplicated tile , the for loop is creating tiles from top left and stops when it reach the tile (size*size) - 2
      It is super weird. On my laptop it duplicates the top left tile but on another computer it doesn't.

      Comment


        New Update :
        - Blob Physics Example


        Website [ LINK ]
        Twitter [ LINK ]
        Support ! [ LINK ]

        Comment


          Mhousse1247, you`re a genius! Thanks for your work! I love your Kart Physics project! Please, answer a question about it.
          If I want to add shock absorbers to your kart, what`s the best way to do this?

          Comment


            Originally posted by marc0s View Post
            Mhousse1247, you`re a genius! Thanks for your work! I love your Kart Physics project! Please, answer a question about it.
            If I want to add shock absorbers to your kart, what`s the best way to do this?
            You can use Morph or RelativeScale for that , "Last Frame Ratios" contains values between 0 & 1 for each wheel , you can find an use of it in "Update Wheels Position" function
            Website [ LINK ]
            Twitter [ LINK ]
            Support ! [ LINK ]

            Comment


              Originally posted by L1K1
              I am trying to access the website, It worked previously on older versions of Chrome but lately I cannot access the website it is always stuck on the loading icon. I tried using different browsers - Firefox, Edge, IE but all of them doesn't load the webpage past the loading icon.
              I just checked it in my old phone browser (mobile & desktop previews) , in windows in many versions of (firefox ,ie ,chrome ) , and I didn't hot any issue !
              Website [ LINK ]
              Twitter [ LINK ]
              Support ! [ LINK ]

              Comment


                Super useful examples. Some **** snappy updating too. A lot of the stuff I saw was either 4.17 or 4.18. Any chance you could add descriptions to some of the examples on the site? I could only gather whatever info I could from the name of the project etc. Here on the forum we have the gifs and I saw a couple of the examples for AI had youtube videos.

                Comment


                  This is an awesome collection of templates and projects - possibly the best yet for learning. Thank you so much.

                  Comment


                    Can parts of these templates or their assets be freely adapted for our own projects? If yes, what's the license? Is the license CC0 (public domain) or something more restrictive? Thank you.

                    Comment


                      These are fantastic! Thanks for offering them to the community.

                      I've been playing around with the Space Invaders one and I'm stuck trying to remove all the aliens (and protectors) after a game over event. Having them in the background makes it harder to see the high score initials input I've added, plus any that are left over stick around for the next game so theres even more you have to shoot.

                      Does anyone have any idea why a simple Get All Actors with a Destroy isn't working? (pictured)
                      I even put a destroy function into the alien BP itself and called that from MainGameActor and they still remain on screen.

                      Comment


                        aha! Thx for bumping it up! I'll definetly check that out !
                        WIP ShootOut - 3rdPerson ARPG

                        Comment


                          Just to update in case anyone else was having the same issue I was. The Blueprints in my image were working fine, it's just that there's code in the template that will automatically set a new bunch of aliens once all the other ones were destroyed (to set the next 'level'), so destroying them all the way I had been was basically resetting the level too. I added a branch to check a game over bool before setting the aliens back and it worked.

                          Comment


                            Originally posted by GraphicsMode View Post
                            Just to update in case anyone else was having the same issue I was. The Blueprints in my image were working fine, it's just that there's code in the template that will automatically set a new bunch of aliens once all the other ones were destroyed (to set the next 'level'), so destroying them all the way I had been was basically resetting the level too. I added a branch to check a game over bool before setting the aliens back and it worked.
                            Good solution I'm kinda kicking myself now for not adding a bunch of checks against the state of my game lol. Looks like I need to start adding stuff to track what is happening a little better.

                            Comment

                            Working...
                            X