Announcement

Collapse
No announcement yet.

Alflakky's Camera styles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    and why does Skeletal Meshes not clickable?

    Leave a comment:


  • replied
    Originally posted by AlFlakky View Post
    There is no such functionality. You must add it by ur own.

    Add an array of objects, and Onclink, perform a search inside that array for pressed object. If object was found, do not move the camera.
    sorry, but i can't do this((( can u show me the blueprint example? many thanks!
    Last edited by aekazmin; 07-11-2017, 09:01 AM.

    Leave a comment:


  • replied
    Originally posted by AlFlakky View Post
    There is no such functionality. You must add it by ur own.

    Add an array of objects, and Onclink, perform a search inside that array for pressed object. If object was found, do not move the camera.
    thank you!

    Leave a comment:


  • replied
    Originally posted by aekazmin View Post
    how can i exlude some objects from zooming by click? thanks!
    There is no such functionality. You must add it by ur own.

    Add an array of objects, and Onclink, perform a search inside that array for pressed object. If object was found, do not move the camera.

    Leave a comment:


  • replied
    how can i exlude some objects from zooming by click? thanks!

    Leave a comment:


  • replied
    Thank you very much!... Is there a way to add "pinch to zoom" option for mobiles? can I get any BP guide?

    and when I'm clicking the object to focus, there is an error message "PIE:Error: Error Blueprint Runtime Error: Accessed None trying to read property FocusedItem from function: 'ExecuteUbergraph_Cam' from node: SetActorLocation in graph: EventGraph in object: Cam with description: Accessed None trying to read property FocusedItem".

    Leave a comment:


  • replied
    Thank you! This blueprint really helpful.

    Leave a comment:


  • replied
    Oh, I was using the Set View Target with Blend. Using the Possess function seems to allow the cameras to work. Thanks!

    Leave a comment:


  • replied
    Originally posted by DMHokie View Post
    This is exactly what I needed! I have a couple cameras in my scene that I want to toggle to. I have one to walk around the scene, then I want to toggle to this one to spin 360 around the exterior. But when I toggle to this camera, I lose my control to spin around. The only way it will work is if I autopossess this camera. How do I set up the controller to be able to spin around after toggling?
    Hello. How do you change cameras? Are you using "possess" function?

    Leave a comment:


  • replied
    Nice work. This makes things a lot easier and gives some good consistency.

    Leave a comment:


  • replied
    This is exactly what I needed! I have a couple cameras in my scene that I want to toggle to. I have one to walk around the scene, then I want to toggle to this one to spin 360 around the exterior. But when I toggle to this camera, I lose my control to spin around. The only way it will work is if I autopossess this camera. How do I set up the controller to be able to spin around after toggling?

    Leave a comment:


  • replied
    Is anyone else having problems downloading these assets? I click on download and nothing happens. I've even created a Yandex.Disk account, copied the assets to my account and still can't download them. Anyone else?

    Leave a comment:


  • replied
    [MENTION=25310]AlFlakky[/MENTION] Thanks so much for this resource, its awesome. Could you answer a couple of queries I have though as I've not blueprinted before.

    1) What aspects of the blueprint would lock the Z axis so the camera can only be moved side to side?
    2) Is there a way of enabling a 'slide' sort of motion, where the camera would slowly come to a stop when you release the mouse. Does that make sense?

    Thanks again!

    Leave a comment:


  • replied
    AlFlakky, this is great!! - Thanks for posting! I do hope you are still keeping an eye on this thread!

    I have multiple cameras in my Level. I switch between them via the Level Blueprint "set view target with blend". When using your Cam in my level, and switching back from a level camera to your camera, it all goes smoothly until almost returned to your camera, then there is a slight 'jump' to final position. I can't for the life of me see how to fix this, no amount of blending works.. any help would be flippin fantastic! More info no probs!! Hope you can get back

    ** hahhh quick edit - think its something to do with different camera types/lenses - looking into that now

    *** right - just in case this helps anyone! I deleted the camera in the pawn blueprint and put in a Cine Camera. All works FAB!
    Last edited by Johnnyx; 08-02-2016, 05:48 AM.

    Leave a comment:


  • replied
    It just occurred to me that for my own super simple ArchViz needs there's an existing way of doing this: 1) put a regular Camera Actor under an Empty Actor; 2) put the Empty Actor [aka Null] at the point you want to orbit around; 3) keyframe and output the rotation frames. I just did this in Matinee, and now I'm going to work out how to do it in Sequencer.

    Leave a comment:

Working...
X