Announcement

Collapse
No announcement yet.

Blender to UE4 - Easily Export/Import Animations and Meshes! - Free Addon - Mr Mannequins Tools v1.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    Hope you are doing well.

    Any ETA on v1.3? Or you suspending development altogether?

    Comment


      #92
      Tom Jue I'm doing okay thanks, hope you're good too!

      Update 1.3 is actually ready to be uploaded, i'm just waiting for a chance to record the guides that are needed for it so i don't get 1000 people asking me the same questions lol

      My daughter isn't at school and is staying up really late at night at the moment so i get barely any time to record, i'll be making an attempt tonight though!

      Comment


        #93
        Awesome plugin!
        I tried getting into animation multiple times but it was always overwhelming.
        With this, I might actually do something

        This might be more of a Blender question than a Mr. Mannequin question, but since I'm new to animation and to Blender I can't rly tell

        I can make and export an animation using this plugin and it works great.
        I can import an animation exported from UE4, and I can see it in Blender, but I can't modify it.

        Rig control widgets (what are they called? ), don't seem to do anything. I can move / rotate them, but they don't have any effect on the animation.

        Probably something obvious I'm missing, but I would appreciate if someone could point me in a right direction and at least tell me what I should google

        EDIT:

        It seems turning off "Mute Default Constraints", makes controls work.. but it basically resets the animation / pose.
        Which makes sense. Imported animations don't use the rig so the rig would have to "IK-itself" into position.
        Do I understand that correctly?
        Can I automatically do that? Position control points in places where they would have to be for the animation to look the same?

        Anyway, end goal is to modify an existing animation, and if thats not possible to at least start with a pose extracted from the animation and hand animate from there. How can I do that?

        Last edited by Allshar; 04-04-2020, 09:03 PM.
        Fog of war / line of sight: MARKETPLACE - Support Thread

        Comment


          #94
          Allshar Thank you! I'm just about to start editing the recordings for latest update so it's going to be even more awesome very soon!

          About the rig controls... They get turned off on import in order to preserve the baked animation, you can workaround this with the switchable IK vs FK option by turning it on before importing then switching back to IK after, though there is no guarantee the rig controls and constraints will generate the same the positions as the imported animation

          I hope that helped a little!

          Comment


            #95
            Thx. It works. At least in my use case i had to make only minor adjustments.
            Fog of war / line of sight: MARKETPLACE - Support Thread

            Comment


              #96
              Update 1.3 is now live! There's armature mapping and retargeting and modular rigging and improved export for certain constraints... aaand there's a rigged bow and arrow for you to animate with!

              What are you waiting for? Go download it and so you can troll me for any bugs lol

              Comment


                #97
                Hey, I'm having the T-pose issue (at least I think I am). I've tried keeping the cursor outside of the frame min/max, but it's still happening to every one of my animations If needed, I can provide a .blend file to work from.

                Comment


                  #98
                  The T-pose bug is not back! People are just exporting with Auto-keying enabled it's not really a bug but i will be fixing it anyway so soon it won't matter, many people have had this problem.

                  Comment


                    #99
                    I love the tool, and was using the v1.1. Even had a video about how to use it on youtube! I just recently grabbed the v1.3, and having a few issues. Firstly, it's suuuuper laggy, compared to 1.3. Secondly, seems my left leg/foot is completely unresponsive. When selecting root, it elevates using g>z[upward], but doesn't seem to respond in reverse (while going lower than ground level, right knee bends, and everything on that side responds as intended, left sinks through the ground in perfect original pose.) Moving along Y or X shows that it's connected to roll control, but neither work. I don't -think- I've missed anything setting up, and I've cross referenced it with the right, and seems to be good... Any ideas on what it may be? Can post a video if needed.

                    Comment


                      I am using this tool and loving it for easily creating new animations with the mannequin rig. Huge thanks to Jim for creating this tool!

                      I have been using version 1.3 and I am running into some issues when trying to import animations for editing. When I import the fbx animations the rig reflects the animation, but the ik targets are broken. They don't follow the imported animation and I can't seem to use them animation movements.

                      Has anyone else run into this issue before? I am using the default import settings with location, rotation, and scale enabled. I am running into this issue on Blender 2.82 and 2.83.

                      Any help would be appreciated, thanks!

                      Comment


                        ironheart901 Same here. Most of the targets don't seem to do anything. Those that do break off pieces of the mesh (the hand just pulls off instead of doing IK). Jim Kroovy said he'd be unavailable for the next while until 1.4 comes out, so I think we're on our own.

                        Comment


                          ironheart901 aaaand MillhouseOne i'm still working on that, although even if you could easily have the IK targets follow the animation using them will 9 times out of 10 corrupt the baked FK movements of FBX also given most of the FBXs that get used with the add-on are keyed linearly on every frame i am needing to develop an intelligent algorithm to reduce their sample rate where possible, which isn't as easy at it doesn't actually sound

                          I'm not unavailable, i just can't support the code or replicate errors as my current build is heavily under construction right now.

                          (I've also been really slack with keeping forums and descriptions up to date, apologies)

                          Comment


                            *EDIT*

                            I sorted this issue out by unparenting the mesh, zeroed out (ctrl+a) all transforms. Then I deleted the rig and recreated it and then reassigned it.


                            *OLD*

                            So everything mostly goes well, I am able to align my mesh with the rig and then apply weights; however I have an issue with the root and exporting the skeletal mesh. When manually exporting I am able to export then import into Unreal Engine, however it gives the skeleton an extra root named "UE4_Mannequin_Skeleton" and thus makes it incompatible with mannequin animations.

                            When I use export mesh (Clicking on the mesh then the armature), I get this error:

                            Click image for larger version  Name:	issue.png Views:	0 Size:	164.6 KB ID:	1786753

                            Is there a solution to either manually exporting or using the Mr Mannequin Export Mesh option?


                            I am using a custom mesh
                            Last edited by FBTH; 07-12-2020, 03:49 AM.

                            Comment


                              Guys How add "extra" bone to this skeleton and export to UE4? I want add this bone for camera hold

                              Comment


                                Hi guys!
                                I don't seem to be able to use this tool, although I think I am doing things right. Maybe you can tell me what I am doing wrong.
                                I am using blender 2.90.1 with Mr Mannequins Tools 1.3.
                                I load the rig. I load the mesh. I select the rig (UE4_Mannequin_Skeleton). I save the blender file. In the tool I select "Export Meshes". I don't change anything else and I press Export FBX. The problem is that nothing happens. No file is created at all. Am I doing something wrong?

                                Comment

                                Working...
                                X