Announcement

Collapse
No announcement yet.

Launcher + Marketplace downloader for Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by Neomer View Post
    Hi all!

    There is my solution for marketplace suppot in ubuntu. It'll be same for any other linux distributions.

    1. Install and setup Wine.
    Wiki is here: https://wiki.winehq.org/Ubuntu

    2. Download winetricks

    3. Install required tools using winetricks
    Code:
    sudo apt install winbind
    winetricks corefonts
    sudo apt install cabextract
    3. Download latest official version of Launcher.
    4. Run installation using wine
    Code:
    wine msiexec /i <path-to-launche-installer>.msi
    5. After installation process finished first time run Launcher using wine with argument "SkipBuildPatchPrereq" to disable update process. Next time this argument isn't necessery anymore.
    Code:
    wine 'C:/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe' -SkipBuildPatchPrereq
    Launcher is ready now, but it will not find any projects you created. To fix that you should do next steps:
    1. Open "My Documents" folder of wine. Usually placed in "~/.wine/drive_c/users/<username-as-lunix>/My documents/".
    2. Open or create folder "Unreal projects". You shuold have something like that: "~/.wine/drive_c/users/kir/Мои документы/Unreal Projects".
    3. Make symbolic link to your project's folder.
    Code:
    cd "~/.wine/drive_c/users/kir/Мои документы/Unreal Projects"
    ln -s <path-to-your-ue4-project> ./<project-name>
    4. Restart Launcher.

    Now you can download any assets to your projects.
    Neomer, you're my true heroe, it works like a charm. It's not that I didn't appreciate the java versions;however, to be honest it brings a lot of troubles. The wine version, not Lutris is easy to follow and works.

    Comment


      #32
      I've tried the java version. Awesome work! But it gets stuck on 2fa, it opens a window with almost no size and i can't do anything.

      I've tried the wine version but it fails with this :
      Code:
      0024:fixme:dwmapi:DwmIsCompositionEnabled 01EAF464
      0024:fixme:win:RegisterTouchWindow (0x30060 00000000): stub
      LogWindows: Warning: Register touch input failed!
      0024:fixme:dwmapi:DwmSetWindowAttribute (00030060, 2, 01EAF48C, 4) stub
      0024:fixme:dwmapi:DwmGetCompositionTimingInfo (00000000 01EAE890)
      0024:fixme:explorerframe:taskbar_list_SetProgressValue iface 075A0E48, hwnd 00030060, ullCompleted fffffffffffffc18, ullTotal 3e8 stub!
      0024:fixme:explorerframe:taskbar_list_SetProgressState iface 075A0E48, hwnd 00030060, flags 2 stub!
      0024:fixme:seh:NtSetContextThread setting partial context (134c150c) not supported
      LogWindows: Error: === Critical error: ===
      LogWindows: Error:
      LogWindows: Error: Fatal error!
      LogWindows: Error:
      LogWindows: Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xdeaddead
      LogWindows: Error:
      LogWindows: Error: [Callstack] 0x00000000deaddead UnknownFunction []
      LogWindows: Error:
      0148:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
      0148:fixme:nls:get_dummy_preferred_ui_language (0x8 0164F58C 00000000 0164F588) returning a dummy value (current locale)
      0148:fixme:nls:get_dummy_preferred_ui_language (0x8 0164F58C 04129718 0164F588) returning a dummy value (current locale)
      0148:fixme:win:DisableProcessWindowsGhosting : stub
      0148:fixme:msctf:InputProcessorProfileMgr_GetActiveProfile (03C2E438)->({34745c63-b2f0-4784-8b67-5e12c8701a31} 0164FA7C)
      0148:fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
      0148:fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
      0148:fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)
      0148:fixme:dxgi:DXGID3D10CreateDevice Ignoring flags 0x1.
      0148:fixme:dwmapi:DwmIsCompositionEnabled 0164F93C
      0148:fixme:win:RegisterTouchWindow (0x30070 00000000): stub
      0148:err:ntdll:RtlpWaitForCriticalSection section 046D3834 "?" wait timed out in thread 0148, blocked by 017c, retrying (60 sec)
      0148:fixme:dwmapi:DwmSetWindowAttribute (00030070, 2, 0164F964, 4) stub
      0148:fixme:dwmapi:DwmGetCompositionTimingInfo (00000000 0164F4E0)
      01a0:fixme:d3d:state_linepattern_w Setting line patterns is not supported in OpenGL core contexts.
      01ac:err:service:process_send_command service protocol error - failed to read pipe r = 0 count = 0!

      Comment

      Working...
      X