Announcement

Collapse
No announcement yet.

Point Cloud Plugin

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Derek Hunter View Post
    Hi - thanks for the quick reply.



    - It works fine in the editor view.
    - It fails in PIE and separate window.
    - The cloud is statically loaded.
    - No custom material - I'm using "point, unlit, solid colour".
    - No changes to default setting that I can think of.
    - I've got about six or seven other plugins enabled.
    - I have not tried it in a fresh project.

    Based on what you said I will try the point-cloud plugin in a new project with all other plugins disabled and let you know what happens.
    Is the crash happening on 0.4? You mentioned solid color render mode, which was removed in 0.4
    Point Cloud Plugin: Project Website | Forum Thread | Roadmap

    If you need help: join me on Discord
    Please support me on Patreon if you enjoy my content

    Comment


      The crash is on 0.4.

      You are right. I did say "solid colour render mode" but thinking about it now I'm 99% certain I was using the new render mode.

      I will try on a new project today.

      This from a customer who is using 0.3: "The Point Cloud is fantastic!"

      Comment


        Originally posted by Derek Hunter View Post
        This from a customer who is using 0.3: "The Point Cloud is fantastic!"
        Happy to hear that
        Point Cloud Plugin: Project Website | Forum Thread | Roadmap

        If you need help: join me on Discord
        Please support me on Patreon if you enjoy my content

        Comment


          Derek Hunter Are you still experiencing crashes?
          Point Cloud Plugin: Project Website | Forum Thread | Roadmap

          If you need help: join me on Discord
          Please support me on Patreon if you enjoy my content

          Comment


            Point Cloud Plugin v0.4.2
            Release Notes

            Fixes
            • Fixed an issue with point clouds not loading at startup sometimes.
            • Changing Render Method at runtime should be much more robust now.
            Point Cloud Plugin: Project Website | Forum Thread | Roadmap

            If you need help: join me on Discord
            Please support me on Patreon if you enjoy my content

            Comment


              Hey,

              I have a feature request: the plugin currently only imports the RGB channels for the vertex colours. Would it be possible to get the 4th channel too (alpha)?

              It would be really useful to be able to have a fourth data channel in there, because it could be used to drive certain effects in the material. Just a thought.

              Thanks!

              Comment


                Originally posted by localstarlight View Post
                Hey,

                I have a feature request: the plugin currently only imports the RGB channels for the vertex colours. Would it be possible to get the 4th channel too (alpha)?

                It would be really useful to be able to have a fourth data channel in there, because it could be used to drive certain effects in the material. Just a thought.

                Thanks!
                Hi and thanks for the feedback!

                I'm experimenting with something that might end up using the alpha channel for other purpose but if not, then It's certainly possible and I will add it to the next release
                Point Cloud Plugin: Project Website | Forum Thread | Roadmap

                If you need help: join me on Discord
                Please support me on Patreon if you enjoy my content

                Comment


                  Awesome!

                  Or perhaps there is an alternative / better way to get different amounts of rotation for each point that you can think of?

                  Comment


                    Originally posted by localstarlight View Post
                    Awesome!

                    Or perhaps there is an alternative / better way to get different amounts of rotation for each point that you can think of?
                    Depends on what you're trying to achieve. How many axes of rotation? Random or specific rotation?
                    For random you can use things like world position / color component etc.
                    Point Cloud Plugin: Project Website | Forum Thread | Roadmap

                    If you need help: join me on Discord
                    Please support me on Patreon if you enjoy my content

                    Comment


                      Ah, you're right, I can actually achieve what I want by just using/combining the RGB colour channels - oops! Thanks!

                      Comment


                        Originally posted by localstarlight View Post
                        Ah, you're right, I can actually achieve what I want by just using/combining the RGB colour channels - oops! Thanks!
                        No problem Glad I could help.
                        Point Cloud Plugin: Project Website | Forum Thread | Roadmap

                        If you need help: join me on Discord
                        Please support me on Patreon if you enjoy my content

                        Comment


                          Hey guys just out of curiosity, what would you use to export a point cloud that has information stored in an alpha channel? This is in regard to localstarlight earlier question for phoboz.

                          Comment


                            Originally posted by J.Kimberley View Post
                            Hey guys just out of curiosity, what would you use to export a point cloud that has information stored in an alpha channel? This is in regard to localstarlight earlier question for phoboz.
                            I'm producing my point clouds with Houdini, so it's just a case of adding an alpha channel manually with whatever data I want. If you wanted to add an alpha channel to a point cloud you had in CSV, that would be pretty easy to do in Houdini too.

                            Comment


                              phoboz I'm occasionally getting errors when trying to build a project using this plugin. Here is the relevant bit from the log:

                              Code:
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: begin: stack for UAT
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: === Handled ensure: ===
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error:
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: Ensure condition failed: MyOwnerWorld [File:D:\Build\++UE4+Release-4.18+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\ActorComponent.cpp] [Line: 1030]
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: Stack:
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000D5A42786 UE4Editor-Core.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000D57E123A UE4Editor-Core.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000D57FB906 UE4Editor-Core.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000BB0B0F58 UE4Editor-Engine.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000AF2FA31A UE4Editor-PointCloudRuntime.dll!APointCloudActor::RebuildComponents() [c:\users\steve\documents\unreal projects\cosmosis\plugins\pointcloudplugin\source\pointcloudruntime\private\pointcloudactor.cpp:143]
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000AF2EFE2F UE4Editor-PointCloudRuntime.dll!TBaseUObjectMethodDelegateInstance<0,APointCloudActor,void __cdecl(void)>::ExecuteIfSafe() [c:\program files\epic games\ue_4.18\engine\source\runtime\core\public\delegates\delegateinstancesimpl.h:858]
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000AF2EB5BC UE4Editor-PointCloudRuntime.dll!TBaseMulticastDelegate<void>::Broadcast() [c:\program files\epic games\ue_4.18\engine\source\runtime\core\public\delegates\delegatesignatureimpl.inl:937]
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000AF2F9E4D UE4Editor-PointCloudRuntime.dll!UPointCloud::Rebuild() [c:\users\steve\documents\unreal projects\cosmosis\plugins\pointcloudplugin\source\pointcloudruntime\private\pointcloud.cpp:516]
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000BE32E8FD UE4Editor-CoreUObject.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000BE3EDABC UE4Editor-CoreUObject.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000BE405259 UE4Editor-CoreUObject.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000BE404774 UE4Editor-CoreUObject.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000B96568B3 UE4Editor-UnrealEd.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000B968D7BB UE4Editor-UnrealEd.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000B9527D61 UE4Editor-UnrealEd.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000B954F391 UE4Editor-UnrealEd.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x000000008844D25F UE4Editor-Cmd.exe!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x000000008844525A UE4Editor-Cmd.exe!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x00000000884454AA UE4Editor-Cmd.exe!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x0000000088452379 UE4Editor-Cmd.exe!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x0000000088453193 UE4Editor-Cmd.exe!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x0000000007823034 KERNEL32.DLL!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: [Callstack] 0x0000000008401551 ntdll.dll!UnknownFunction []
                              UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogOutputDevice: Error: end: stack for UAT
                              Any idea what's going on here?

                              If I remove the point cloud plugin (and all point clouds from the project), I don't get this error and the project packages fine.

                              Comment


                                Originally posted by localstarlight View Post
                                I'm occasionally getting errors when trying to build a project using this plugin. Here is the relevant bit from the log:

                                Any idea what's going on here?

                                If I remove the point cloud plugin (and all point clouds from the project), I don't get this error and the project packages fine.
                                I'll have a look tonight and see what causes it.
                                You mentioned it only happening occasionally - as in, the same project will sometimes build without problems or that only some projects suffer from it?

                                Some control questions:
                                - Are you using the v0.4.2?
                                - Is the issue reproducible in fresh, empty project with just the PC in question?
                                - Are you using binary version of 4.18?
                                - Is it a code or content-only project?

                                Thanks for the feedback
                                Point Cloud Plugin: Project Website | Forum Thread | Roadmap

                                If you need help: join me on Discord
                                Please support me on Patreon if you enjoy my content

                                Comment

                                Working...
                                X