Announcement

Collapse
No announcement yet.

gFur, free shell based fur plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by g0_Vi View Post
    Hi,

    Experiencing an issue where the fur will disappear randomly, and sometimes just by adjusting the camera angle. What could the issue be?

    Here is a reference

    https://imgur.com/a/E7xMjag
    What engine version are you using and which gFur, free or PRO?

    Comment


      Well, trying to launch the project on the Switch with gFur enabled just crashes the whole thing outright when trying to serialize some material.

      The problem is that the GFur skin vertex factory cannot be found at run-time. The reason it cannot be found is because the plug-in isn't being loaded. The plug-in isn't loaded, because it is not whitelisted in the plug-in descriptor file. Therefor, to fix this issue, simply add "Switch" to the list of whitelisted platforms in GFur.uplugin:

      Code:
      "WhitelistPlatforms": [
          "Win64",
          "Win32",
          "PS4", 
      "Switch",
      "XboxOne" ]
      Last edited by gmpreussner; 02-07-2020, 01:17 PM.
      Gerke Max Preussner | UE4 Programming Consultant

      Logo
      Follow me on Github | Goodreads | Linkedin | Pinterest | SlideShare | Twitter.
      Chat with me as gmpreussner on Discord.

      Comment


        Hello
        I cant find where i can adjust this, but am a beginner and might be misunderstood something
        I need my furry pillow to look like this
        Click image for larger version  Name:	photo_20200330_201432.jpg Views:	0 Size:	178.2 KB ID:	1739027

        But from the distance it looks like this:

        Click image for larger version  Name:	photo_20200330_201436.jpg Views:	0 Size:	63.2 KB ID:	1739028

        How can i change that?

        Comment


          Originally posted by Wolh View Post
          Hello
          I cant find where i can adjust this, but am a beginner and might be misunderstood something
          I need my furry pillow to look like this

          But from the distance it looks like this:

          Click image for larger version Name:	photo_20200330_201436.jpg Views:	0 Size:	63.2 KB ID:	1739028

          How can i change that?
          Hi, I had same issue. I found a way to get it right but I don't know if it's the most efficient way.

          In the texture of the FurPattern itself, there is a parameters unter "Level of Detail" and you can choose different options. When you select "NoMipmaps" , the fur remains nice from any distance in the active LOD.

          Click image for larger version  Name:	Fur_detail.PNG Views:	1 Size:	411.8 KB ID:	1739049

          Mabye there is a better option but I don't know.
          Last edited by TrygonLudo; 03-30-2020, 02:04 PM.

          Comment


            Originally posted by TrygonLudo View Post

            Hi, I had same issue. I found a way to get it right but I don't know if it's the most efficient way.

            In the texture of the FurPattern itself, there is a parameters unter "Level of Dertail" and you can choose different options. When you select "NoMipaps" , the fur remains nice from any disdtance in the active LOD.

            Mabye there is a better option but I don't know.
            oh, nice, at least some solution
            i'll try this, thank you!

            Comment


              Yo, GiM s.r.o. I can't help but notice that the plugin is now V3.

              But I can't see a changelog or anything anywhere. But I did see a review reply from you where you mention.
              "
              Thanks, btw we have submited update for 4.25, 24 and 23.
              for 23, 24 and 25 it fixes motion blur issues
              24 and 25 are actually upgrades to v3
              this adds alembic spline importer
              and adds gFur groom export to Epic's hair system (including generating dense strands)
              updated shaders will follow"

              So is that correct? Did you add the 'grooming for epic's hair system' feature I suggested? If that's the case, then awesome!

              Comment


                Hi, I have a question about subsurface scattering. I tried to add it, but when it comes to the shader material on the animal, it appears completely white when I switch from default Lit to Subsurface.

                The effect seems to work very well on the fur strands, just lacking the actual color. Any idea what could cause this? Thx

                Attached Files

                Comment

                Working...
                X