Announcement

Collapse
No announcement yet.

[FREE] Launchpad - A free, open-source UE4-compatible game launcher

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hey! Would this work with a direct Google Drive link?

    Leave a comment:


  • replied
    Anything similar for Android?

    Leave a comment:


  • replied
    This launcher is eant for 32 bit and i cant seem to change it to either any cpu or 64 bit only, is there a version of the files in 64 bit?

    Leave a comment:


  • replied
    While the question was answered on Discord, I'll put the answer here as well

    Launchpad is licensed under GPLv3. The clause mentioned is not legally binding, and just me asking you nicely not to try and sell the launcher as-is as a standalone product without an associated game.

    Leave a comment:


  • replied
    I'd like more information on where you state:

    > Launchpad is released under the GPLv3 license, which means you're free to use Launchpad in commercial projects and to build off of the code as much you want to. I have, however, added a gentleman's clause to it.

    That page mentions nothing about an addition clause but does state right at the top of the GPL explanation that modification of the GPL is not allowed (and honestly getting a legal department to approve a GPL thing is hard enough - even for my tiny company a _modified_ GPL is pretty much a non-starter where a regular GPL may be fine depending on use case)

    Leave a comment:


  • replied
    Here's the Discord link: https://discord.gg/0uvPPH2sOmcalj0K

    Leave a comment:


  • replied
    Really can't seem to find discord link sorry but it's well hidden or I am totally blind.
    Thanks a lot, getting the .net 4.6.2 targeting framework fix this error. I have a new one tho !

    Erreur CS4023 /platform:anycpu32bitpreferred can't be used with /t:exe, /t:winexe and /t:appcontainerexe Launchpad.Tests C:\Users\Mael\Desktop\Launchpad\Launchpad.Tests\CSC 1 Actif

    Leave a comment:


  • replied
    Originally posted by Elseware-Experience View Post
    Hey there, I have this weird issue when trying to build :

    Gravité Code Description Projet Fichier Ligne État de la suppression
    Erreur MSB3644 Les assemblys de référence pour le Framework ".NETFramework,Version=v4.6.2" sont introuvables. Pour résoudre ce problème, installez le SDK ou le Targeting Pack pour cette version de Framework, ou reciblez votre application vers une version du Framework pour laquelle le SDK ou le Targeting Pack est installé. Les assemblys seront résolus à partir du Global Assembly Cache (GAC) et seront utilisés à la place des assemblys de référence. C'est pourquoi votre assembly peut ne pas cibler correctement le Framework souhaité. Launchpad.Utilities C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets 1179

    Meaning it can't find netframework 4.6.2.. I have 4.7.2 and the sdk but well. Can't seem to fix it. Any clue ?
    Can't find your discord link either, should be in first post if you want ppl to find it
    Heya!

    You need the targeting pack for 4.6.2 installed, not just 4.7.2. The discord link is on the github page

    Leave a comment:


  • replied
    Hey there, I have this weird issue when trying to build :

    Gravité Code Description Projet Fichier Ligne État de la suppression
    Erreur MSB3644 Les assemblys de référence pour le Framework ".NETFramework,Version=v4.6.2" sont introuvables. Pour résoudre ce problème, installez le SDK ou le Targeting Pack pour cette version de Framework, ou reciblez votre application vers une version du Framework pour laquelle le SDK ou le Targeting Pack est installé. Les assemblys seront résolus à partir du Global Assembly Cache (GAC) et seront utilisés à la place des assemblys de référence. C'est pourquoi votre assembly peut ne pas cibler correctement le Framework souhaité. Launchpad.Utilities C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets 1179

    Meaning it can't find netframework 4.6.2.. I have 4.7.2 and the sdk but well. Can't seem to fix it. Any clue ?
    Can't find your discord link either, should be in first post if you want ppl to find it

    Leave a comment:


  • replied
    Hey there, got a weird bug don't know how to fix since I have the latest .net sdk and framework

    Gravité Code Description Projet Fichier Ligne État de la suppression
    Erreur MSB3644 Les assemblys de référence pour le Framework ".NETFramework,Version=v4.6.2" sont introuvables. Pour résoudre ce problème, installez le SDK ou le Targeting Pack pour cette version de Framework, ou reciblez votre application vers une version du Framework pour laquelle le SDK ou le Targeting Pack est installé. Les assemblys seront résolus à partir du Global Assembly Cache (GAC) et seront utilisés à la place des assemblys de référence. C'est pourquoi votre assembly peut ne pas cibler correctement le Framework souhaité. Launchpad.Utilities C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets 1179


    any clue ? Running on vs 2017. Can't find your discord either.

    Leave a comment:


  • replied
    Could u briefly explain how to make an auto update in windows?

    Leave a comment:


  • replied
    it works now
    Thank you

    Leave a comment:


  • replied
    Originally posted by Scardio View Post
    can not be compiled in VS2015
    Error:
    Some of the properties associated with the solution could not be read. ___\Launchpad\Launchpad.Common\Launchpad.Common.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Common\Launchpad.Common.csproj

    ...\Launchpad\Launchpad.Launcher\Launchpad.Launcher.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Launcher\Launchpad.Launcher.csproj

    ...\Launchpad\Launchpad.Utilities\Launchpad.Utilities.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Utilities\Launchpad.Utilities.csproj

    ...\Launchpad\Launchpad.Tests\Launchpad.Tests.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Tests\Launchpad.Tests.csproj


    Yes, you need VS2017 or JetBrains Rider to compile the launcher.

    Leave a comment:


  • replied
    can not be compiled in VS2015
    Error:
    Some of the properties associated with the solution could not be read. ___\Launchpad\Launchpad.Common\Launchpad.Common.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Common\Launchpad.Common.csproj

    ...\Launchpad\Launchpad.Launcher\Launchpad.Launcher.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Launcher\Launchpad.Launcher.csproj

    ...\Launchpad\Launchpad.Utilities\Launchpad.Utilities.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Utilities\Launchpad.Utilities.csproj

    ...\Launchpad\Launchpad.Tests\Launchpad.Tests.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns="http://schemas.microsoft.com/developer/msbuild/2003" to the <Project> element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. ...\Launchpad\Launchpad.Tests\Launchpad.Tests.csproj



    Leave a comment:


  • replied
    Hi Jargon, thanks for this work its really cool to see a tool like this as open source for the community.

    I've been working with the launcher on a Win64 platform , it appears that the Launchpad.Launcher is not generating a GameManifest.txt.old file thus preventing further installation of the game files.

    It could be that my build settings in visual studio are off, is there anything specific that needs to be done when building the project or have you seen an issue like this before?

    Thanks again for contributing your work.

    Leave a comment:

Working...
X