Announcement

Collapse
No announcement yet.

[FREE] Launchpad - A free, open-source UE4-compatible game launcher

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    When I try building, I get these errors:
    Click image for larger version

Name:	Screenshot_190.png
Views:	1
Size:	23.2 KB
ID:	1107479
    -Josh Steinhauer ~ HERO ~ My Blog ~ My Twitter

    Comment


      Originally posted by Warcabbit View Post
      Wasn't code opacity, it was someone with GPL V2 avoidance syndrome. Long story, but I'm okay with erring on the side of respect, you know?
      Yeah, I can understand that. GPL avoidance syndrome though, must make it hard to use computers x)
      Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
      Stalk me on the IRC: jarl or jargon
      Need a launcher for your games? Check out Launchpad

      Comment


        Originally posted by joshcamas View Post
        When I try building, I get these errors:
        [ATTACH=CONFIG]95639[/ATTACH]
        Looks like you haven't restored the nuget packages. Pull the latest, restore them and try again.
        Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
        Stalk me on the IRC: jarl or jargon
        Need a launcher for your games? Check out Launchpad

        Comment


          I just released a new version of Launchpad with logging capabilities which will make it far easier for me and you to debug any issues you might run into. Check "launchpad.log" for extended debugging information in the future The aforementioned hotloading of a game banner is also unofficially available on Mac and Linux, but it's not supported yet.
          Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
          Stalk me on the IRC: jarl or jargon
          Need a launcher for your games? Check out Launchpad

          Comment


            Originally posted by Jargon View Post
            Looks like you haven't restored the nuget packages. Pull the latest, restore them and try again.
            Hate to be annoying, but how do I exactly do this? I have next to no knowledge with building stuff like this.
            Does this have to do with the version of NGettext being out of date?

            EDIT: Figured it out! All I did was go to Project > Manage NuGet packages and updated NGettext! Thanks a hugeee bunch!!!
            Last edited by joshcamas; 06-01-2016, 05:38 PM.
            -Josh Steinhauer ~ HERO ~ My Blog ~ My Twitter

            Comment


              Originally posted by joshcamas View Post
              Hate to be annoying, but how do I exactly do this? I have next to no knowledge with building stuff like this.
              Does this have to do with the version of NGettext being out of date?

              EDIT: Figured it out! All I did was go to Project > Manage NuGet packages and updated NGettext! Thanks a hugeee bunch!!!
              Nice, there you go
              Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
              Stalk me on the IRC: jarl or jargon
              Need a launcher for your games? Check out Launchpad

              Comment


                hey, great work here :]
                i was wondering if the launcher can handle authentication ?

                anyway thanks for your work, real time saver

                Comment


                  Originally posted by nelther View Post
                  hey, great work here :]
                  i was wondering if the launcher can handle authentication ?

                  anyway thanks for your work, real time saver
                  Hey, sorry for the late reply. Forum didn't send an email as usual :P

                  Launchpad has no native support for individual user authentication, but it does support per-server authentication.
                  Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
                  Stalk me on the IRC: jarl or jargon
                  Need a launcher for your games? Check out Launchpad

                  Comment


                    I can't seem to get Launchpad.Utilities.exe to open on Win10 x64 at the moment. I downloaded it from here -> http://directorate.asuscomm.com/file...pad/Utilities/

                    Ideas?

                    The old version I have opens. I'm not sure what version it is but it's dated 09-10-2015 on my computer.
                    Last edited by Parvan; 07-13-2016, 02:29 AM.

                    Metahusk: A 501(c)(3) Creative Development Cooperative
                    Projects | Forums | Repositories | Nonprofit | Donate

                    Comment


                      Originally posted by Parvan View Post
                      I can't seem to get Launchpad.Utilities.exe to open on Win10 x64 at the moment. I downloaded it from here -> http://directorate.asuscomm.com/file...pad/Utilities/

                      Ideas?

                      The old version I have opens. I'm not sure what version it is but it's dated 09-10-2015 on my computer.
                      Hi Parvan,

                      The new version doesn't have a WinForms UI anymore, and requires you to have the GTK runtime Make sure you've the latest one installed.
                      Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
                      Stalk me on the IRC: jarl or jargon
                      Need a launcher for your games? Check out Launchpad

                      Comment


                        I have the following installed:
                        mono-4.4.1.0-gtksharp-2.12.38-win32-0.msi (Also 2.12.26)
                        gtk2-runtime-2.24.10-2012-10-10-ash.exe
                        gtk-sharp-2.12.38.msi

                        I have GTK2-Runtime installed. Should I try an older version?

                        I will try it on different computers later.

                        Thanks! Feel free to answer at your leisure. I'm not in a hurry. I know answering questions can get annoying. (Especially if I'm doing something silly.)

                        Metahusk: A 501(c)(3) Creative Development Cooperative
                        Projects | Forums | Repositories | Nonprofit | Donate

                        Comment


                          Originally posted by Parvan View Post
                          I have the following installed:
                          mono-4.4.1.0-gtksharp-2.12.38-win32-0.msi (Also 2.12.26)
                          gtk2-runtime-2.24.10-2012-10-10-ash.exe
                          gtk-sharp-2.12.38.msi

                          I have GTK2-Runtime installed. Should I try an older version?

                          I will try it on different computers later.

                          Thanks! Feel free to answer at your leisure. I'm not in a hurry. I know answering questions can get annoying. (Especially if I'm doing something silly.)
                          That would be the correct version - I'm not sure why it wouldn't be working. Perhaps having multiple versions installed at the same time would cause issues? Try removing all of them except the one you can get here: http://www.mono-project.com/download/#download-win
                          Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
                          Stalk me on the IRC: jarl or jargon
                          Need a launcher for your games? Check out Launchpad

                          Comment


                            Nice! That did the trick.

                            Installing only gtk-sharp-2.12.38.msi (aka "GTK# for .NET" for those browsing this post) worked. The issue was having more than one version installed at once.

                            Metahusk: A 501(c)(3) Creative Development Cooperative
                            Projects | Forums | Repositories | Nonprofit | Donate

                            Comment


                              Time for some important news!

                              The WinForms frontend for Launchpad will be deprecated in the next release, which means all users MUST have the GTK# runtime installed, or the launcher will not start. This shouldn't affect the majority of users, but some of you may not have installed the GTK# runtime for .NET.

                              As for what it means for the launcher, you're going to get more UI updates from here on out. Any fixes that previously only went into the Linux version will now apply to all platforms. I've gotten rid of the old graphics and gone for something a bit more lightweight, and the launcher now inherits the full theming support from GTK. In visuals, this means the launcher can go from this
                              Click image for larger version

Name:	Screenshot from 2016-07-28 13-46-48.png
Views:	1
Size:	153.2 KB
ID:	1112707
                              to this
                              Click image for larger version

Name:	Screenshot from 2016-07-28 13-47-41.png
Views:	1
Size:	150.0 KB
ID:	1112708
                              to high-contrast for the visually impaired like this
                              Click image for larger version

Name:	Screenshot from 2016-07-28 13-49-05.png
Views:	1
Size:	148.6 KB
ID:	1112709
                              or maybe something a bit more Windows 10?
                              Click image for larger version

Name:	Screenshot from 2016-07-28 13-53-49.png
Views:	1
Size:	149.6 KB
ID:	1112710

                              All by changing the loaded GTK theme!

                              If you don't have the GTK# runtime installed, download it here, install it and reboot your computer.
                              I currently don't have a release date for the next version, but I wanted to get this out there as early as possible so I didn't break any existing installations. You can expect me to roll it out mid-august, but I don't have a set date.
                              Talk to me on qTox: E8FF4A2B55C2C3A8BC7B60F729E8884BF95CEB4FE8906AE76F5941B08E73066AF562A26C280B
                              Stalk me on the IRC: jarl or jargon
                              Need a launcher for your games? Check out Launchpad

                              Comment


                                That's great news! Awesome

                                Metahusk: A 501(c)(3) Creative Development Cooperative
                                Projects | Forums | Repositories | Nonprofit | Donate

                                Comment

                                Working...
                                X